%%ItemTitle%%

IMS Customer Interfaces - Interface documentation
Introduction
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Customer Interfaces

release 1.5.5

release date 23.11.2017

(Dokument Version 3.9)

The interface system Customer Interfaces comprised all interfaces for the electronic communication between IMS group and customers or partners.

This interfaces will be permanently extended and updated to fulfil the wishes of our customers and partners. Please pay attention to the actual release number of this documentation.

This documentation is also available as an online documenation.

---> What's new? <---

Within this actual release the following interfaces are available:

Schnittstellenbezeichnung | current release | Description
WebCargo | . | IMS Web application providing tools as order history, offer overview, train information, ...
Customer Invoice | 1.0.9.6 | Transmission of invoices to customers of IMS GmbH
eRechnung | . | Receiving IMS invoices as signed PDF document within an email
Web Order | . | Entry of cutomer orders in the web application of IMS GmbH by the customer
Order Inbound | 3.1.3.0 | Transmission of orders to IMS GmbH
Status Outbound | 1.0.9.5 | Transmission of status information to customers of IMS GmbH

Show a note to our readers ...

We aim to fix errors in this document all the time. For this, we need your assistance. Please use the link "send feedback" in the page header to inform us about spelling or translation errors, any dead links and structure errors.

Thank you for your help.

See Also

Support
Versionshistorie
What's new?

©IMS CARGO Austria 2017. All rights reserved.


What's new?
See Also Send Feedback
Overview > What's new?

Glossary Item Box

Show All Show All
Hide All Hide All

Find here a list and some links to all the new topics in the manuell for each new release.

Release publishing date Description
1.5.5 23.11.2017

Cahnge of release number to V 1.0.9.6

(No changes happened to the XML/Field structure of these interfaces)

  • CI-CI Customer Invoices
1.5.4 22.11.2017

New customs procedure available:

  • Import: T1 + community goods (EU)
    Marks a container with partially customs goods

see Legend - customs procedures

1.5.3 29.08.2017

Extension of the Status Outbound messages (CI-SO)

  • 220 Road arrival
  • 221 Road departure
1.5.2 13.06.2017

Correction of a wrong node in <container/container/data>

  • The node <ContainerType> has been removed.
    (It was never part of the underlying XML schema)
  • The allowed codes for the node <HabisCode> have been reduced

Find the overhauled schema here:
IMS_CI_Schemas.IMS_CI_Order_V3_1_2_0 -Content Node "Data"
IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "Data"
1.5.0 14.04.2017

New release interface CI-OI V3.1.3.0 Order Inbound

  • new release 3.1.3.0
  • new nodes in node "Container\Data"
    CustomsDepartment, CustomsDepartmentname
    IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "Data"
    new codes for customs procedure
    Legend - customs procedures
  • new node "T1Consignee"
    IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "Container"
    IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "T1Consignee"
1.4.5 20.01.2017

New release interface CI-OI V3.1.2.0 Order Inbound

  • new release 3.1.2.0
  • new nodes in node "Container\Data"
    NetValue, NetValueCurrencyCode
    IMS_CI_Schemas.IMS_CI_Order_V3_1_2_0 -Content Node "Data"
  • new nodes in node "Container\Content"
    HS Code
    IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Content"

New release interface CI-SO Status Outbound

  • new release 1.0.9.5
    new field-code "invoiceID"
    new status-code "218 Invoice advice"
    IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5

See Also

Versionshistorie

Getting Started
Introduction


Versionshistorie
Send Feedback
Overview > Versionshistorie

Glossary Item Box

Show All Show All
Hide All Hide All

Release | publishing date | Description
1.5.5 | 23.11.2017 | Change of release numer for Customer_Invoices to V 1.0.9.6
1.5.4 | 22.11.2017 | new costums procedure (Import: T1 + community goods (EU))
1.5.3 | 29.08.2017 | Extension Status-Outbound CI-SO (220 Road arrival, 221 Road departure)
1.5.2 | 13.06.2017 | Corrections node <container/data>
1.5.1 | 19.04.2017 | Corrections (mostly typos, some links fixed)
1.5.0 | 14.04.2017 | New release interface CI-OI V3.1.3.0 Order Inbound
1.4.5 | 20.07.2017 | New release interface CI-OI V3.1.2.0 Order Inbound Extension interface CI-SO Status Outbound
1.4.4 | 11.09.2015 | Corrections interface description CI-OI V 3.1.1.0 / updated interface description CI-SU V1.0.9.5
1.4.3 | 26.01.2015 | Corrections Customer Invoices
1.4.2 | 01.07.2014 | Implementation additional nodes in CI-OI Segment RID
1.4.1 | 10.08.2013 | Implementation of the interfaces "Web order" and "Status Outbound"
1.3.3 | 01.03.2013 | Layout changes
1.3.2 | 23.11.2012 | Update Order Inbound XSD IMS_Schemas_Ext.V3_0_0_1
1.3.1 | 26.01.2012 | administrative changes
1.3.0 | 12.01.2012 | Implementation of B2B platform Tradeshift over CXML formatted XML files
1.2.0 | 12.01.2011 | Start implementation of the interface "order inbound"
1.1.3 | 03.01.2011 | Corrections of content
1.1.0 | 30.12.2010 | Official release
1.0.0 | 01.12.2010 | Development release of this interface documentation


Contact
Overview > Contact

Glossary Item Box

Show All Show All
Hide All Hide All

For detailed information or technical requests, please contact:

Ing. Roland Desort

IT-Manager

eMail: r.desort@imscargo.com

Telephone: +43 (0)1 20168-152
Fax: +43 (0)1 2902909-152

IMS CARGO Austria
Trillergasse 8
A-1210 Vienna


Subscription to Customer Interfaces
See Also Send Feedback
Overview > Subscription to Customer Interfaces

Glossary Item Box

Show All Show All
Hide All Hide All

We appreciate your interest in our electronic interfaces. To activate the interfaces we need some particular information. Please send us an email which contains the following particulars:

Show Subscription eInvoice

Necessary information:

Information Description
email address

IMS is sending the emails including the electronically signed invoice with the format PDF to this email address.

You will receive one confirmation email at this email address including a link for the proof of the used email address and activation of the interface.

Show Subscription Customer Invoice

Necessary information:

Information | Description
Choosen data format | please tell us, which data format you want to use - IMS_CI_CustomerInvoice_FF - IMS_CI_CustomerInvoice_XML - openTrans_Invoive_1_0 - Tradeshift *
email address | IMS is sending the interface file to this email address.
Contact person | Name, phone number and email address of the IT-related contact person.
email adresse (test environment) | The email address which is used during the test period.
*) The transmission is done between IMS and Tradeshift. The invoice is available to the customer in the Tradeshift web application.

Show Subscription Order Inbound

Necessary information:

Information Description
choosen transmission type

Übertragungsart | Description
FTP Download | Download of the files from your FTP server
Mail | Sending of the files as an attachment within an email

email-address

IMS is sending the Acknowledge messages to this email address.

(If you choose email as tramsmission type)

IP-address of your FTP client

The IP address of your FTP client accessing our FTP server.

(If you choose FTP as tramsnission type)

We need to know the IP address of your FTP client to whitelist it in our firewall. Unknown FTP clients will be blocked.

contact person

 Name, phone number and email address of the IT-related contact person.

Show Subscription Web Order

Necessary information:

Information | Description
Signed user agreement | Download PDF
List of authorized user | Please announce the name and email address of all users within your company, who are allowed to use Web Cargo and enter web orders in the IMS web application.
Web administrator | Announce the name and email address of the web administrator who will be able to maintain your company settings in the IMS Web Cargo web application.

Show Subscription Status Outbound

Necessary information:

Information Description
shoosen transmission type

Übertragungsart | Description
FTP upload | Upload of files to your FTP server
FTP download | Download of files from the FTP server of IMS
Mail delivery | Zustellung der Dateien per email an den Kunden durch IMS

email-address

IMS will send the files to this mail address

(if you choose Mail delivery)

IP address FTP Server

The IP address of your FTP server. Also the account data of the IMS account and the upload directory.

(If you choose FTP upload)
IP address FTP Client

The IP address of your FTP client

(If you choose TP download)

We need to know the IP address of your FTP client to whitelist it in our firewall. Unknown FTP clients will be blocked.

contact person

 Name, phone number and email address of the IT-related contact person.

Please send the information to:

Ing. Roland Desort

IT-Manager

email: r.desort@imscargo.com

phone: +43 (0)1 20168-152

fax: +43 (0)1 2902909-152

See Also

Tutorials
eInvoice
Interface Customer Invoice
Interface Order Inbound
Interface Status Outbound


WebCargo
See Also Send Feedback
WebCargo > WebCargo

Glossary Item Box

Show All Show All
Hide All Hide All

WebCargo contains all services, which IMS is providing within the IMS web application.

WebCargo contains the following functions:

  • Maintainance of the accounts of the users of your company for the IMS WebCargo application
  • Entry of online orders (see WebOrder)
  • Query your personal offers
  • Printing of your personal offers
  • Query of conditions about additional costs
  • Query your orders at IMS
  • Query of IMS trains and their capacity
  • Statistical querys
  • Query of open invoices

You can see a selection of screenshots here.

Please notice our terms of service.

To apply to use WebOrder please contact your key accounter at IMS .

See Also

Web order

Getting Started
Introduction


Web order
See Also Send Feedback
WebOrder > Web order

Glossary Item Box

Show All Show All
Hide All Hide All

As a part of our Service WebCargo IMS is offering its customers an web application to enter orders online.

This online order entry offers you the following functions:

  • Create new orders at IMS
  • Create drafts for periodic types of orders
  • Pre entry online orders for later completion and processing
  • Status overview about all your online orders

You can see a selection of screenshots here (Presentation WebCargo)

Please notice our terms of service.

To apply to use WebOrder please contact your key accounter at IMS .

See Also

WebCargo

Getting Started
Introduction


Interface Customer Invoice
Interface Customer Invoice > Interface Customer Invoice

Glossary Item Box

Show All Show All
Hide All Hide All

The interface Customer Invoice provides the transmission of invoices generated by IMS to the customer.

The following data-types are:

Schnittstellentype | Version | Freigabedatum | Description
IMS_CI_CustomerInvoice_FF | IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 | 23.11.2017 | Flatfile (.csv)
IMS_CI_CustomerInvoice_XML | IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 | 23.11.2017 | XML-file
openTrans_Invoive_1_0 *) | IMS_CI_Schemas.openTRANS_INVOICE_1_0_all_in_one_V1096 | 23.11.2017 | XML-file using the definitions of openTrans *)
Tradeshift | Zustellung via B2B Plattform Tradeshift | 01.02.2012 | **)

*) The format "openTrans" is a free XML-based data model for handling business processes under the lead of Fraunhofer-Institut für Arbeitswirtschaft und Organisation IAO.
The interface description and the XML schemata are available at this link.

Please take into account that we only support openTrans release 1.0.

**) Invoices and credit notes are transmitted by IMS using the B2B platform TradeShift of our customers.

You can use any of the above-listed interface types which fit to the possibilities of your IT environment. (please also see subscription to electronic invoice transmission)

We recommend a test period in which all invoices are marked as sent by the test environment. This trial period helps to make sure, that the interface is working well and the receiver can process all data.

To optimise the benefits of the electronic transmission of invoice data we suggest to also subscribe to the eInvoice system of IMS. You can find more information about eInvoice here.
Especially the contemporary delivery of eInvoice and the electronic invoice data accelerates the handling of invoices.
One interface file contains one and only one document. There are no multiple documents inside a single interface file.

Show technical spezifications

Specifikation | Description
filename

IMSAT_Cxxxxxxxx_Byyyyyyyyy_zz.eee

Placeholder | Content
xxxxxxxx | your customer number in IMS as an 8-digit number with leading zeros
yyyyyyyyy | the document number (e.g. invoice number) as a 9-digit number with leading zeros
zz

type of document

Document code | Type of document
AR | Invoice
GU | credit note
eee | extension (e.g. XML, CSV)

encoding | "utf-8"
eMail

The emails are sent as "plain-text" mails.

The sender is named CustomerInterfaceRobot@imscargo.com.

Please note that you have to configure your spam filter properly.

The subject of the email is "Customer Invoice Datensatz for invoice no. yyyyyyyyy".
receiver

The customer has to name a qualified email address. Please take care, that this email account will be checked periodically. Please announce changes of this email address to IMS.


IMS_CI_CustomerInvoice_FF
Interface Customer Invoice > Flatfile - IMS_CI_CustomerInvoice_FF > IMS_CI_CustomerInvoice_FF

Glossary Item Box

Show All Show All
Hide All Hide All

This interface delivers IMS invoices to the customers as a flat file with the extension ".CSV".

current release: 1.0.9.6

Show technical spezifications

Specifikation | Description
file extension | XML
date format | IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096
field delimiter | <Tab> (see ASCII-Tabelle)

For technical reasons, the email includes a second file in XML format, which contains the email-address of the receiver. This file can be ignored.

Show release history

Release | Release date | Description
1.0.9.6 | 22.11.2017 | Pure change of Version number No changes compared to Version 1.0.2.4
1.0.2.4 | 01.02.2012 | Implementation XCML (Tradeshift)
1.0.0 | 01.10.2010 | Release of the production-release

Show Schema

Column description for IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096

Show example

file | Description
IMS_CI_CustomerInvoice_V1096_Example File | CSV-Interfacefile with test data V 1.0.9.6
IMS_CI_CustomerInvoice_V1-0_Example File | CSV-Interfacefile with test data V 1.0.2.4

back


IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 - Colums description
Send Feedback
Interface Customer Invoice > Flatfile - IMS_CI_CustomerInvoice_FF > Column definition > IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 - Colums description

Glossary Item Box

Show All Show All
Hide All Hide All

Description der Spalten:

Nr. | Spalte | min | max | mand. | Format | Description
1 | CreationDate | 1 | 1 | ü | . | Technical data of the message
 |  | 1 | 1 | ü | . | Data of the message

Nr. Spalte min max mand.

Format

 Description
1 | CreationDate | 1 | 1 | ü | jjjj-mm-ddThh:nn:ss | date and time of the creation of the interface file
2 DocumentType 1 1 ü string(2)

type of the document (legend)
3 | InvoiceNo | 1 | 1 | ü | integer | document number (invoice number, credit note number, ...)
4 | InvoiceDate | 1 | 1 | ü | jjjj-mm-tt | date of the document (invoice date)
5 Test 1 1 ü integer

determination test-/production environment

Value | Description
0 | production environment
1 | test environment
6 | MailTechnicalResponse | 1 | 1 | ü | string | email-adress of IMS for requests concerning IT-issues
7 | IMSUID | 1 | 1 | ü | string | value-added tax odentification number of IMS
8 | ReceiverID | 1 | 1 | ü | integer | IMS-internal customer number of the invoice receiver
9 | ReceiverName1 | 1 | 1 | ü | string | name of the company of the invoice receiver
10 | ReceiverName2 | 1 | 1 | string | secondary name of the company of the invoice receiver
11 | ReceiverAdress1 | 1 | 1 | ü | string | street and house number of the adress of the company of the invoice receiver
12 | ReceiverAdress2 | 1 | 1 | string | extended adress informations of the company of the invoice receiver
13 | ReceiverZip | 1 | 1 | ü | string | ZIP-code of the company of the invoice receiver
14 | ReceiverTown | 1 | 1 | ü | string | town of the company of the invoice receiver
15 | ReceiverUID | 1 | 1 | ü | string | value-added tax odentification number of the invoice receiver
16 | DatePayment | 1 | 1 | ü | jjjj-mm-tt | payment target date
17 | LineNo | 1 | 1 | ü | integer | serial number of the position within the document
18 | IMSOrderID | 1 | 1 | ü | integer | order number of IMS (IMS Reference)
19 | CustomerOrderRef | 1 | 1 | string | Reference from the customer order
20 | CustomerOrderDate | 1 | 1 | jjjj-mm-tt | date of inbound of the customer order
21 | ServiceDateFrom | 1 | 1 | ü | jjjj-mm-tt | start date of service provision
22 | ServiceDateUntil | 1 | 1 | ü | jjjj-mm-tt | end date of service provision
23 | Sender | 1 | 1 | string | name, ZIP-Code and town of the sender
24 | Recipient | 1 | 1 | string | name, ZIP-Code and town of the recipient
25 | IMSContact | 1 | 1 | string | name of the user in charge for this document at IMS
26 | ShipName | 1 | 1 | string | name of the ship
27 | POL | 1 | 1 | string | country of destination
28 | POD | 1 | 1 | string | country of origin
29 | ETA | 1 | 1 | jjjj-mm-ttThh:nn:ss | closing date (shipping)
30 | OfferText | 1 | 1 | ü | string | Description of the underlying offer
31 | ContainerText | 1 | 1 | ü | string (13) | container number
32 | Scale | 1 | 1 | ü | string | scale Description
33 | Services | 1 | 1 | ü | string | invoice service(s)
34 | Quantity | 1 | 1 | ü | integer | quantity of invoiced service units
35 | NetValue | 1 | 1 | ü | decimal (9,2) | invoiced net value
36 | TaxValue | 1 | 1 | ü | decimal (9,2) | invoiced value-added tax value
37 | TaxPercent | 1 | 1 | ü | decimal(3,2) | value-added tax in percent
38 | Memo | 1 | 1 | string | notes/informations to this line
39 | Info | 1 | 1 | string | notes/informations to this line
40 | SumLineCount | 1 | 1 | ü | integer | number of lines in this invoice
41 | SumNetValue | 1 | 1 | ü | decimal (9,2) | grand total net value of this invoice
42 | SumTaxValue | 1 | 1 | ü | decimal (9,2) | grand total value-added tax of this invoice

legend

back to parent node


openTRANS_INVOICE_1_0
Interface Customer Invoice > XML - openTRANS_INVOICE > openTRANS_INVOICE_1_0

Glossary Item Box

Show All Show All
Hide All Hide All

This interface delivers invoices/credit notes created by IMS as an XML document using the format "openTrans 1.0" with the file extension ".XML"

actual release: 1.0.9.6

The data definition "openTrans" is a free available XML-based model supporting the handling of business processes under the administration of Fraunhofer-Institut für Arbeitswirtschaft und Organisation IAO. The interface and the needed XML-schemas can be received using this link.

Please note that we are using the interface definitions release 1.0. The new interface definition 2.0 is not supported by IMS yet.

IMS is using the subset "openTRANS_INVOICE_1_0" of the interface system openTrans with a few modifications as an "IMS subset". This is needed to deliver some necessary codes and formats. This documentation describes this IMS subset. Please use only the XML schema which you can find here at the end of this page.

Show technical specifications

specification | Description
file extension | XML
schema | IMS_CI_Schemas.openTRANS_INVOICE_1_0_all_in_one
targetnamespec | <ns0:INVOICE version="1.0" xmlns:ns0="http://www.opentrans.org/XMLSchema/1.0">

Show release history

release | release date | Description
1.0.9.6 | 23.11.2017 | Change release number to 1.0.9.6 (No changes happened to the XML structure)
1.0.2.4 | 12.01.2012 | Implementation CXML
1.0.0 | 01.10.2010 | release of production system

Show documentation XML schema

IMS_CI_Schemas.openTRANS_INVOICE_1_0_all_in_one_V1096

Show downloads / examples

File | Description
openTRANS_INVOICE_1_0_all_in_one File_V1096 | XML schema V 1.0.9.6
IMS_openTRANS_INVOICE_1_0_Example File_V1096 | XML-interface file with example data V 1.0.9.6
openTRANS_INVOICE_1_0_all_in_one File | XML schema
IMS_openTRANS_INVOICE_1_0_Example File | XML-interface file with example data

back


openTRANS_INVOICE_1_0_all_in_one - Node "INVOICE"
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Node "INVOICE"

Glossary Item Box

Show All Show All
Hide All Hide All

The XML-schema of the interface openTrans is a very complex aggregation of all XML-nodes. IMS is only using a small part of this nodes within the interfacesystem "Customer Invoice" (root-node "INVOICE"). Therefor this documentation only describes the used nodes.

Node min max mand. Format Description
Invoice 1 1 ü root node of the invoice-document

Attribute | Content
version | "1.0"

legend

back


openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE"
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "INVOICE":

Node/field | min | max | mand. | Format | Description
INVOICE_HEADER | 1 | 1 | ü |  | Headerinformations for this document
INVOICE_ITEM_LIST | 1 | 1 | ü |  | lines
INVOICE_SUMMARY | 1 | 1 | ü |  | grand total values

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_HEADER"
Send Feedback
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_HEADER"

Glossary Item Box

Show All Show All
Hide All Hide All

Contant of the node "INVOICE_HEADER":

Node | min | max | Pflicht | Format | Beschreibung
CONTROL_INFO | 1 | 1 | ü |  | technical information about this decument
INVOICE_INFO | 1 | 1 | ü |  | header informations about the document

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_ITEM_LIST"
Send Feedback
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_ITEM_LIST"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "INVOICE_ITEM_LIST":

Node | min | max | mand. | Format | Description
INVOICE_ITEM | 1 | 1 | ü |  | invoice line

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_SUMMARY"
Send Feedback
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_SUMMARY"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "INVOICE_SUMMARY":

Field | min | max | mand. | Format | Description
TOTAL_ITEM_NUM | 1 | 1 | ü | integer | count invoice lines
TOTAL_AMOUNT | 1 | 1 | ü | decimal (9,2) | grand total net value of the invoice
TOTAL_TAX_AMOUNT | 1 | 1 | ü | decimal (9,2) | grand total value-added tax of the invoice
TOTAL_GROS_AMOUNT | 1 | 1 | ü | decimal (9,2) | grand total gross value of the invoice

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "CONTROL_INFO"
Send Feedback
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "CONTROL_INFO"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "CONTROL_INFO":

Field | min | max | mand. | Format | Description
STOP_AUTOMATIC_PROCESSING | 1 | 1 |  | string | Determination test-/productionenvironment If this field is filled with text, the document is generated within the test environment of IMS . If this field is empty, it is a official decument (incoice) from the production environment of IMS . fixed text if the decument is from the test environment: "Testmodus! Bitte nicht in Produktionsumgebung überleiten"
GENERATOR_INFO | 1 | 1 | ü | string | informations about the document and the sender
GENERATION_DATE | 1 | 1 | ü | jjjj-mm-ttThh:nn:ss | date and tim eof the creation of this dicument

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_INFO"
Send Feedback
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_INFO"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "INVOICE_INFO":

Node/field min max mand.

Format

 Description
INVOICE_ID 1 1 ü integer

invoice number
INVOICE_DATE | 1 | 1 | ü | jjjj-mm-ttThh:mm:ss | invoice date
DELIVERY_DATE | 1 | 1 | ü | time period of service provision
BUYER_PARTY | 1 | 1 | ü | informations about the ordering customer
SUPPLIER_PARTY | 1 | 1 | ü | informations about supplier
INVOICE_PARTY | 1 | 1 | ü | informations about the invoice recipient
PRICE_CURRENCY | 1 | 1 | ü | string (3) | currency
TERMS_AND_CONDITIONS | 1 | 1 | string | Link to the "allgemeinen österreichischen Spediteurbedingungen (AÖSp)"
REMARK 1 n

string

Format:

"Zahlungsziel: jjjj-mm-tt"

payment target date

Attribute | Content
type | "invoice"

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_ITEM"
Send Feedback
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "INVOICE_ITEM"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "INVOICE_ITEM":

Node/Field min max mand.

Format

 Description
LINE_ITEM_ID | 1 | 1 | ü | integer | serial number of the line within this document
ARTICLE_ID | 1 | 1 | ü | Informations about the container and services
QUANTITY | 1 | 1 | ü | integer | quantity of invoiced service units
ORDER_UNIT | 1 | 1 | ü | string | fixed "ZZ"
ARTICLE_PRICE 1 1 ü

Informations about the price

attribute | Content
type | "net_customer"
ORDER_REFERENCE | 1 | 1 | ü | references from the cumstomer order
SUPPLIER_ORDER_REFERENCE | 1 | 1 | ü | IMS-references
REMARK 1 n

extended informations about the incoice line

attribute | Content | Text
type | "invoice" | name, ZIP-Code and town of the sender
type | "receiver" | name, ZIP-Code and town of the recipient
type | "PIC" | Nname of the user in charge for this document at IMS
type | "ship" | name of the ship
type | "POL" | country of destination
type | "POD" | country of origin
type | "ETA" | closing date (export) / arrivel date (import) Harbour
type | "relation" | Description of the underlying offer

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "ARTICLE_ID"
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "ARTICLE_ID"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "ARTICLE_ID":

Node/field | min | max | mand. | Format | Description
SUPPLIER_AID | 1 | 1 | ü | string (13) | Container number Format: "xxxx nnnnnn-n"
Description_SHORT | 1 | 1 | ü | string | scale Description
Description_LONG | 1 | 1 | ü | integer | invoice service(s)

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "ARTICLE_PRICE"
Send Feedback
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "ARTICLE_PRICE"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "ARTICLE_PRICE":

Knoten/Feld | min | max | mand. | Format | Description
PRICE_AMOUNT | 1 | 1 | ü | decimal (9,2) | prive of one service unit
PRICE_LINE_AMOUNT | 1 | 1 | ü | decimal (9,2) | net value of this invoice line
TAX | 1 | 1 | ü | decimal (9,2) | value-added tax as percent
TAX_AMOUNT | 1 | 1 | ü | decimal (9,2) | value-added tax value
PRICE_QUANTITY | 1 | 1 | ü | integer | number of invoiced service units

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "ORDER_REFERENCE"
Send Feedback
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "ORDER_REFERENCE"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "ORDER_REFERENCE":

Node/field | min | max | mand. | Format | Description
ORDER_ID | 1 | 1 | ü | string | order reference of the ordering customer
LINE_ITEM_ID | 1 | 1 | ü | integer | fixed "0"
ORDER_DATE | 1 | 1 | ü | jjjj-mm-ttT00:00:00.000 | inbound date of the order at IMS

legend

back to parent node


openTRANS_INVOICE_1_0_all_in_one - Content Node "SUPPLIER_ORDER_REFERENCE"
Send Feedback
Interface Customer Invoice > XML - openTRANS_INVOICE > XML Schemata > openTRANS_INVOICE_1_0_all_in_one - Content Node "SUPPLIER_ORDER_REFERENCE"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "SUPPLIER_ORDER_REFERENCE":

Node/field | min | max | mand. | Format | Description
SUPPLIER_ORDER_ID | 1 | 1 | ü | integer | IMS order reference
SUPPLIER_ORDER_ITEM_ID | 1 | 1 | ü | integer | fixed "0"

legend

back to parent node


IMS_CI_CustomerInvoice_XML
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > IMS_CI_CustomerInvoice_XML

Glossary Item Box

Show All Show All
Hide All Hide All

This interface delivers IMS invoices to the customers as an XML document with the extension ".XML"

current release: 1.0.9.6

Show technical spezifications

Specifikation | Description
file extension | XML
schema | IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096
targetnamespec | <ns0:Invoice xmlns:ns0=http://IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096>

Show release history

Release | Release date | Description
1.0.9.6 | 23.11.2017 | Correction IMS_CustomerInvoice2
1.0.2.4 | 01.02.2012 | Implementation of CXML (Tradeshift)
1.0.0 | 01.10.2010 | release of the production-release

Show documentation XML Schema

XML Schema for IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096

Show downloads / examples

file | Description
IMS_CI_CustomerInvoice2_V1096 File | XML Schema V 1.0.9.6
IMS_CI_CustomerInvoice2_V1096_Example File | XML-Interfacedatei mit Testdaten V 1.0.9.6
IMS_CI_CustomerInvoice2_V1024 File | XML Schema V 1.0.2.4 (outdated)
IMS_CI_CustomerInvoice2_V1024_Example File | XML-Interfacefile with test data V 1.0.2.4 (outdated)

back


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Summery"
Send Feedback
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemata > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Summery"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Summery":

Node/field | min | max | mand. | Format | Description
LineCount | 1 | 1 | ü | integer | number of lines in this invoice
NetValue | 1 | 1 | ü | decimal (9,2) | grand total net value of this invoice
TaxValue | 1 | 1 | ü | decimal (9,2) | grand total value-added tax of this invoice

legend

back to parent node


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Line"
Send Feedback
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemata > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Line"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Line":

Node/field | min | max | mand. | Format | Description
LineNo | 1 | 1 | ü | integer | serial number of the position within the document
IMSOrderID | 1 | 1 | ü | integer | order number of IMS (IMS Reference)
CustomerOrderRef | 1 | 1 |  | string | Reference from the customer order
CustomerOrderDate | 1 | 1 |  | jjjj-mm-tt | date of inbound of the customer order
ServiceDateFrom | 1 | 1 | ü | jjjj-mm-tt | start date of service provision
DerviceDateUntil | 1 | 1 | ü | jjjj-mm-tt | end date of service provision
Sender | 1 | 1 | ü | string | name, ZIP-Code and town of the sender
Recipient | 1 | 1 | ü | string | name, ZIP-Code and town of the recipient
IMSContact | 1 | 1 | ü | string | name of the user in charge for this document at IMS
ShipName | 0 | 1 |  | string | name of the ship
POL | 0 | 1 |  | string | country of destination
POD | 0 | 1 |  | string | country of origin
ETA | 0 | 1 |  | jjjj-mm-ttThh:nn:ss | closing date (export) / arrivel date (import) Harbour
OfferText | 1 | 1 | ü | string | Description of the underlying offer
ContainerText | 1 | 1 | ü | string (13) | container number Format: "xxxx nnnnnn-n"
Scale | 1 | 1 | ü | string | scale Description
Services | 1 | 1 | ü | string | invoiced service(s)
Quantity | 1 | 1 | ü | integer | quantity of invoiced service units
NetValue | 1 | 1 | ü | decimal (9,2) | invoiced net value
TaxValue | 1 | 1 | ü | decimal (9,2) | invoiced value-added tax value
TaxPercent | 1 | 1 | ü | decimal (3,2) | value-added tax in percent
Memo | 0 | 1 |  | string | notes/informations to this line
Info | 0 | 1 |  | string | notes/informations to this line

legend

back to parent node


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Content of Node "Lines"
Send Feedback
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemata > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Content of Node "Lines"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Lines":

Node | min | max | mand. | Format | Description
Line | 1 | n | ü |  | line of the invoice

legend

back to parent node


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Recipient"
Send Feedback
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemata > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Recipient"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Recipient":

Node/field | min | max | mand. | Format | Description
ID | 1 | 1 | ü | integer | IMS-internal customer number of the invoice receiver
Name1 | 1 | 1 | ü | string | name of the company of the invoice receiver
Name2 | 0 | 1 |  | string | secondary name of the company of the invoice receiver
Street1 | 1 | 1 | ü | string | street and house number of the adress of the company of the invoice receiver
Street2 | 0 | 1 |  | string | extended adress informations of the company of the invoice receiver
Zip | 1 | 1 | ü | string | ZIP-code of the company of the invoice receiver
Town | 1 | 1 | ü | string | town of the company of the invoice receiver
CountryCode | 1 | 1 | ü | string (2) | countrycondes (see list)
UID | 1 | 1 |  | string | value-added tax odentification number of the invoice receiver

legend

back to parent node


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Prefix"
Send Feedback
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemata > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Prefix"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Prefix":

Node/field min max mand.

Format

 Description
CreationDate | 1 | 1 | ü | jjjj-mm-ddThh:nn:ss | date and time of the creation of the document
Guid 1 1 ü string(2)

distinct GUID of this interface file
Test 1 1 ü integer

determination test-/production environment

Value | Description
0 | determination test-/production environment
1 | test environment
MailTechnicalResponse | 1 | 1 | ü | string | email-adress of IMS for requests concerning IT-issues
MailReceiver | 1 | 1 | ü | integer | email-adresse of the receiver of the document on the customers side

legend

back to parent node


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Header"
Send Feedback
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemata > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "Header"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Header":

Node/field | min | max | mand. | Format | Description
InvoiceData | 1 | 1 | ü |  | document data
Recipient | 1 | 1 | ü |  | informations about the recepient of the document (invoice receiver)

legend

back to parent node


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "InvoiceData"
Send Feedback
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemata > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096_- Content of Node "InvoiceData"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the "InvoiceData":

Node/field | min | max | mand. | Format | Description
DocumentType | 1 | 1 | ü | string (2) | type of the document (legend)
InvoiceNo | 1 | 1 | ü | integer | document number (invoice number, credit note number, ...)
InvoiceDate | 1 | 1 | ü | jjjj-mm-tt | date of the document (invoice date)
IMSUID | 1 | 1 | ü | string | value-added tax odentification number of IMS
DatePayment | 1 | 1 | ü | jjjj-mm-tt | payment target date

legend

back to parent node


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Content of Node "Invoice"
Send Feedback
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemata > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Content of Node "Invoice"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Invoice":

Knoten | min | max | Pflicht | Format | Beschreibung
Prefix | 1 | 1 | ü |  | technical informations for this document
Header | 1 | 1 | ü |  | header informations
Lines | 1 | 1 | ü |  | lines
Summery | 1 | 1 | ü |  | grand total values

legend

back to parent node


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Node "Invoice"
Send Feedback
Interface Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemata > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Node "Invoice"

Glossary Item Box

Show All Show All
Hide All Hide All

Node | min | max | mand. | Format | Description
Invoice | 1 | 1 | ü |  | root node for this interface data record

legend

back to parent node


Interface Order Inbound
See Also Send Feedback
Interface Order Inbound > Interface Order Inbound

Glossary Item Box

Show All Show All
Hide All Hide All

The interface Order Inbound supports the transmission of orders from the customer to IMS.

The interface system contains the following data schemas.

Interface type | current release | Date of release | Description
IMS_CI_Order | IMS_Schemas_Ext.PxB_CI_OI.V3130 | 14.04.2017 | XML-schema for order data
IMS_CI_ACK | IMS_Schemas.PxB_CI_ACK.V1-2-0-1 | 01.02.2011 | XML-schema for acknowledge data

To sign in for this interface see Application for electronic data exchange

To ensure the functionality fo a common interface we strongly recommend a test phase to check all the transmitted data without forward them to the production systems of IMS.

Show technically spezifications

Specification | Description
File name

CI_OI_3-1-3-0_xxxxxxxxxxx.XML

placeholder Content
xxxxxxxxxxx

unique identifier of this interface file, generated by the customer.

The name of the interface file has to be unique. Even if you are retransmitting a file, because the first one was declined because of errors, you have to use a new file name.

Encoding | "utf-8"
Content
A single interface file can only contain one single order.

Show Communication

There are multiple ways of communicaton available.

Type of communication Description
FTP

You'll have an account on the FTP server of IMS. There are two directories present:

Directory Description
inbound

This directory represents the inbound directory of IMS to put your data files. In the present release, this are only the order inbound files.

To prevent the receiving system to process the files before the sending process is done, you have to set the final filename after the sending process is done.

We suggest using the file extension ".tmp" during the sending process. After the file is transmitted, rename the file to ".xml".

outbound

This directory provides you with all files send from IMS to the customer. In the present release, this contains the acknowledgement files.

Mail

The data files have to be sent as attachments within a mail.

Field | Description

Inbound

Please send the mail as plain-text.
Receiver

the mail receiver is the following mail-address:

"interfaces.at@imscargo.com"

Do not send any other mails to this mail-address besides mails with data files. Mails addressed to this mail-address are processed automatically and not recognized by any employee of IMS.
Subject

The subject of the mail has to start with the text "IMS Order-Inbound". You can extend the subject with any other text.
Object

The text in the object of the mail is ignored by the interface system. Please do not send any information for IMS in the object of the mail.
Attachment

The attached interface file has to match the rules for naming (see technical specifications above)
Receipts

The IMS mail server will not send any delivery or read receipts for received mails. The inbound of the interface file will be announced by sending a Acknowldege file.

Outbound
Sender

All interface mails from IMS will be send with the sender:

"CustomerInterfaceRobot@imscargo.com"

Do not send any mail to this email-address. This mail-address is only used as the sender for automated mails created by the IMS interface system.
Subject

The text in this field for sending Acknowledge-messages is:

"Customer-Interfaces Order-Inbound ACK für File ID nnnnnn"

"nnnnnnn" = GUID (this is the Message-Ident of the data transmission (inbound), on which this Acknowledge is based on.
Object | The text is only for informational purpose, and there is no need to process any of this information.
Attachment

The attached interface file has to match the rules for naming (see technical specifications above)
Receipts | The IMS server will not ask for any delivery or reads receipts.

Content
Within one single mail, there is only one attached data file allowed.

Show Workflow diagram

Click to Enlarge Click to Enlarge
Click to Shrink Click to Shrink

Show Legende

Sendungsnummer Description
1

Sending of an order to IMS

Interface type | Direction
IMS_CI_Order | Outbound
2

Sending of the "technical acknowledge" from IMS to the customer

Interface type | Direction
IMS_CI_ACK | Outbound

With the sending of a technical acknowledge IMS is conforming the inbound of your data transmission. (In this case, the Order Inbounds).

The technical ACK is only confirming the reception of the data file, not if the data is valid and successfully processed!

If an error is occurring during the reception process, there will be no technical acknowledge send!

Because there are so many steps during the transmission process (FTP client, FTP server, copying/renaming of the file, interface system offline, ...), it is not possible to create a negative technical acknowledge message. Please take care, that your system is informing you about data sendings without a technical acknowledge within approx. 30 minutes. If such an error occurs, we have to investigate about the error manually.
3

Information about technical errors within the data file (invalid XML structure or invalid values in single nodes/fields)

This information is send as a data acknowledge with information about the errors occurred during the test of the XML structure.

interface type | Direction
IMS_CI_ACK | Outbound

If there is an error detected during the testing of the XML document, the processing of the data will stop because it is not possible to evaluate the logical correctness of the data.

It is possible, that after you adjust and resend the data file, there will be an error detected during the logical check of the transmitted data.

see IMS_CI_ACK
4

Informations about logical errors within the transmitted data (Dangerous goods without dangerous goods declarations, ...)

This informations is sent as a data acknowledge with informations about the errors occurred during the processing of the data.

Interface type | Direction
IMS_CI_ACK | Outbound

see IMS_CI_ACK
5

Information about errors occurred during the processing of the order inbounds.

This information is sent as a data acknowledge with informations about the errors occurred during the processing of the data.

Interface type | Direction
IMS_CI_ACK | Outbound

see IMS_CI_ACK
6

IMS is sending a data acknowledge to the customer to inform about the successful processing of the order inbounds. Your order will be forwarded to our sales employees for the final check.

Interface type | Direction
IMS_CI_ACK | Outbound

This data acknowledge contains all the reference numbers your order in the IMS Systems.

see IMS_CI_ACK
7

The customer doesn't need to store all the references send within the final data acknowledge. If you receive any further information about your order, your order reference will always be part of this information.

See Also

IMS_CI_Order
IMS_CI_ACK


IMS_CI_Order
Interface Order Inbound > IMS_CI_Order

Glossary Item Box

Show All Show All
Hide All Hide All

This format defines a customer order as a XML document.

current release: 3.1.3.0

Show technical specifications current release

Specification | Description
file name extension | XML
Schema | IMS_Schemas_Ext.PxB_CI_OI.V3130
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3130>

Show Release history

Release Date of release Description
3.1.3.0 14.04.2017

(Extended subset for V 3.1.2.0)

Spezification | Description
File name extension | XML
Schema | IMS_Schemas.IMS_CI_Order.V3-1-3-0
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3130>

3.1.2.0

 20.01.2016

(Extended subset for V 3.1.1.0)

Spezification | Description
File name extension | XML
Schema | IMS_Schemas.IMS_CI_Order.V3-1-2-0
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3120>

3.1.1.0

 01.07.2014

(Extended subset for V 3.1.0.0)

Spezification | Description
File name extension | XML
Schema | IMS_Schemas.IMS_CI_Order.V3-1-1-0
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3110>
3.1.0.0 23.11.2012

Production

Specification | Description
File name extension | XML
Schema | IMS_Schemas.IMS_CI_Order.V3-1-0-0
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3100>
1.2.2.0 01.02.2011

Production

Specification | Description
File name extension | XML
Schema | IMS_Schemas.IMS_CI_Order.V1-2-2-0
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V1220>

Show Documentation XML Schema

current release:

XML Schema for IMS_Schemas_Ext.PxB_CI_OI.V3130

(Subset for V3.1.2.0/V3.1.1.0/V3.1.0.0)

older releases:

XML Schema for IMS_Schemas_Ext.PxB_CI_OI.V3120 (Subset for V3.1.1.0/V3.1.0.0)

XML Schema for IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0

Show Downloads / Examples

File | Description
IMS_CI_OI_V3130.xsd | XML Schema
IMS_CI_OI_V3120.xsd | XML Schema
IMS_CI_OI_V3110.xsd | XML Schema
PxB_CI_OI_V3100.xsd | XML Schema
PxB_CI_OI_V3100.xml | XML-Interfacedatei mit Testdaten

back


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Node "Orders"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Node "Orders"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Prefix"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Prefix"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Orders"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Orders"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Order"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Order"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Header"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Header"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Customer"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Customer"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "OrderData"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "OrderData"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Verification"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Verification"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Informations"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Informations"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "References"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "References"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Reference"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Reference"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Comments"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Comments"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Comment"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Comment"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Contact"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Contact"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Relations"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Relations"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "PickUp"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "PickUp"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Outbound"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Outbound"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "StationData"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "StationData"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "LocationData"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "LocationData"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Ship"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Ship"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Waypoints"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Waypoints"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Waypoint"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Waypoint"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Inbound"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Inbound"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Destination"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Destination"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Container"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Container"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Data"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Data"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Temperature"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Temperature"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Content"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Content"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Collis"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Collis"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Colli"
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Colli"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "DangerousClass"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "DangerousClass"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Packaging"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Packaging"

Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 - Node "Orders"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 - Node "Orders"

Glossary Item Box

Show All Show All
Hide All Hide All

node/field/attribute | min | max | mand. | Format | Description
Orders | 1 | 1 | ü | . | Root Node for order inbound

legend

back


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Orders"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Orders"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Orders":

node/field/attribute | min | max | mand. | Format | Description
Prefix | 1 | 1 | ü | . | technical data about the interface file
Order | 1 | 1 | ü | . | order data

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Order"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Order"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Order":

node/field/attribute | min | max | mand. | Format | Description
Header | 1 | 1 | ü | . | Head data of the online order
Relations | 1 | 1 | ü | . | Information about pickup-, destination- and waypoints
Container | 1 | 1 | ü | . | Information about the container and content

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Prefix"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Prefix"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Prefix":

node/field/attribute

min

max

mand.

Format

 Description
Version

1

1

ü

string(7-7)

Release number of the inteface file

The interface system is only processing order inbounds, if the release number in this node matches the release number of the XML schema.

current Release number
3-1-0-0

ID

1

1

ü

string(36-36)

unique GUID of this data file
DateTime

1

1

ü

jjjj-mm-ddThh:nn:ss

 Date and time of creation of this interface file
Sendtype

1

1

ü

string(3-3)

Type of communication

Content | Description
MAI | eMail
FTP | FTP push to IMS FTP server
HandlingCode

1

1

ü

string(1-1)

Definition of target system (Test/Production)

Content | Description
P | Production
T | Test

Please pay attention about the content of this node. If you adress the test system, the online order will only be checked, but not forwarded to the iMS production system.
SenderID

1

1

ü

string(36-36)

GUID of the sender (customer)

Your GUID will be handed out after you applied for an interface.
ReceiverID

1

1

ü

string(36-36)

GUID IMS
D4AF98C4-5930-430B-855B-B74785ACFEF6

IDReferenced

0

1

string(36-36)

GUID of the online order this message is based on

*) This node is not available in the current release
DocumentType

1

1

ü

string(1-1)

Type of transmitted data

Content | Description
N | new order
U | update for an already transmitted online order *
S | deletion of an already transmitted online order *

*) These types are not available in the current release
DB

0

1

string

 not used
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used
Field5

0

1

string

 not used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Header"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Header"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Header":

node/field/attribute | min | max | mand. | Format | Description
Customer | 1 | 1 |  | . | Information about the customer
OrderData | 1 | 1 | ü | . | Information about the oonline order
Informations | 1 | 1 | ü | . | Comments, references and contact information

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Customer"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Customer"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Customer":

node/field/attribute | min | max | mand. | Format | Description
CustomerNo | 0 | 1 |  | integer | Your customer number at IMS
Name1 | 0 | 1 |  | string(50) | Customer name
Name2 | 0 | 1 |  | string(50) | Extension customer name
Adress1 | 0 | 1 |  | string(50) | Address
Adress2 | 0 | 1 |  | string(50) | Address extension
ZipCode | 0 | 1 |  | string(4-8) | ZIP code
Town | 0 | 1 |  | string(50) | City
CountryCode | 0 | 1 |  | string(2-2) | Country code (ISO 3166 ALPHA-2) (see Wikipedia)
VATID | 0 | 1 |  | string(15) | Tax identification number (see Wikipedia)
Field1 | 0 | 1 |  | string | not used
Field2 | 0 | 1 |  | string | not used
Field3 | 0 | 1 |  | string | not used
Field4 | 0 | 1 |  | string | not used
Field5 | 0 | 1 |  | string | mot used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "OrderData"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "OrderData"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "OrderData":

node/field/attribute

min

max

mand.

Format

 Description
OrderNo

1

1

ü

integer

Order reference in the customer ERP system
OrderDate

1

1

ü

string(50)

Order date in the customer ERP system
IMSOfferNo

0

1

string(50)

ID of the IMS offer the order is based on
Direction

1

1

ü

string(50)

Direction of transport

Content | Description
I | Import
E | Export
GoodsNetValue

0

1

string(50)

Total of net values of all the content in this order
CustomHandling

1

1

string(4-8)

not used
IMSOrderID

0

1

string(50)

Order number in the IMS ERP system
FreightTerm

0

1

string(2-3)

Freight terms

Content | Description
FOG | free on ground
FOT | free on truck
FOR | free on rail
NA | unknown
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used
Field5

0

1

string

 not used

Verification

0

1

.

Information for validation of the order

This node is not used in the current relase.

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Informations"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Informations"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Informations":

node/field/attribute | min | max | mand. | Format | Description
References | 0 | 1 |  | . | References
Comments | 0 | 1 |  | . | Comments and additional information
Contact | 0 | 1 |  | . | Information about the contact/salesman at the customer

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "References"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "References"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "References":

node/field/attribute | min | max | mand. | Format | Description
References | 0 | 99 | ü | . | single reference

legend

back to parent node "Informations"

back to parent node "Container"


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Reference"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Reference"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Reference":

node/field/attribute

min

max

mand.

Format

 Description

Code

(Attribut)

1

1

ü

string

This attribute defines the typ of reference. These codes need to be agreed between IMS and the customer.

Content | Description
Reference

1

1

ü

string

Reference

The usage of references in this node must be based on the agreed codes (above) between IMS and the customer)

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Comments"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Comments"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Comments":

node/field/attribute | min | max | mand. | Format | Description
Comment | 1 | 99 | ü | . | Single comment

legend

back to parent node "Information"

back to parent node "PickUp"

back to parent node "Waypoint"

back to parent node "Destination"

back to parent node "Container"


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Comment"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Comment"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Comment":

node/field/attribute | min | max | mand. | Format | Description
Comment | 1 | 1 | ü | string(255) | Comment

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Contact"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Contact"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Contact" (for node "Header"):

node/field/attribute

min

max

mand.

Format

 Description
Department

0

1

string(100)

Name of the department
Name

1

1

ü

string(100)

name of the user
Phone

1

1

ü

string(20)

Telefone number
Mail

1

1

ü

string(200)

Email-address of the user
Fax

0

1

string(20)

Fax number
CallBack

0

1

string(1)

Remark to receive a callback from the order entrance department of IMS

Content | Description
Y | A sales representive of IMS will call the sender before the online order is imported into the IMS production system
N | no callback needed

legend

back to parent node "Header"


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Verification"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Verification"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Verification":

This node is not used in the current release

node/field/attribute | min | max | mand. | Format | Description
CountContainer | 0 | 1 |  | integer | Total count of the containers in this online order
Net | 0 | 1 |  | decimal | Total net value based on the offer excl. additional services
VAT | 0 | 1 |  | integer | Total tax value of the offer

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Relations"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Relations"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Relations":

node/field/attribute | min | max | mand. | Format | Description
Pickup | 1 | 1 | ü | . | Point of loading
Waypoints | 0 | 1 |  | . | Known way points
Destination | 1 | 1 | ü | . | Point of discharge

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "PickUp"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "PickUp"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "PickUp":

node/field/attribute

min

max

mand.

Format

 Description
CarriageType

1

1

ü

string

Type of freight

predefined value: "unbekannt"
TransportType

1

1

ü

string

Type of transport

Content | Description
Train | Loading on train
Truck | Loading on truck
unknown | Type of loading unknown
Outbound

1

1

ü

Information about the date and time of loading
LocationCode

1

1

ü

string(1)

Type of address information

Content | Description | Corresponding node
L | Adress (no station data) | LocationData
T | Railway station | StationData
B | Adress and Railway station | LocationData and StationData

Please fill the corresponding nodes correlated to the choosen type of adress information
StationData

0

1

.

Information about the railway station as point of loading
LocationData

0

1

.

Information about the adress of the point of loading
Ship

0

1

.

Information about the ship, port and shipowner

This node is mandatory for import orders and forbidden for export orders
Contact

0

1

.

Information about the contact person for questions about the loading process
Comments

0

1

.

 Comments related to the loading process
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used

Field5

0

1

string

 not used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Waypoints"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Waypoints"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Waypoints":

node/field/attribute | min | max | mand. | Format | Description
Waypoint | 1 | 99 | ü | . | Single waypoint

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Waypoint"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Waypoint"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Waypoint":

node/field/attribute

min

max

mand.

Format

 Description
CarriageType

1

1

ü

string

Type of freight

predefined value: "unbekannt"
TransportType

1

1

ü

string

Type of transport

Content | Description
Train | Discharge from train
Truck | Discharge from truck
unknown | Type of discharge unknown
Inbound

1

1

ü

.

Information about the date/time of discharging
Outbound

1

1

ü

.

Information about the date/time of loading
LocationCode

1

1

ü

string(1)

type of Adress information

Content | Description | Corresponding node
L | Adress (no station data) | LocationData
T | Railway station | StationData
B | Adress and Railway station | LocationData and StationData

Please fill the corresponding nodes correlated to the choosen type of adress information
StationData

0

1

.

Information about the railway station as loading/discharge point
LocationData

0

1

.

Information about the adress of the loading/discharge point
Contact

0

1

.

Information about the contact person for questions about the loading/discharge process
Comments

0

1

.

Comments related to the loading/discharge process
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used

Field5

0

1

string

 not used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Destination"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Destination"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Destination":

node/field/attribute

min

max

mand.

Format

 Description
CarriageType

1

1

ü

string

Type of freight

predefined value: "unbekannt"
TransportType

1

1

ü

string

Type of transport

Content | Description
Train | Discharge from train
Truck | Discharge from truck
unknown | Type of loading unknown
Inbound

1

1

ü

.

Information about the date and time of discharge
LocationCode

1

1

ü

string(1)

Type of address information

Content | Description | Corresponding node
L | Adress (no station data) | LocationData
T | Railway station | StationData
B | Adress and Railway station | LocationData and StationData

Please fill the corresponding nodes correlated to the choosen type of adress information
StationData

0

1

.

Information about the railway station as point of discharge
LocationData

0

1

.

Information about the adress of the point of discharge
Ship

0

1

.

Information about the ship, port and shipowner

This node is mandatory for export orders and forbidden for import orders
Contact

0

1

.

Information about the contact person for questions about the discharging process
Comments

0

1

.

 Comments related to the discharge process
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used

Field5

0

1

string

 not used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Inbound"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Inbound"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Inbound":

node/field/attribute

min

max

mand.

Format

 Description
Optional

1

1

ü

string(1)

Type of date/time information

Content | Description
Y | Date of discharge is optional (like a proposal)
N | Date of discharge is mandatory
Date

1

1

ü

jjjj-mm-tt

Date if discharge
TimeFrom

1

1

ü

hh:mm:ss

earliest possible time of discharge
TimeTo

1

1

ü

hh:mm:ss

latest possible time of discharge

legend

back to parent node "Waypoint"

back to parent node "Destination"


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Outbound"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Outbound"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Outbound":

node/field/attribute

min

max

mand.

Format

 Description
Optional

1

1

ü

string(1)

Type of date/time information

Content | Description
Y | Date of loading optional (like a proposal)
N | Date of loading is mandatory
Date

1

1

ü

jjjj-mm-tt

Date of loading
TimeFrom

1

1

ü

hh:mm:ss

earliest possible time of loading
TimeTo

1

1

ü

hh:mm:ss

latest possible time of loading

legend

back to parent node "PickUp"

back to parent node "Waypoint"

back to parent node "Destination"


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "StationData"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "StationData"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "StationData":

node/field/attribute | min | max | mand. | Format | Description
Code | 1 | 1 | ü | int | internation railway station numer (IBNR) (always 8-digits incl. country prefix) (see Wikipedia)
Name | 1 | 1 | ü | string | name of the railway station
Terminal | 1 | 1 | ü | string | Code of the terminal (sliding)
TerminalName | 1 | 1 | ü | string | Name of the terminal (sliding)

legend

back to parent node "PickUp"

back to parent node "Waypoint"

back to parent node "Destination"


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "LocationData"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "LocationData"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "LocationData":

node/field/attribute | min | max | mand. | Format | Description
Name | 1 | 1 | ü | string | Name of the company or information about the point of loading/discharge
Adress | 1 | 1 | ü | string(4-8) | Adress
Town | 1 | 1 | ü | string | City
CountryCode | 1 | 1 | ü | string(2) | Countrycode ISO 3166 ALPHA-2 (see Wikipedia)

legend

back to parent node "PickUp"

back to parent node "Waypoint"

back to parent node "Destination"


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Ship"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Ship"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Ship" (für übergeordneten Knoten "PickUp"):

node/field/attribute

min

max

mand.

Format

 Description
CarrierCode

1

1

string

Code of the shipowner

4-digit SCAC-Code of the shipowner

(see Wikipedia)
CarrierName

1

1

ü

string

Name of the ship owner
Code

0

1

string

call sign of the ship
Name

1

1

ü

string

Name of the ship

ETA (Segment Pickup)

ETC (Segment Destination)

0

1

jjjj-mm-ttThh:nn:ss

Content | Description
Import | Arrival time port (ETA)
Export | Closing time (ETC)

Please use the corresponding node name(ETA/ETC) depending on the parent node of the node "ship" (Pickup/Destination)
PortCode

1

1

ü

string

Portcode (UN/LOCODE)

(see UNECE, List of all international ports here)
PotName

1

1

ü

string

 Name of the harbour
TravelNumber

0

1

string

 Voyage number

legend

back to parent node "PickUp"

back to parent node "Destination"


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Contact"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Contact"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Contact" (für die Übergeordneten Knoten "PickUp", "WayPoint" und "Destination"):

node/field/attribute

min

max

mand.

Format

 Description
Department

0

1

string(100)

Name of the department
Name

1

1

ü

string(100)

Name of the contact person
Phone

1

1

ü

string(20)

Telephone number
Mail

1

1

ü

string(200)

Mail address
Fax

0

1

string(20)

Fax number
CallBack

0

1

string(1)

Request for a callback before the order is processed from IMS

Content | Description
Y | The customer receives a telephone call before the online order is forwarded to the production system of IMS
N | No callback needed

legend

back to parent node "PickUp"

back to parent node "Waypoint"

back to parent node "Destination"


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Container"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Container"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Container":

node/field/attribute | min | max | mand. | Format | Description
Container (up to Version 3.1.2.0) Container (Version 3.1.3.0 and higher) | 1 | 99 | ü | . | single Container

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Container"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Container"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Container":

node/field/attribute

min

max

mand.

Format

 Description

Data (V3.0.0.0)

Data (V3.1.2.0)

1

1

ü

.

Container data
Temperature

0

1

.

Information about cooling
References

0

1

.

References
Comments

0

1

.

Comments
Content

0

1

.

Information about the content of the container
Services

0

1

.

Information about the requested services

The node "Services" is not used in the current relase.

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_0_0_0 -Content Node "Data"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_0_0_0 -Content Node "Data"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Data":

node/field/attribute

min

max

mand.

Format

 Description
RefNo

1

1

ü

string

Container reference from the customer ERP system
ID

0

1

string(11)

Container number

HabisCode

1

1

ü

string

Code based on Rail-Port-Direct HABIS A05-Container type

(see Rail-Port-Direkt)
ContainerType

1

1

ü

string(2)

Type of Container

(see type of container)
LengthCode

1

1

ü

string(2)

Length of the container in foot

(see lenght of container)
Tara

1

1

ü

integer

Weigth of the empty container (Tara)
Weight

1

1

ü

decimal(2)

Gross weight of the container (tara + net weight)
Empty

1

1

ü

string(1)

Empty container

Content | Description
Y | Container is empty
N | Container with content
CustomSealNumber

0

1

string

Customs seal number
IMSContainerID

0

1

integer

IMS-Reference for this container

(is generated by IMS)
IMSPoolID

0

1

integer

IMS-Reference for container pool

(is generated by IMS)
TurnInOut

0

1

string

Turn-In, bzw. Turn-Out Reference
PickUpReference

0

1

string

Pick up reference
DeliveryReference

0

1

string

Delivery reference
CustomIndicator

1

1

ü

string(1)

dutiable goods

Content | Description
Y | Container contains dutiable goods
N | Container contains only non dutiable goods
CustomProcedure

0

1

ü

string(2-3)

Zollprozedur

Content | Description
AZA | Exportverzollung
BT1 | Bahn T1
ERL | Container ist abgefertigt
EU | Gemeinschaftsware
IVZ | Importverzollung
T1 | T1
T1B | FB T1 Stempel
VZT | IVZ d. Terminalspedition
XX | keine Verfügung

Due to the importance of this information there is no translation of the German codes. The codes has to be discussed between the customer and IMS to make sure that the correlated code is used depending on the needed customs handling of the goods.
CustomsAgency

0

1

string

Name and Adress of the customs agency in charge
DossierNo

0

1

string

Dossier number

(only needed for handling at the harbour Rotterdam)
EmptyDepot

0

1

string

name of the empty container depot
EmptyDepotPin

0

1

string

Pin for Pick up/discharge of the container in the empty container depot
ATBNo

0

1

string

ATB number
ATA-ATCNo

0

1

string

ATA or ATC number
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used
Field5

0

1

string

 not used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_2_0 -Content Node "Data"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_2_0 -Content Node "Data"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Data":

node/field/attribute

min

max

mand.

Format

 Description
RefNo

1

1

ü

string

Container reference from the customer ERP system
ID

0

1

string(11)

Container number

HabisCode

1

1

ü

string

Type of Container

(see type of container)
LengthCode

1

1

ü

string(2)

Length of the container in foot

(see lenght of container)
Tara

1

1

ü

integer

Weigth of the empty container (Tara)
Weight

1

1

ü

decimal(2)

Gross weight of the container (tara + net weight)
Empty

1

1

ü

string(1)

Empty container

Content | Description
Y | Container is empty
N | Container with content
CustomSealNumber

0

1

string

Customs seal number
IMSContainerID

0

1

integer

IMS-Reference for this container

(is generated by IMS)
IMSPoolID

0

1

integer

IMS-Reference for container pool

(is generated by IMS)
TurnInOut

0

1

string

Turn-In, bzw. Turn-Out Reference
PickUpReference

0

1

string

Pick up reference
DeliveryReference

0

1

string

Delivery reference
CustomIndicator

1

1

ü

string(1)

dutiable goods

Content | Description
Y | Container contains dutiable goods
N | Container contains only non dutiable goods
CustomProcedure

0

1

ü

string(2-3)

Zollprozedur

Content | Description
AZA | Exportverzollung
BT1 | Bahn T1
ERL | Container ist abgefertigt
EU | Gemeinschaftsware
IVZ | Importverzollung
T1 | T1
T1B | FB T1 Stempel
VZT | IVZ d. Terminalspedition
XX | keine Verfügung

Due to the importance of this information there is no translation of the German codes. The codes has to be discussed between the customer and IMS to make sure that the correlated code is used depending on the needed customs handling of the goods.
CustomsAgency

0

1

string

Name and Adress of the customs agency in charge
DossierNo

0

1

string

Dossier number

(only needed for handling at the harbour Rotterdam)
EmptyDepot

0

1

string

name of the empty container depot
EmptyDepotPin

0

1

string

Pin for Pick up/discharge of the container in the empty container depot
ATBNo

0

1

string

ATB number
ATA-ATCNo

0

1

string

ATA or ATC number

NetValue

0

1

.

decimal(2)

Net value of the loaded goods in the container.

If you authorize IMS to create customs documents, the net value and currency is mandatory.

NetValueCurrencyCode

0

1

.

string(3)

 Currency (ISO 4217)
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used
Field5

0

1

string

 not used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "Data"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "Data"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Data":

node/field/attribute

min

max

mand.

Format

 Description
RefNo

1

1

ü

string

Container reference from the customer ERP system
ID

0

1

string(11)

Container number

HabisCode

1

1

ü

string

Type of Container

(see type of container)
LengthCode

1

1

ü

string(2)

Length of the container in foot

(see lenght of container)
Tara

1

1

ü

integer

Weigth of the empty container (Tara)
Weight

1

1

ü

decimal(2)

Gross weight of the container (tara + net weight)
Empty

1

1

ü

string(1)

Empty container

Content | Description
Y | Container is empty
N | Container with content
CustomSealNumber

0

1

string

Customs seal number
IMSContainerID

0

1

integer

IMS-Reference for this container

(is generated by IMS)
IMSPoolID

0

1

integer

IMS-Reference for container pool

(is generated by IMS)
TurnInOut

0

1

string

Turn-In, bzw. Turn-Out Reference
PickUpReference

0

1

string

Pick up reference
DeliveryReference

0

1

string

Delivery reference
CustomIndicator

1

1

ü

string(1)

Dutiable goods

Content | Description
Y | Container contains dutiable goods
N | Container contains only non dutiable goods
CustomProcedure

0

1

ü

string(2-3)

Zollprozedur

(see customs prozedures)
CustomsAgency

0

1

string

Name and Adress of the customs agency in charge
CustomsDepartment

0

1

.

string

Reference number of the official customs office for Import or Export

(siehe http://ec.europa.eu/taxation_customs)

If you authorize IMS to create customs documents, the field official customs agency is mandatory.

CustomsDepartmentName

0

1

.

string

 Name of the official customs office
DossierNo

0

1

string

Dossier number

(only needed for handling at the harbour Rotterdam)
EmptyDepot

0

1

string

Name of the empty container depot
EmptyDepotPin

0

1

string

Pin for Pick up/discharge of the container in the empty container depot
ATBNo

0

1

string

ATB number
ATA-ATCNo

0

1

string

ATA or ATC number

NetValue

0

1

.

decimal(2)

Net value of the loaded goods in the container.

If you authorize IMS to create customs documents, the net value and currency is mandatory.

NetValueCurrencyCode

0

1

.

string(3)

 Currency (ISO 4217)
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used
Field5

0

1

string

 not used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Temperature"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Temperature"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Temperature":

node/field/attribute

min

max

mand.

Format

 Description
Refrigeration

1

1

ü

string(1)

Container is temperature controlled

Content | Description
Y | Container is temperature controlled
N | Container is not temperate controlled
Min

1

1

ü

decimal(2)

Minimal temperature (degree celsius)
Max

1

1

ü

decimal(2)

Maximal temperature (degree celsius)

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Content"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Content"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Content":

node/field/attribute | min | max | mand. | Format | Description
Content (V3.1.1.0 and earlier) Content (V3.1.2.0 and above) | 1 | 99 | ü | . | Information about the content of the container

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Content"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Content"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Content":

node/field/attribute

min

max

mand.

Format

 Description
RefNo

1

1

ü

string

Reference of the goods in the customer ERP system
Description

1

1

ü

string(255)

Description
RIDCode

1

1

ü

string(1)

Dangerous goods

Content | Description
Y | Dangerous goods
N | Non dangerous goods

If this node contains "Y" the appearence of the node "DangerousClass" (see below) is mandatory.
NetWeight

1

1

ü

decimal(2)

Net weight of the goods (incl. Weight of package)
Collis

1

1

ü

Packaging
CountryCodeOrigin

1

1

ü

string(2)

Country of origin

Country code ISO 3166 ALPHA-2
(see Wikipedia)
CountryCodeDestination

1

1

ü

string(2)

Country of destination

Country code ISO 3166 ALPHA-2
(see Wikipedia)
NetValue

0

1

decimal(2)

Net value in Euro
CustomNumber

0

1

string

Customs number
ATBNumber

0

1

string

ATB number
IMSContentID

0

1

integer

IMS Reference of the goods in the IMS ERP system

(will be created by IMS)
BLNo

0

1

string

Master BL Nr. (Bill of Lading)

(only used for handling in harbour Rotterdam)
BLSerialNo

0

1

string

Serial number within one Master BL Nr. (Bill of Lading)

(only used for handling in harbour Rotterdam)
MRNNo

0

1

string

Movement Reference Number

(see Wikipedia)

HSCode

0

1

.

integer

Zolltarifnummer

siehe (Wikipedia, TARIC EU)

Wird IMS von Ihnen mit der Erstellung von Zolldokumenten beauftragt, ist die Angabe des HS Codes (Zolltarifnummer) verpflichtend.
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used
Field5

0

1

string

 not used

DangerousClass (V3.1.0.0)

DangerousClass (V3.1.1.0 and above)

0

1

.

Dangerous goods declaration

The content of this node is only processed if the goods are marked as dangerous goods (see node "RIDCode" above).

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Content"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Content"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Content":

node/field/attribute

min

max

mand.

Format

 Description
RefNo

1

1

ü

string

Reference of the goods in the customer ERP system
Description

1

1

ü

string(255)

Description
RIDCode

1

1

ü

string(1)

Dangerous goods

Content | Description
Y | Dangerous goods
N | Non dangerous goods

If this node contains "Y" the appearence of the node "DangerousClass" (see below) is mandatory.
NetWeight

1

1

ü

decimal(2)

Net weight of the goods (incl. Weight of package)
Collis

1

1

ü

Packaging
CountryCodeOrigin

1

1

ü

string(2)

Country of origin

Country code ISO 3166 ALPHA-2
(see Wikipedia)
CountryCodeDestination

1

1

ü

string(2)

Country of destination

Country code ISO 3166 ALPHA-2
(see Wikipedia)
NetValue

0

1

decimal(2)

Net value in Euro
CustomNumber

0

1

string

Customs number
ATBNumber

0

1

string

ATB number
IMSContentID

0

1

integer

IMS Reference of the goods in the IMS ERP system

(will be created by IMS)
BLNo

0

1

string

Master BL Nr. (Bill of Lading)

(only used for handling in harbour Rotterdam)
BLSerialNo

0

1

string

Serial number within one Master BL Nr. (Bill of Lading)

(only used for handling in harbour Rotterdam)
MRNNo

0

1

string

Movement Reference Number

(see Wikipedia)

HSCode

0

1

.

integer

Harmonized system code

siehe (Wikipedia, TARIC EU)

If you athorize IMS to create customsdocuments, you need to provide the HS code.

The HS Code has to be 8 digits long. You are allowed to fill the digits 7-8 with "00" if this part of the HS Code is unknown.

Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used
Field5

0

1

string

 not used

DangerousClass (V3.1.0.0)

DangerousClass (V3.1.1.0 and above)

0

1

.

Dangerous goods declaration

The content of this node is only processed if the goods are marked as dangerous goods (see node "RIDCode" above).

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Collis"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Collis"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Collis":

node/field/attribute | min | max | mand. | Format | Description
Colli | 1 | 99 | ü | . | Information for a single packaging type

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Colli"
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Colli"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Colli":

node/field/attribute | min | max | mand. | Format | Description
Count | 1 | 1 | ü | integer | Count of pasckaging units
Code | 1 | 1 | ü | string(2) | type of packaging We are using the following Codes
Description | 1 | 1 | ü | string | Description of the packaging type

%LegendebackParent%%


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "DangerousClass"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "DangerousClass"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "DangerousClass":

node/field/attribute

min

max

mand.

Format

 Description
Class

1

1

ü

string

Class

(see Wikipedia)
UNCode

0

1

ü

string

IMS internal RID code
UNNumber

1

1

ü

string

UN-RID number

(see Wikipedia)
Description

1

1

ü

string(500)

Description of the dangerous content
FlashPoint

1

1

ü

decimal

Flash point (degrees celsius)
GrossWeight

1

1

ü

integer

Gross weight of the dfangerous goods in kg
NetWeight

0

1

ü

integer

Net weight of the dangerous goods in kg
NetExplosive

0

1

integer

Net weight of explosive parts in kg
Number

1

1

ü

string

RID-Dangerous group nummer

(see Wikipedia)
ClassCode

1

1

ü

string

RID-classification code
GrossZettel

0

1

string

"Gefahrengutzettel"

dieses Feld wird in der aktuellen Version nicht verarbeitet
Packaging

0

99

.

Informations about the packaging of the dangerous goods
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used
Field5

0

1

string

 not used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_1_0 -Content Node "DangerousClass"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_1_0 -Content Node "DangerousClass"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "DangerousClass":

node/field/attribute

min

max

mand.

Format

 Description
Class

1

1

ü

string

Class

(see Wikipedia)
UNCode

0

1

ü

string

IMS internal RID code
UNNumber

1

1

ü

string

UN-RID number

(see Wikipedia)
Description

1

1

ü

string(500)

Description of the dangerous content
FlashPoint

1

1

ü

decimal

Flash point (degrees celsius)
GrossWeight

1

1

ü

integer

Gross weight of the dfangerous goods in kg
NetWeight

0

1

ü

integer

Net weight of the dangerous goods in kg
NetExplosive

0

1

integer

Net weight of explosive parts in kg
Number

1

1

ü

string

RID-Dangerous group nummer

(see Wikipedia)
ClassCode

1

1

ü

string

RID-classification code
GrossZettel

0

1

string

"Gefahrengutzettel"

dieses Feld wird in der aktuellen Version nicht verarbeitet
Packaging

0

99

.

Informations about the packaging of the dangerous goods
LQ

0

1

.

string

Limited Quantity

(see Wikipedia)

Content Description
N

Transport not based on Limited Quantity Definition
Y

Transport based on Limited Quantity Definitiom

In case of a transport based on Limited Quantity Definition the only mandatory node is the "UNNumber".

UWG

0

1

.

string

Hazardous material

Content | Description
N | Goods containing no hazardous materials
Y | Goods containing hazardous materials
BefCode

0

1

.

integer

Transportcode

Content | Description
0 or missing | No special transport code
1 | Transport based on RID chapter 1.1.4.2.1.
Field1

0

1

string

 not used
Field2

0

1

string

 not used
Field3

0

1

string

 not used
Field4

0

1

string

 not used
Field5

0

1

string

 not used

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Packaging"
Send Feedback
Interface Order Inbound > IMS_CI_Order_V3_1_n_n > IMS_CI_Schemas.IMS_CI_Order_V3_1_0_0 -Content Node "Packaging"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Packaging":

node/field/attribute | min | max | mand. | Format | Description
Code | 1 | 1 | ü | string(2) | Packaging code For data exhange we use the following Codes
Count | 1 | 1 | ü | integer | Amount of packaging units
Group | 1 | 1 | ü | string | RID packaging group

legend

back to parent node


Interface Status Outbound
See Also Send Feedback
Interface Status Outbound > Interface Status Outbound

Glossary Item Box

Show All Show All
Hide All Hide All

The interface Status Outbound is used to transfer status information from IMS to the customer.

Current interface release:

Interface type | actual Release | Date of release | Description
IMS_CI_StatusOutbound | IMS_CI_Schemas.IMS_CI_StatusOutbound_V1095 | 20.01.2017 | XML-Schema for status information

The current version V1.0.9.5 has the same XML structure as the previous release V1.0.3.1.

But we have added an additional status code (218 Invoice preadvise).

IMS will send out the data files using the new target namespec http://IMS_CI_Schemas.IMS_CI_StatusOutbound_V1095

To apply for this interface please see Applying for electronic data exchange

To ensure all functions of this interface are working as intended we will start the electronic data exchange using a limited test phase. During this test phase you will receive data targeted to your test environment. Please make sure that you only process data marked as production data in your production systems.

Show Technical specifications

Spezification Description
File name

IMS_CI_SO_a-a-a-a_nnn_xxxxxxxxxxx.XML

Place holder | Content
a-a-a-a | Release number of the interface schemata
nnn | Status code
xxxxxxxxxxx

GUID for unique naming of the interface file

The name of every interface file has to be unique.

encoding

"utf-8"
Inhalt
One interface file always contains information for a single container.

Show Communikation

There are three ways of communications available by now:

Type of communication Description
FTP Pull

We will provide an account on the FTP server of IMS.

Directory | Description
outbound | All IMS interface file are provided for download in this directory.
FTP Push

IMS will transmit the Status Outbound messages to your FTP server
eMail

IMS will send the Status Outbound messages as an attachment within an email to the customer.

Field | Description
Sender

The email-address for this emails is always:

"CustomerInterfaceRobot@imscargo.com"

Do not reply to this email-address. Emails addressed to this email-address will be ignored.
Subject

The subject will be formated like this:

"Customer-Interfaces - Status Outbound - Code nnn xxx...xxx

Place holder | Content
nnn | Status-code
xxx...xxx | Name of the status
Object

All text in the object is only for additional information and not part of the interface data.
Attachment

The interface file will be send as an attachment (siehe "technical specifications" above)

Every email will only contain a single interface file.
Confirmation | The interface system is sending all emails without requesting receive- or read confirmations.

Content
One interface file always contains information for a single container.

Show Status Codes

An overview about all supported status codes is available here.

Show Documentation XML Schema

actual Release:

IMS_CI_Schemas.IMS_CI_StatusOutbound_V1095

previous releases:

IMS_CI_Schemas.IMS_CI_StatusOutbound_V1031

Show Downloads / Examples

File | Description
IMS_CI_StatusOutbound_V1095.xsd | XML Schema
IMS_CI_StatusOutbound_V1031.xsd | XML Schema
IMS_CI_StatusOutbound_V1031.xml | XML-Interface file with test data

See Also

legends
Status Outbound Status-Codes

Release 1.0.3.1
IMS_CI_Schemas.IMS_CI_SO_V1_0_3_1

Release 1.0.9.5
IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5


Legend for XML schmas description
Legends > Legend for XML schmas description

Glossary Item Box

Show All Show All
Hide All Hide All

Legend for the tables containing the node- and fieldDescriptions.

Spalte | Description
Node | Name of the node/field
min

The minimum count of the appearance of this node/field on this postition within the data structure

"0" = node/field has not to be present on this position of the data structure
max

The maximum count of the appearance of this node/field on this positiion within the data structure

"n" = node/field can occur multiple times on this position of the data structure without restrictions
mand.

Node/field is mandatory.

"ü" = there has to be a value set in this field. Empty field is not allowed
Format

Format of the data in this field

Format | Description
string (n)

alpha-numeric value

Value | Description
n | maximum lenght (characters)
string (m-n)

alpha-numeric value

Value | Description
m | minimum lenght (characters)
n | maximum lenght (characters)
integer | numeric integer Value
decimal (n)

decimal number. Decimal point = "."

Value | Description
n | maximal number of digits after the decimal point
jjjj-mm-ttThh:nn:ss

date and time

Value | Description
jjjj | year, 4-digits
mm | month
tt | say
T | fixed delimiter "T" between date and time
hh | hour
nn | minute
ss | second
boolean

yes/no informations

Value | Description
Y | yes
N | no

Beschreibung | Informations to this nodes/field


Invoice Interface - types of documents
Legends > Invoice Interface - types of documents

Glossary Item Box

Show All Show All
Hide All Hide All

Type of the transmitted document within the invoice interface (Customer Invoice).

Code | Beschreibung
RG | invoice
GU | credit note
RU | incoming debit note
PG | partner credit note


Legend - Container types
See Also Send Feedback
Legends > Legend - Container types

Glossary Item Box

Show All Show All
Hide All Hide All

List of used container types:

Code | Description
BK | Bulk
DC | Box
FC | Flat
RH | High Cube Reefer
HC | High Cube
HT | Hard Top
OT | Open Top
RE | Reefer
TA | Tank

See Also

Version 3.1.n.n
IMS_CI_Schemas.IMS_CI_Order_V3_0_0_0 -Content Node "Data"
IMS_CI_Schemas.IMS_CI_Order_V3_1_2_0 -Content Node "Data"
IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "Data"

Version 1.2.2.0
IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Data"


Legend - container lenghts
See Also Send Feedback
Legends > Legend - container lenghts

Glossary Item Box

Show All Show All
Hide All Hide All

List of available container lenghts:

Code | Description
20 | 20 foot
24 | 24 foot
25 | 25 foot
30 | 30 foot
40 | 40 foot
45 | 45 foot

See Also

Version 3.1.n.n
IMS_CI_Schemas.IMS_CI_Order_V3_0_0_0 -Content Node "Data"
IMS_CI_Schemas.IMS_CI_Order_V3_1_2_0 -Content Node "Data"
IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "Data"

Version 1.2.2.0
IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Data"


Companies within the IMS group
See Also Send Feedback
Legends > Companies within the IMS group

Glossary Item Box

Show All Show All
Hide All Hide All

The IMS group consists of the following companies:

Shortcut | Short name | Address
IMS AT | IMS CARGO Austria GmbH | IMS CARGO Austria GMBH Trillergasse 8 1210 Vienna Austria
IMS DE | IMS CARGO Germany GmbH | IMS CARGO Germany GmbH Heidenkampsweg 44 20097 Hamburg Germany
IMS SK | IMS CARGO Sloavkia s.r.o | IMS CARGO Slovakia s.r.o Hranicna 18 82105 Bratislava Slowakia
IMS CH | IMS RAIL Switzerland AG | IMS RAIL SWITZERLAND AG Margarethenstrasse 38 4002 Basel Switzerland
IMS HU | IMS CARGO Hungary Kft. | IMS CARGO HUNGARY Kft. Visonta utca 1 1151 Budapest Hungary
IMS BE | IMS CARGO Belgium BVBA | IMS CARGO Belgium BVBA Legrandlaan 41 1050 Bruxelles Belgium
IMS ES | Intercontainer Iberica S.A. | Intercontainer Iberica S.A. C/ Enrique Larreta, 7 28036 Madrid Espania
IMS NL | IMS CARGO Netherlands B.V. | IMS CARGO Netherlands B.V. Hoefsmidstraat 41 3194 AA Rotterdam-Hoogvliet Netherlands

See Also

Status Outbound Status-Codes


Status Outbound Status-Codes
See Also Send Feedback
Legends > Status Outbound Status-Codes

Glossary Item Box

Show All Show All
Hide All Hide All

The interface Status Outbound in its current release contains the transmission of information about the following events:

Show Common data

Each status message contains the following general information:

  • Order
    • order reference of the cutomer
    • IMS order ID
    • IMS offer ID
    • ID of the customer at IMS
    • Responsible user for this order at the customers company
  • Container
    • IMS container ID
    • Container number
    • Type of container
    • Scale
    • Grossweight

Show Status-Codes

Status-Code

Code

ab Version

 Description transmitted information
205

Order confirmation

1.0.3.1

Order confirmation

net, PoD, PoA, notes

(net, PoD, PoA, notes)
206

Additional costs - pre advice

1.0.3.1

 Information about newly incidential expenses

service, net, company, notes

(service, net, company, notes)
207

Container number assigned

1.0.3.1

 Newly assigned Container number

containerno

(containerno)
208 Seal number assigned

1.0.3.1

 Newly assigned seal number

sealno

(sealno)
209 . .

unused

 .
210 . .

unused

 .
211 . .

unused

 .
212 Booking confirmation

1.0.3.1

Information about the first booking of the container transport

DoD, DoA, ship, carrier, SoA, ToA, notes

(DoD, DoA, ship, carrier, SoA, ToA, notes)
213 Booking information

1.0.3.1

Information about the assignment of the container to a train

DoD, DoA, SoA, ToA, notes

(DoD, DoA, SoA, ToA, notes)
214 Information about delay

1.0.3.1

Information about the delay/shifting of a transport date

DoD, notes

(DoD, notes)
215 Crossbooking information

1.0.3.1

Information about the crossbooking of a container

DoD, notes

(DoD, notes)
216 Train departure

1.0.3.1

 Information about the departure of a train from the departure terminal

DoD, DToA, SoA, ToA, SoD, ToD, wagon, notes

(DoD, DToA, SoA, ToA, SoD, ToD, wagon, notes)
217 Train arrival

1.0.3.1

Information about the arrival of a train on the destination terminal

DoD, DToA, SoA, ToA, SoD, ToD, wagon, notes

(DoD, DToA, SoA, ToA, SoD, ToD, ToA, wagon, notes)
218 Invoice advice

1.0.9.5

Information about a new invoice

service, net, company, notes, invoiceID

(service, net, company, notes, invoiceID)
219 Train delay

1.0.3.1

 Information about the delay of a train

DToD, notes

(DToD, notes)
220 Road arrival

1.0.9.5

(since 29.08.2017)

Information about the arrival of a container on the departure terminal

This status information is provided by IMS only if the terminal is providing electronically Gate-In-/Gate-Out-Messeges.

By now this status information is only provided for the terminals "WienCont Containerterminal Vienna Freudenau" and "Containerterminal Enns".

DToA, SoD, ToD

(DToA, SoD, ToD)
221 Road departure

1.0.9.5

(since 29.08.2017)

Information about the departure of a container from the arrival terminal

This status information is provided by IMS only if the terminal is providing electronically Gate-In-/Gate-Out-Messeges.

By now this status information is only provided for the terminals "WienCont Containerterminal Vienna Freudenau" and "Containerterminal Enns".

DToD, SoA, ToA

(DToD, SoA, ToA)

See Also

Tutorials
Interface Status Outbound


Legend - customs procedures
See Also Send Feedback
Legends > Legend - customs procedures

Glossary Item Box

Show All Show All
Hide All Hide All

List of available container lenghts:

Version 3.1.3.0 and above:

Code | Description
EER | Export: Container cleared
EEU | Export: EU goods
ENE | Export: Non EU goods
ETT | Export: T1
IEM | Empty container
IER | Import: Container already cleared
IEU | Import: Community goods (EU)
IKK | Import: Rail T1 by customer
IT | Import: Rail T1 to final destination
ITC | Import: T1/Import declaration by customer
ITI | Import: T1/Import declaration
ITN | Import: T1/no directive
ITT | Import: T1/T1
ITg | Import: T1 + community goods (EU) *)

*) since 22.11.2017

until Version 3.1.2.0:

Code | Description
AZA | Exportverzollung
BT1 | Bahn T1
ERL | Container ist abgefertigt
EU | Gemeinschaftsware
IVZ | Importverzollung
T1 | T1
T1B | FB T1 Stempel
VZT | IVZ d. Terminalspedition
XX | keine Verfügung

See Also

Version 3.1.n.n
IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "Data"
IMS_CI_Schemas.IMS_CI_Order_V3_0_0_0 -Content Node "Data"
IMS_CI_Schemas.IMS_CI_Order_V3_1_2_0 -Content Node "Data"

Version 1.2.2.0
IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 -Content Node "Data"


Downloads
Download > Downloads

Glossary Item Box

Show All Show All
Hide All Hide All

List of all XML-schemas and example files within the Interface system "Customer Interfaces":

Interface system "Customer Invoice"

Show XML Schemas

Interface | File | Description
Customer Invoice - IMS_CI_CustomerInvoice_XML | IMS_CI_CustomerInvoice2_V1096 File | XML Schema
Customer Invoice - openTRANS_INVOICE_1_0_all_in_one | openTRANS_INVOICE_1_0_all_in_one File_V1096 | XML Schema
Customer Invoice - IMS_CI_CustomerInvoice_FF | . | XML Schema

Show Examples

The examples are logically not coherent.. All nodes and fields are filled with valid values. But neither quantities, prices nor relations are matching with values of the production environment. Also all customer related values are virtual.

Interface | File | Description
Customer Invoice - IMS_CI_CustomerInvoice_XML | IMS_CI_CustomerInvoice2_V1096_Example File | XML-interface file mit Testdaten
Customer Invoice - IMS_openTRANS_INVOICE_1_0 | IMS_openTRANS_INVOICE_1096_Example File | XML-interface file mit Testdaten
Customer Invoice - IMS_CI_CustomerInvoice_FF | IMS_CI_CustomerInvoice_V1096_Example File | XML-interface file mit Testdaten

Interface system "Order Inbound"

Show XML Schemas

Interface | File | Description
Order Inbound - IMS_CI_Order | PxB_CI_OI_V3130.xsd PxB_CI_OI_V3120.xsd PxB_CI_OI_V3110.xsd PxB_CI_OI_V3100.xsd | XML Schema Order Inbound
Order Inbound - IMS_CI_ACK | PxB_CI_ACK.xsd | XML Schema Acknowledge

Show Examples

The examples are logically not coherent.. All nodes and fields are filled with valid values. But neither quantities, prices nor relations are matching with values of the production environment. Also all customer related values are virtual.

Interface | File | Description
Order Inbound - IMS_CI_Order | PxB_CI_OI_V3100.xml | XML-interface file with test data
Order Inbound - IMS_CI_ACK | PxB_CI_TACK_V1201.xml | XML-interface file with test data for technical acknowledge
Order Inbound - IMS_CI_ACK | PxB_CI_DACK_V1201_Error.xml | XML-interface file with test data for data acknowledge (with errors)
Order Inbound - IMS_CI_ACK | PxB_CI_DACK_V1201_OK.xml | XML-interface file with test data wfor data acknowledge (without errors)

Interface system "Status Outbound"

Show XML Schemata

Interface | File | Description
Status Outbound - IMS_CI_StatusOutbound | IMS_CI_StatusOutbound_V1031.xsd | XML Schema Status Outbound

Show Beispieldaten

The examples are logically not coherent.. All nodes and fields are filled with valid values. But neither quantities, prices nor relations are matching with values of the production environment. Also all customer related values are virtual.

Interface | File | Description
Status Outbound - IMS_CI_StatusOutbound | IMS_CI_StatusOutbound_V1095.xml IMS_CI_StatusOutbound_V1031.xml | XML-Schnittstellendatei with test data


eInvoice
See Also Send Feedback
eInvoice > eInvoice

Glossary Item Box

Show All Show All
Hide All Hide All

IMS offers you the transmission of electronically signed invoices per email. The using of eInvoice offers you a bunch of benefits:

  • the invoice is available as a digital document
  • easy archiving of the invoice
  • the legal storage period is the same as for invoices received by letter
  • we both take care about the environment by using reducing the amount of used paper, energy and garbage
  • due to the legal signing, the eInvoice complies with all statutory provisions within the European Union

Show informationen about our signatur

Root Certificate Authority - Installation

IMS is using the certificat "A-CERT Advanced" for signing the eInvoice.

Below you find some links with information about the installation process of a certificate and the legal basics. Please note that these information are only available in German language.

settings vor Adobe Reader

http://www.a-cert.at/php/cms_monitor.php?q=PUB-SUPPORT-A-CERT

A-CERT ADVANCED 3 is Microsoft XP- and Vista-ready. If a customer receives a document containing a certificate from A-CERT ADVANCED 3, his certificate storage will be updated automatically, if an internet connection is available. If there is no internet connection available or the access is restricted by firewalls or permissions, the certificate store has to be updates manually.

Ausführliche Informationen zum Stammzertifikatsupdate finden sich unter
http://www.a-cert.at/php/cms_monitor.php?q=PUB-TEXT-A-CERTs=03375qjv

Allgemeine Informationen zum Thema Zertifizierung finden sich unter
http://www.a-cert.at/php/cms_monitor.php?q=FAQ-A-CERT

Signaturgesetz:
http://www.signatur.rtr.at/de/legal/sigg.html

We invite you to use this link to download and sign the subscription document for eInvoice. If you have further questions, please contact us.

See Also

Getting Started
Subscription document


%%Phrase%%

Glossary

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

acknowledge

Acknowledges in our customer interfaces are used as an answer to data messages.

The "technical acknowledge" confirms the physical reception of the message file.

The "data acknowledge" confirms that the data has been processed. The "data acknowledge" contains information wheter the data was processed with or without errors. In case of an error the data acknowledge contains additional information about the error.

C

Customer Interfaces
The term "Customer Interfaces" defines all electronic data exchange interfaces between customers and partners with IMS.

Customer Invoice
The termin "Customer Invoice" defines all interfaces between IMS and our customers for sending electronical invoice data.

D

data acknowledge

The "data acknowledge" confirms that the data has been processed. The "data acknowledge" contains information wheter the data was processed with or without errors. In case of an error the data acknowledge contains additional information about the error.

F

FieldCode: Carrier
SCA-Code and name of the carrier

FieldCode: Company
Sode of the assigned company inside the IMS group

FieldCode: Container number
11-digit container number (without special characters)

FieldCode: DoA
Date of arrival

FieldCode: DoD
Date of departure (without a time)

FieldCode: DToA
Date and time of arrival

FieldCode: DToD
Date and time of the departure

FieldCode: invoiceID
Invoice number of the advised invoice

FieldCode: Netto-Auftragswert
Net value of the order as a sum of all known services.

FieldCode: Netto-Leistungswert
Net value of a single service

FieldCode: Notes
Notes and additional information

FieldCode: Port of Arrival
UnLoCode and name of the port of arrival

FieldCode: Port of Departure
UnLoCode and name of the port of departure

FieldCode: Seal number
The seal number assigned to this container

FieldCode: Service
Description of the performed service

FieldCode: Ship
Name of the ship

FieldCode: SoA
Railway station number (IBNR) of the station of arrival

FieldCode: SoD
Railway station number (IBNR) of the station of departure

FieldCode: ToA
Name of the terminal at the destination railway station

FieldCode: ToD
Name of the terminal at the departure railway station

FieldCode: wagon
Wagon number of the wagon the container is loaded

G

GUID

Global Unique Identifier

A hexadecimal string as unique identifier of a company, a data transmission or data record within the interface system "Customer Interfaces".

Format: "XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX"
Example: "936DA01F-9ABD-4D9D-80C7-02AF85C822A8"

I

Inbound
Inbound definies all data transmissions in direction to IMS.

O

Order Inbound
"Order Inbound" is the electronic reception of an customer order in the interface system of IMS.

Outbound
Outbound definies all data transmission from IMS to our customers or partners.

S

Status Outbound
"Status Outbound" defines electronically sended informations about changes in customer orders from IMS to the customer.

T

technical acknowledge
The "technical acknowledge" confirms the physical reception of the message file.


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you


IMS_CI_ACK

Glossary Item Box

Show All Show All
Hide All Hide All

This format defines the Acknowledge (technical and data), which is used as receipt for data transmissions between IMS and our partners.

current release : 1.2.0

Show technical specifications

Spezifikation | Description
File name extension | XML
Schema | IMS_Schemas.PxB_CI_ACK.V1-2-0-1
targetnamespec | <ns0:ACK xmlns:ns0="http://IMS_Schemas.PxB_CI_ACK.V1-2-0-1">

Show Release history

Spezifikation | Freigabedatum | Description
1.2.0.1 | 01.02.2011 | Betatest-Phase

Show Documentation XML Schema

XML Schema for IMS_CI_Schemas.PxB_CI_ACK.V1-2-0-1

Show Download / Examples

Spezifikation | Description
PxB_CI_ACK.xsd | XML Schema
PxB_CI_TACK_V1201.xml | XML-Interfacedatei containing test data for technical acknowledge
PxB_CI_DACK_V1201_Error.xml | XML-Interfacedatei containing test data for data acknowledge (with errors)
PxB_CI_DACK_V1201_OK.xml | XML-Interfacedatei containing test data for data acknowledge (without errors)

back


Glossary Item Box


IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "Container"
Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Container":

node/field/attribute

min

max

mand.

Format

 Description

Data (Version 3.1.3.0 and above)

1

1

ü

.

Container data
Temperature

0

1

.

Information about cooling
T1Consignee (Version 3.1.3.0 and above)

0

1

.

.

Information about the receiver of the goods regarding to the customs document

This information is mandatory, if the container contains dutiable goods and the receiver of the goods regarding to the customs document is not the receiver of the goods stated in the nodes "Relations".
References

0

1

.

References
Comments

0

1

.

Comments
Content

0

1

.

Information about the content of the container
Services

0

1

.

Information about the requested services

The node "Services" is not used in the current relase.

legend

back to parent node


IMS_CI_Schemas.IMS_CI_Order_V3_1_3_0 -Content Node "T1Consignee"
Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "T1Consignee":

This information is mandatory, if the container contains dutiable goods and the receiver of the goods regarding to the customs document is not the receiver of the goods stated in the nodes "Relations".

node/field/attribute | min | max | mand. | Format | Description
Name1 | 1 | 1 | ü | string(50) | Name of the receiver of the goods regarding the customs document
Name2 | 1 | 1 |  | string(50) | Extended name of the receiver of the goods regarding the customs document
Adress1 | 1 | 1 |  | string(50) | Address of the receiver of the goods regarding the customs document
Adress2 | 1 | 1 |  | string(50) | Extended Address of the receiver of the goods regarding the customs document
ZipCode | 1 | 1 |  | string(7) | Zip code
Town | 1 | 1 | ü | string(50) | Town
CountryCode | 1 | 1 | ü | string(2) | Country code (ISO 3166 ALPHA-2) (see Wikipedia)
VATID | 1 | 1 |  | string(13) | Tax identification number (see Wikipedia)

legend

back to parent node


IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 - Node "Invoice"

Glossary Item Box

Show All Show All
Hide All Hide All

Node | min | max | mand. | Format | Description
Invoice | 1 | 1 | ü |  | root node for this interface data record

legend

back


IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 - Node "Line"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Invoice":

Node | min | max | mand. | Format | Description
Line | 1 | n | ü |  | line of the invoice

legend

back to parent node


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Node "ACK"

Glossary Item Box

Show All Show All
Hide All Hide All

node/field/attribute | min | max | mand. | Format | Description
ACK | 1 | 1 | ü | . | Root nood for acknowledge

legend

back


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Node "ACK"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "ACK":

node/field/attribute

min

max

mand.

Format

 Description
Data

1

1

ü

.

 Information about acknowledge
Errors

0

1

.

.

Listing of all errors occurred

Only available for data acknowledge
References

0

1

.

.

Listing of all references

Only available for data acknowledge if no errors have been occurred

legend

back to parent node


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Node "Data"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Data":

node/field/attribute

min

max

mand.

Format

 Description
ID

1

1

ü

guid

ID of the transmission (ACK)
DateTime

1

1

ü

jjjj-mm-ttThh:mm:ss

 Date and time of the creation of this acknowledge
Code

1

1

ü

string(1)

type of acknowledge

Content | Description
T | technical acknowledge
D | data acknowledge
SendType

1

1

ü

string(1)

Type of communication

Content | Description
MAI | eMail
FTP | FTP push on the IMS-FTP-Server
OTH | other (type of communication unknown)
HandlingCode

1

1

ü

string(1)

Target system

Content | Description
P | production system
T | Test system
SenderID

1

1

ü

guid

GUID of the sender
ReceiverID

1

1

ü

guid

GUID of the receiver
IDReferenced

1

1

ü

guid

ID of the based file guid (The ID of the inbound order)
ErrorCode

1

1

ü

string(2)

Error code

Content | Description
OK | no errors
OE | Errors occurred (see node Errors)
DE | Errors occurred (see node Errors)

legend

back to parent node


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Node "Errors"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Errors":

node/field/attribute | min | max | mand. | Format | Description
Error | 1 | 99 | ü | . | single error message

legend

back to parent node


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Node "Data"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Error":

node/field/attribute | min | max | mand. | Format | Description
Text | 1 | 1 | ü | string | Error description

legend

back to parent node


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Node "Errors"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "References":

node/field/attribute | min | max | mand. | Format | Description
Orders | 1 | 1 | ü | . | Node containing the references of the based data record (inbound order)

legend

back to parent node


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Node "Errors"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Orders":

node/field/attribute | min | max | mand. | Format | Description
Order | 1 | 99 | ü | . | Node containing the references of the online order

%LegendebackParent%%


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Node "ACK"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Order":

node/field/attribute | min | max | mand. | Format | Description
RefExt | 0 | 1 |  | string | Order reference from the customers system
RefIMS | 0 | 1 | . | integer | order number of IMS
Container | 0 | 1 | . | . | Node containing the references for the containers

legend

back to parent node


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Node "Errors"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Container":

node/field/attribute | min | max | mand. | Format | Description
Container | 1 | 1 | ü | . | Node containing the reference for a single container

legend

back to parent node


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Node "ACK"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Container":

node/field/attribute

min

max

mand.

Format

 Description
RefExt

0

1

string

 Reference from the customers system
RefIMS

0

1

.

integer

 Reference from IMS
Content

0

1

.

.

Node containing the references for the container content

This node is not used in the current release.

legend

back to parent node


IMS_CI_Schemas.IMS_CI_SO_V1_0_3_1

Glossary Item Box

Show All Show All
Hide All Hide All

node/field/attribute | min | max | mand. | Format | Description
StatusOutbound | 1 | 1 | ü | . | Root Node for status messages

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_3_1 - Node "Status Outbound"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "StatusOutbound":

node/field/attribute | min | max | mand. | Format | Description
Prefix | 1 | 1 | ü | . | Technical data of the message
Status | 1 | 1 | ü | . | Data of the message

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_3_1 - Node "Prefix"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Prefix":

node/field/attribute

min

max

mand.

Format

 Description
Version

1

1

ü

string(7-7)

Release number of the interface

Please pay attention about this release number. We will inform you in time, if there are changes in the release.

current release number
1-0-3-1

ID

1

1

ü

string(36-36)

 Unique GUID of this message
DateTime

1

1

ü

jjjj-mm-ddThh:nn:ss

 Date and time of the creation of this message
Sendtype

1

1

ü

string(3-3)

Type of communication

Content | Description
MAI | email
FTP | FTP push/pull
HandlingCode

1

1

ü

string(1-1)

Test or production environment

Content | Description
P | Production
T | Test

Please pay attention about the content of this node. If we adress the test system, the status message should not be forwarded to your production system.
SenderID

1

1

ü

string(36-36)

GUID IMS
D4AF98C4-5930-430B-855B-B74785ACFEF6

ReceiverID

1

1

ü

string(36-36)

GUID of the receiver (customer)

Your GUID will be announced after you applied for the interface.
IDReferenced

0

0

.

string(36-36)

GUID of the previous/based message

Not used in this interface
ErrorCode

0

0

.

string(2)

Error code

Not used in this interface

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_3_1 - Node "Status"
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Status":

node/field/attribute | min | max | mand. | Format | Description
Code | 1 | 1 | ü | integer | Status-Code
Text | 1 | 1 | ü | string | Name of the Status-Code
Order | 1 | 1 | ü | . | Data about the order / countainer / status

legend

back

See Also

legends
Status Outbound Status-Codes


IMS_CI_Schemas.IMS_CI_SO_V1_0_3_1 - Node "Order"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Order":

node/field/attribute | min | max | mand. | Format | Description
Reference | 1 | 1 | ü | string | Customer reference of this order
IMSOrderID | 1 | 1 | ü | integer | Order ID of the customer order at IMS
IMSOfferID | 1 | 1 | ü | integer | ID of the offer of IMS this order is based on
IMSCustomerID | 1 | 1 | ü | integer | Customer ID of the customer at IMS
User | 1 | 1 | ü | string() | Name of the responsible user at the customer (for this order)
Container | 1 | 1 | ü | . | List of containers

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_3_1 - Node "Container"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Container":

node/field/attribute | min | max | mand. | Format | Description
Container | 1 | n | ü | . | Data for one container

legend

back


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Node "ACK"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Container":

node/field/attribute | min | max | mand. | Format | Description
IMSContainerID | 1 | 1 | ü | integer | Container ID at IMS
Number | 1 | 1 | ü | string(11) | Container number (without any format strings)
Type | 1 | 1 | ü | string | Type of container (see)
Scale | 1 | 1 | ü | string | Information about the lenght-/weight scale (see)
GrossWeight | 1 | 1 | ü | decimal(2) | Grossweight including tara
Data | 1 | 1 | ü | . | List of informations about the status

legend

back


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Node "Data"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Data":

node/field/attribute | min | max | mand. | Format | Description
Data | 1 | n | ü | . | Single status information

legend

back


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Node "ACK"
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Data":

node/field/attribute | min | max | mand. | Format | Description
Code | 1 | 1 | ü | string | Code (see Definition)
Value | 1 | 1 | ü | string | Value
Text | 0 | 1 |  | string | Additional information (see Definition)

legend

back

See Also

legends
Status Outbound Status-Codes


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5

Glossary Item Box

Show All Show All
Hide All Hide All

node/field/attribute | min | max | mand. | Format | Description
StatusOutbound | 1 | 1 | ü | . | Root Node for status messages

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Node "Status Outbound"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "StatusOutbound":

node/field/attribute | min | max | mand. | Format | Description
Prefix | 1 | 1 | ü | . | Technical data of the message
Status | 1 | 1 | ü | . | Data of the message

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Node "Prefix"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Prefix":

node/field/attribute

min

max

mand.

Format

 Description
Version

1

1

ü

string(7-7)

Release number of the interface

Please pay attention about this release number. We will inform you in time, if there are changes in the release.

current release number
1-0-3-1

ID

1

1

ü

string(36-36)

 Unique GUID of this message
DateTime

1

1

ü

jjjj-mm-ddThh:nn:ss

 Date and time of the creation of this message
Sendtype

1

1

ü

string(3-3)

Type of communication

Content | Description
MAI | email
FTP | FTP push/pull
HandlingCode

1

1

ü

string(1-1)

Test or production environment

Content | Description
P | Production
T | Test

Please pay attention about the content of this node. If we adress the test system, the status message should not be forwarded to your production system.
SenderID

1

1

ü

string(36-36)

GUID IMS
D4AF98C4-5930-430B-855B-B74785ACFEF6

ReceiverID

1

1

ü

string(36-36)

GUID of the receiver (customer)

Your GUID will be announced after you applied for the interface.
IDReferenced

0

0

.

string(36-36)

GUID of the previous/based message

Not used in this interface
ErrorCode

0

0

.

string(2)

Error code

Not used in this interface

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Node "Status"
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Status":

node/field/attribute | min | max | mand. | Format | Description
Code | 1 | 1 | ü | integer | Status-Code
Text | 1 | 1 | ü | string | Name of the Status-Code
Order | 1 | 1 | ü | . | Data about the order / countainer / status

legend

back

See Also

legends
Status Outbound Status-Codes


IMS_CI_Schemas.IMS_CI_SO_V1_0_8_5 - Node "Order"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Order":

node/field/attribute | min | max | mand. | Format | Description
Reference | 1 | 1 | ü | string | Customer reference of this order
IMSOrderID | 1 | 1 | ü | integer | Order ID of the customer order at IMS
IMSOfferID | 1 | 1 | ü | integer | ID of the offer of IMS this order is based on
IMSCustomerID | 1 | 1 | ü | integer | Customer ID of the customer at IMS
User | 1 | 1 | ü | string() | Name of the responsible user at the customer (for this order)
Container | 1 | 1 | ü | . | List of containers

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Node "Container"

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Container":

node/field/attribute | min | max | mand. | Format | Description
Container | 1 | n | ü | . | Data for one container

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Node Container

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Container":

node/field/attribute | min | max | mand. | Format | Description
IMSContainerID | 1 | 1 | ü | integer | Container ID at IMS
Number | 1 | 1 | ü | string(11) | Container number (without any format strings)
Type | 1 | 1 | ü | string | Type of container (see)
Scale | 1 | 1 | ü | string | Information about the lenght-/weight scale (see)
GrossWeight | 1 | 1 | ü | decimal(2) | Grossweight including tara
Data | 1 | 1 | ü | . | List of informations about the status

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Node Data

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Data":

node/field/attribute | min | max | mand. | Format | Description
Data | 1 | n | ü | . | Single status information

legend

back


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Node Data1
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Content of the node "Data":

node/field/attribute | min | max | mand. | Format | Description
Code | 1 | 1 | ü | string | Code (see Definition)
Value | 1 | 1 | ü | string | Value
Text | 0 | 1 |  | string | Additional information (see Definition)

legend

back

See Also

legends
Status Outbound Status-Codes


XML Vorlage

Glossary Item Box

Show All Show All
Hide All Hide All

Node | min | max | mand. | Format | Description

legend

back


Legende - Field-Code "net" (net value)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "net":

Value

Text

 Description used with Status-Code
net value

currency code

Net value of all known services for the order.

Format: XML decimal (see)

During the processing of your order additional expenses may occur.

(f.i. Craning, terminal services, ...)
205
net value

currency code

Net value of the additional service/costs

Format: XML decimal (see)

 206

See Also

Status Outbound Status-Codes


Legend - Field-Code "PoD" (Port of departure)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "PoD":

Value | Text | Description | used with Status-Code
UNLoCode | Name of the port | Port of departure | 205,

See Also

Status Outbound Status-Codes


Legend - Field-Code "PoA" (Port of arrival)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "PoA":

Value | Text | Description | verwendet bei Status-Code
UNLoCode | Name of the port | Port of arrival | 205,

See Also

Status Outbound Status-Codes


Legend - Field-Code "notes"
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "notes":

Value | Text | Description | verwendet bei Status-Code
<Notes> | . | Additional informations, notes, ... | 205, 206, 212, 213, 214, 215, 216, 217, 219

See Also

Status Outbound Status-Codes


Legend - Field-Code "service"
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "service":

Value | Text | Description | verwendet bei Status-Code
<Service> | . | Description of the provided service | 206

See Also

Status Outbound Status-Codes


Legende - Field-Code "company" (Company of IMS group)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "company":

Value | Text | Description | verwendet bei Status-Code
<Company shortcut> | Name of the company | Company within the IMS group in charge for this order (List) | 206

See Also

Companies within the IMS group
Status Outbound Status-Codes


Legende - Field-Code "containerno" (Container number)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "containerno":

Value | Text | Description | verwendet bei Status-Code
<Container number> | . | 11-digit container number (without format strings) | 207

See Also

Status Outbound Status-Codes


Legende - Field-Code "sealno" (Seal number)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "sealno":

Value | Text | Description | verwendet bei Status-Code
<seal number> | . | newly assigned seal number of the container | 208

See Also

Status Outbound Status-Codes


Legende - Field-Code "DoD" (Date departure)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "DoD":

Value | Text | Description | verwendet bei Status-Code
Date | . | Date of departure (without time) Format: XML date (see) | 212, 213, 214, 215, 216, 217

See Also

Status Outbound Status-Codes


Legende - Field-Code "DToD" (Date and time of departure)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "DToD":

Value | Text | Description | verwendet bei Status-Code
Date and time | . | Date and time of departure Format: XML date (see) | 219, 221

See Also

Status Outbound Status-Codes
Legend for XML schmas description


Legende - Field-Code "DoA" (Date of arrival
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "DoA":

Value | Text | Description | verwendet bei Status-Code
Date | . | Date of arrival (without time) Format: XML date (see) | 212, 213

See Also

Status Outbound Status-Codes


Legende - Field-Code "DToA" (Date and time of arrival)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "DToA":

Value | Text | Description | verwendet bei Status-Code
Date and time | . | Date and time of arrival Format: XML date (see) | 216, 217, 220

See Also

Status Outbound Status-Codes
Legend for XML schmas description


Legende - Field-Code "ship" (name of the ship)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "ship":

Value | Text | Description | verwendet bei Status-Code
<ship name> | . | Name of the ship | 212

See Also

Status Outbound Status-Codes


Legende - Field-Code "carrier"
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "ship":

Value | Text | Description | verwendet bei Status-Code
SCA-Code | Name of the carrier | SCA Code and name of the carrier | 212

See Also

Status Outbound Status-Codes


Legende - Field-Code "SoA" (Railway station of arrival)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "SoA":

Value | Text | Description | verwendet bei Status-Code
IBNR railway station number | Name of the railway station | IBNR of the railway station of arrival | 212, 213, 216, 217, 221

See Also

Status Outbound Status-Codes


Legende - Field-Code "ToA" (Terminal of arrival)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "ToA":

Value | Text | Description | verwendet bei Status-Code
<Name of the terminal> | . | Name of the terminal of arrival | 212, 213, 216, 217, 221

See Also

Status Outbound Status-Codes


Legende - Field-Code "SoD" (Railway station of destination)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "SoD":

Value | Text | Description | verwendet bei Status-Code
IBNR railway station number | Name of the railway station | IBNR of the railway station of departure | 216, 217, 220

See Also

Status Outbound Status-Codes


Legende - Field-Code "ToD" (Terminal of departure)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "ToD":

Value | Text | Description | verwendet bei Status-Code
<Name of the terminal> | . | Name of the terminal of departure | 216, 217, 220

See Also

Status Outbound Status-Codes


Legende - Field-Code "wagon" (Wagon number)
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "wagon":

Value | Text | Description | verwendet bei Status-Code
<Wagon number> | . | Wagon number | 216, 217

See Also

Status Outbound Status-Codes


Legend - Field-Code "invoiceID"
See Also Send Feedback

Glossary Item Box

Show All Show All
Hide All Hide All

Field code "service":

Value | Text | Description | verwendet bei Status-Code
<Invoice ID> | . | ID of the corresponding invoice | 218

See Also

Status Outbound Status-Codes