%%ItemTitle%%

IMS Customer Interfaces - Schnittstellen Dokumentation
Einleitung
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Customer Interfaces

Version 1.5.5

Release Datum 23.11.2017

(Dokument Version 3.9)

Das Schnittstellensystem Customer Interfaces umfasst alle Schnittstellen für die Kommunikation mit Kunden und Partner der IMS Firmengruppe.

Diese Schnittstellensammlung wird von IMS laufend erweitert und den Kundenwünschen angepasst. Bitte beachten Sie die aktuelle Versionsnummer der Dokumentation.

Diese Dokumentation steht Ihnen auch als online Dokumenation zur Verfügung.

---> What's new? <---

In der aktuellen Version sind folgende Schnittstellen verfügbar:

Schnittstellenbezeichnung | aktuelle Version | Beschreibung
WebCargo | . | Webapplikation zur Abfrage Ihrer Daten, Auftragsstatus, Offerte, Fahrpläne und Auslastung, Statistic, Rechnungen
Customer Invoice | 1.0.9.6 | Übertragung von IMS-Ausgangsrechnungen an Kunden
eRechnung | . | Zustellung der IMS-Ausgangsrechnungen als signiertes PDF per eMail
WebOrder | . | Erfassung von Aufträgen in der Webapplikation von IMS Gmbh durch Kunden
Order Inbound | 3.1.3.0 | Übertragung von Aufträgen an IMS GmbH
Status Outbound | 1.0.9.5 | Übertragung von Statusinformationen an Kunden

Show in eigener Sache ...

Wir sind bemüht, Fehler in dieser Dokumentation schnellstens zu beseitigen. Dazu bitten wir um Ihre geschätzte Mithilfe. Bitte nutzen Sie den Link "Sende Feedback" im Seitenkopf um uns über Rechtschreibfehler, fehlende/fehlerhafte Übersetzung oder Fehler in der Dokumentstruktur zu informieren.

Wir bedanken uns für Ihre Unterstützung.

Siehe auch

Support
Version history
Neuerungen

©IMS CARGO Austria GmbH 2017. Alle Rechte vorbehalten


Neuerungen
Siehe auch Sende Feedback
Übersicht > Neuerungen

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

hier finden Sie Informationen zu neuen Versionen der Dokumentation und Schnittstellen:

Version Veräffentlicht Beschreibung
1.5.5 23.11.2017

Änderung Versionsnummer auf V 1.0.9.6

(keine Änderung der XML/Feld-Struktur)

  • CI-CI Customer Invoices
1.5.4 22.11.2017

Neue Zollprozedur verfügbar:

  • Import: T1 + Gemeinschaftsware
    Kennzeichnet einen teilverzollten Container

siehe Legende Zollprozeduren
1.5.3 29.08.2017

Erweiterung der Status Outbound Meldungen (CI-SO)

  • 220 Road arrival
  • 221 Road departure
1.5.2 13.03.2017

Korrektur des Inhalts des Segments <container/container/data>

  • Der Knoten <ContainerType> wurde entfernt.
    (Dieser war nie Teil des XML-Schemas)
  • Die Anzahl der erlaubten Codes für den Knoten <HabisCode> wurden reduziert.

Sie finden die überarbeite Dokumentation hier:
IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Data"
IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "Data"
1.5.0 14.04.2017

Neue Version Schnittstelle CI-OI V3.1.3.0 Order Inbound

  • neue Version 3.1.3.0
  • neue Knoten im Knoten "Container\Data"
    CustomsDepartment, CustomsDepartmentname
    IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "Data"
    neue Codes für Zollprozeduren
    Legende Zollprozeduren
  • neuer Knoten "T1Consignee"
    IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "Container"
    IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "T1Consignee"
1.4.5 20.01.2017

Neue Version Schnittstelle CI-OI V3.1.2.0 Order Inbound

  • neue Version 3.1.2.0
  • neue Knoten im Knoten "Container\Data"
    NetValue, NetValueCurrencyCode
    IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Data"
  • neue Knoten im Knoten "Container\Content"
    HS Code
    IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Content"

Neue Version Schnittstelle CI-SO Status Outbound

  • neue Version 1.0.9.5
    neuer Field-code "invoiceID"
    neuer Status-code "218 Invoice advice"
    IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5

Siehe auch

Version history

Einleitung
Einleitung


Version history
Sende Feedback
Übersicht > Version history

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Version | Freigabedatum | Beschreibung
1.5.5 | 23.11.2017 | Änderung Versionsnummer Customer_Invoices auf V 1.0.9.6
1.5.4 | 22.11.2017 | Neue Zollprozedur (Import: T1 + Gemeinschaftsware)
1.5.3 | 29.08.2017 | Erweiterung Status-Outbound CI-SO (220 Road arrival, 221 Road departure)
1.5.2 | 13.06.2017 | Korrektur Knoten <Container/Data>
1.5.1 | 19.04.2017 | Korrekturen (Rechtschreibfehler, Korrektur fehlerhafte Links)
1.5.0 | 14.04.2017 | Neue Release Schnittstelle CI-OI V3.1.3.0 Order Inbound
1.4.5 | 20.01.2017 | Neue Release Schnittstelle CI-OI V3.1.2.0 Order Inbound Erweiterung Schnittstelle CI-SO Status Outbound
1.4.4 | 11.09.2015 | Korrekturen Schnittstellenbeschreibung CI-OI V3.1.1.0
1.4.3 | 26.01.2015 | Korrekturen Customer Invoice
1.4.2 | 01.07.2014 | Erweiterung CI-OI Segment RID
1.4.1 | 10.08.2013 | Implementierung Web Order und Status Outbound
1.3.3 | 01.03.2013 | Änderungen im Layout
1.3.2 | 23.11.2012 | Update Order Inbound XSD IMS_Schemas_Ext.V3_0_0_1
1.3.1 | 26.01.2012 | formale Änderungen
1.3.0 | 12.01.2012 | Implementierung Plattform Tradeshift Format CXML
1.2.0 | 12.01.2011 | Start Implementierung Order Inbound Dokumentation
1.1.3 | 03.01.2011 | diverse Korrekturen in Dokumentation
1.1.0 | 30.12.2010 | Freigabe zur Veröffentlichung
1.0.0 | 01.12.2010 | Entwicklungsrelease der Schnittstellendokumentation


Kontakt
Übersicht > Kontakt

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Für weitere Informationen und technische Rückfragen wenden Sie sich bitte an:

Ing. Roland Desort

IT-Manager

eMail: r.desort@imscargo.com

Telefon: +43 (0)1 20168-152
Fax: +43 (0)1 2902909-152

IMS CARGO Austria GmbH
Trillergasse 8
A-1210 Wien


Anmeldung zu Customer Interfaces
Siehe auch Sende Feedback
Übersicht > Anmeldung zu Customer Interfaces

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Wir freuen uns über ihr Interesse an unseren elektronischen Schnittstellen. Zur Aktivierung der Schnittstellen benötigen wir von Ihnen einige Informationen. Wir bitten Sie, uns eine eMail zu senden und uns darin folgende Informationen bekannt zu geben.

Show Anmeldung eRechnung

Benötigte Informationen:

Information Beschreibung
eMail-Adresse

IMS sendet die eMails mit den elektronisch signierten Ausgangsrechnungen im Format PDF an diese Adresse.

Sie erhalten am Beginn eine Freischaltungsmail mit einem Link, der zur Bestätigung der eMail-Adresse dient und die Freischaltung der Schnittstelle durchführt.

Show Anmeldung Customer Invoice

Benötigte Informationen:

Information | Beschreibung
gewähltes Datenformat | Angabe des gewählten Datenformats - IMS_CI_CustomerInvoice_FF - IMS_CI_CustomerInvoice_XML - openTrans_Invoive_1_0 - Tradeshift *
eMail-Adresse | IMS sendet die elektronischen Rechnungsdaten an diese email-Adresse.
Ansprechpartner | Name, Telefonnummer und eMail-Adresse des EDV-technischen Ansprechpartners
eMail-Adresse (Testbetrieb) | Die eMail-Adresse, an die IMS die ersten Ausgangsrechnungen sendet, die im Testbetrieb zur Überprüfung der Funktion der gemeinsamen Schnittstelle erstellt werden.
*) Bei der Übermittlung via Tradeshift erfolgt keine direkte Zustellung von Datenfiles an den Kunden. Die Rechnungen werden elektronisch an Tradeshift übermittelt und werden vom Kunden dort bearbeitet.

Show Anmeldung Order Inbound

Benötigte Informationen:

Information Beschreibung
gewählter Datenübertragungsweg

Übertragungsart | Beschreibung
FTP Abholung | Abholung der Dateien von Ihrem FTP Server durch IMS
Mail Zustellung | Zustellung der Dateien per email an IMS

eMail-Adresse

IMS sendet die Acknowledge-Meldungen an diese email-Adresse.

(bei Auswahl des Übertragswegs eMail)

IP-Adresse des FTP Clients

Die IP des FTP-Clients, der auf den IMS FTP-Server zugreift.

(bei Auswahl des Übertragungswegs FTP)

Die Bekanntgabe der IP-Adresse des FTP-Clients an IMS ist notwendig, um dem FTP-Client den Zugriff auf den FTP-Server zu gestatten. Aus Sicherheitsgründen wird der Zugriff von FTP Clients mit anderen IP-Adressen von IMS blockiert.

Ansprechpartner

 Name, Telefonnummer und eMail-Adresse des EDV-technischen Ansprechpartners

Show Anmeldung Web Order

Benötigte Informationen:

Information | Beschreibung
unterfertigte Nutzungserklärung | Download PDF
Liste der berechtigten Mitarbeiter | Geben Sie IMS die Namen und email-Adressen Ihrer Mitarbeiter bekannt, die zur Erfassung von online-Aufträgen berechtigt sind.
Bekanntgabe Web Administrator | Geben Sie IMS den Namen und die eMail-Adresse Ihres Mitarbeiters bekannt, der Zugriff auf die Systemfunktionen von Web Cargo / Web order erhält. Diese Person ist u.a. berechtigt, die Systemeinstellungen für Ihre Kundendaten zu warten.

Show Anmeldung Status Outbound

Benötigte Informationen:

Information Beschreibung
gewählter Übertragungsweg

Übertragungsart | Beschreibung
FTP Versand | Upload der Daten auf den FTP Server des Kunden durch IMS
FTP Abholung | Abholung der Daten vom FTP Server der IMS durch den Kunden
Mail Zustellung | Zustellung der Dateien per email an den Kunden durch IMS

eMail-Adresse

IMS sendet die Dateien an diese email-Adresse.

(bei Auswahl des Übertragswegs Mail Zustellung)

IP Adresse FTP Server

Die IP Adresse Ihres FTP Servers. Weiters die Zugangsdaten für IMS und der Pfad des Uploadverzeichnisses.

(bei Auswahl des Übertragswegs FTP Versand)
IP Adresse FTP Client

die IP Adresse Ihres FTP Clients.

(bei Auswahl des Übertragswegs FTP Zustellung)

Die Bekanntgabe der IP-Adresse des FTP-Clients an IMS ist notwendig, um dem FTP-Client den Zugriff auf den FTP-Server zu gestatten. Aus Sicherheitsgründen wird der Zugriff von FTP Clients mit anderen IP-Adressen von IMS blockiert.

Bitte senden Sie die Daten an:

Ing. Roland Desort

IT-Manager

eMail: r.desort@imscargo.com

Telefon: +43 (0)1 20168-152

Fax: +43 (0)1 2902909-152

Siehe auch

Tutorials
eRechnung
Schnittstelle Customer Invoice
Schnittstelle Order Inbound
Schnittstelle Status Outbound


WebCargo
Siehe auch Sende Feedback
WebCargo > WebCargo

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

WebCargo umfasst alle Services, die Ihnen als Kunden von IMS in der Webapplikation zur Verfügung gestellt werden.

WebCargo umfasst unter anderen folgende Funktionen:

  • Verwaltung der Zugänge zu WebCargo für Ihre Mitarbeiter
  • Erfassung von online Aufträgen (siehe WebOrder)
  • Abfrage/Suche der für Sie hinterlegten Offerte
  • Druck der für Sie hinterlegten Offerte
  • Abfrage der Nebenspesenvereinbarungen
  • Abfrage/Suche Ihrer Aufträge bei IMS
  • Abfrage der Züge der IMS und deren Auslastung
  • Statistische Auswertungen
  • Abfrage offener Posten

Eine Auswahl an Screenshots zu den Funktionen können Sie hier abrufen.

Bitte beachten Sie unsere Nutzungsbedingungen.

Zur Anmeldung an WebCargo wenden Sie sich bitte an Ihren Betreuer bei IMS.

Siehe auch

WebOrder

Einleitung
Einleitung


WebOrder
Siehe auch Sende Feedback
WebOrder > WebOrder

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Als Teil unserer Service WebCargo bietet IMS Ihnen die Möglichkeit, Aufträge online in unserer Webapplikation zu erfassen.

Die online Erfassung bietet Ihnen unter andere folgende Funktion:

  • Zugangssteuerung für Ihre Mitarbeiter
  • Erfassung von Vorlagen für wiederkehrende Auftragsarten
  • Vorerfassung von Aufträgen zur späteren Einreichung
  • Statusübersicht über alle online erfassten Aufträge

Eine Auswahl an Screenshots zu den Funktionen können Sie hier abrufen. (Präsentation WebCargo)

Bitte beachten Sie unsere Nutzungsbedingungen.

Zur Anmeldung an WebOrder wenden Sie sich bitte an Ihren Betreuer bei IMS.

Siehe auch

WebCargo

Einleitung
Einleitung


Schnittstelle Customer Invoice
Schnittstelle Customer Invoice > Schnittstelle Customer Invoice

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Die Schnittstelle Customer Invoice dient zur Übermittlung von Ausgangsrechnungend der IMS an die Kunden.

Es stehen folgende Schnittstellentypen zur Verfügung:

Schnittstellentype | Version | Freigabedatum | Beschreibung
IMS_CI_CustomerInvoice_FF | IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 | 23.11.2017 | Flatfile (.csv)
IMS_CI_CustomerInvoice_XML | IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 | 23.11.2017 | XML-Datei
openTrans_Invoive_1_0 *) | IMS_CI_Schemas.openTRANS_INVOICE_1_0_all_in_one_V1096 | 23.11.2017 | XML-Datei im Format openTrans *)
Tradeshift | Zustellung via B2B Plattform Tradeshift | 01.02.2012 | **)

*) Das Format Invoice "openTrans" ist ein frei verfügbares XML-basierendes Modell zum Handling von Geschäftsprozesse unter der Leitung des Fraunhofer-Institut für Arbeitswirtschaft und Organisation IAO. Die Schnittstellenbeschreibung und die XML-Schemata können unter diesem Link bezogen werden.

Bitte beachten Sie, dass wir den Schnittstellentyp openTrans nur in der Version 1.0 unterstützen. Das von openTrans angebotene Schema 2.0 wird zur Zeit noch nicht unterstützt.

**) Rechnungen und Gutschriften werden von IMS an die B2B Web-Plattform TradeShift zu Handen des Kunden übermitteln.

Sie können entsprechend Ihren EDV-technischen Möglichkeiten frei zwischen den obig beschriebenen Datenformaten wählen. (siehe auch Anmeldung zum elektronischen Datenaustausch)

Um die einwandfreie Funktion der gemeinsamen Schnittstelle zu gewährleisten, empfehlen wir einen Testbetrieb, während dessen die Daten geprüft werden.

Zur optimalen Nutzung empfehlen wir Ihnen auch die Anmeldung zum Empfang von elektronischen Rechnungen (eRechnung). Nähere Informationen dazu finden Sie hier.
Vor allem die zeitnahe Zustellung der eRechnung und elektronischen Rechnungsdaten beschleunigt die Verarbeitung.
Eine Schnittstellendatei enthält immer nur einen Beleg (Rechnung/Gutschrift).

Show technische Spezifikationen

Die nachfolgenden, technischen Spezifikationen umfassen nur die Beschreibung der Daten für den direkten Datenaustausch. Bei der Übermittlung via B2B Plattformen (z.B. Tradeshift) erfolgt kein direkter Datenaustausch.

Spezifikation | Beschreibung
Dateiname

IMSAT_Cxxxxxxxx_Byyyyyyyyy_zz.sss

Platzhalter | Inhalt
xxxxxxxx | Ihre Kundennummer bei IMS als 8-stellige Nummer inkl. führende Nullen
yyyyyyyyy | Die Belegnummer (z.B. Rechnungsnummer) als 9-stellige Nummer inkl. führende Nullen
zz

Belegart

Code | Belegart
AR | Ausgangsrechnung
GU | Gutschrift
sss | Dateierweiterung (z.B. XML, CSV)

encoding | "utf-8"
eMail

Die eMails werden als "plain-text" eMails versendet.

Der Absender lautet CustomerInterfaceRobot@imscargo.com.

Bitte achten Sie darauf, dass dieser Absender nicht von Ihrem Spam-Filter geblocked wird.

Der Betreff lautet "Customer Invoice Datensatz zu Rechnung Nr. yyyyyyyyy".
Empfänger | Sie geben am Anmeldeformular die eMail-Adresse des Empfänger an. Bitte sorgen Sie für die regelmäßige Abfrage dieses Mailkontos und melden Sie Änderungen der eMail-Adresse unverzüglich an IMS.


IMS_CI_CustomerInvoice_FF
Schnittstelle Customer Invoice > Flatfile - IMS_CI_CustomerInvoice_FF > IMS_CI_CustomerInvoice_FF

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Dieses Format liefert Ihnen die Ausgangsrechnung der IMS als Flatfile mit der Dateierweiterung .CSV.

aktuelle Version: 1.0.9.6

Show technische Spezifikationen

Spezifikation | Beschreibung
Dateierweiterung | CSV
Datenformat | IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096
Feldtrennzeichen | <Tab> (siehe ASCII-Tabelle)

Aus technischen Gründen liegt der eMail mit der Rechnungsdatei auch eine XML-Datei bei, in der die eMail-Adresse des Empfängers enthalten ist. Diese Datei kann vom Empfänger ignoriert werden.

Show Versionshistorie

Version | Freigabedatum | Beschreibung
1.0.9.6 | 22.11.2017 | Änderung Versionsnummer keine Änderung zur Version 1.0.2.4
1.0.2.4 | 12.01.2012 | Implementierung CXML (Tradeshift)
1.0.0 | 01.10.2010 | Produktionsfreigabe

Show Struktur

Spaltenbeschreibung für IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096

Show Beispieldaten

Datei | Beschreibung
IMS_CI_CustomerInvoice_V1096_Example File | CSV-Interfacedatei mit Testdaten V 1.0.9.6
IMS_CI_CustomerInvoice_V1-0-2-4_Example File | CSV-Interfacedatei mit Testdaten V 1.0.2.4

zurück


IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 - Spaltendefinitionen
Sende Feedback
Schnittstelle Customer Invoice > Flatfile - IMS_CI_CustomerInvoice_FF > Spaltenbeschreibung > IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 - Spaltendefinitionen

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Beschreibung of the columns:

No. Knoten/Feld min max Pflicht

Format

 Beschreibung
1 | CreationDate | 1 | 1 | ü | jjjj-mm-ddThh:nn:ss | Datum und Uhrzeit der Erstellung der Schnittstellendatei
2 DocumentType 1 1 ü string(2)

Art des Dokuments (Legende)
3 | InvoiceNo | 1 | 1 | ü | integer | Belegnummer (Rechnungsnummer, Gutschriftsnummer, ...)
4 | InvoiceDate | 1 | 1 | ü | jjjj-mm-tt | Belegdatum
5 Test 1 1 ü integer

Unterscheidung Test-/Produktionsbetrieb

Wert | Bedeutung
0 | Produktionsbetrieb
1 | Testbetrieb
6 | MailTechnicalResponse | 1 | 1 | ü | string | eMail-Adresse bei IMS für EDV-technische Anfragen bezüglich dieses Belegs
7 | IMSUID | 1 | 1 | ü | string | Umsatzsteueridentnummer der IMS
8 | ReceiverID | 1 | 1 | ü | integer | IMS-interne Kundennummer des Rechnungsempfängers
9 | ReceiverName1 | 1 | 1 | ü | string | Firmenbezeichnung des Rechnungsempfängers
10 | ReceiverName2 | 1 | 1 | string | erweiterte Firmenbezeichnung des Rechnungsempfängers
11 | ReceiverAdress1 | 1 | 1 | ü | string | Strasse und Hausnummer der Anschrift des Rechnungsempfängers
12 | ReceiverAdress2 | 1 | 1 | string | erweitere Anschrift des Rechnungsempfängers
13 | ReceiverZip | 1 | 1 | ü | string | Postleitzahl der Anschrift des Rechnungsempfängers
14 | ReceiverTown | 1 | 1 | ü | string | Ort der Anschrift des Rechnungsempfängers
15 | ReceiverUID | 1 | 1 | ü | string | Umsatzsteueridentnummer des Rechnungsempfängers
16 | DatePayment | 1 | 1 | ü | jjjj-mm-tt | Zahlungsziel laut gültiger Zahlungsvereinbarung
17 | LineNo | 1 | 1 | ü | integer | fortlaufende Positionsnummer innerhalb des aktuellen Belegs
18 | IMSOrderID | 1 | 1 | ü | integer | Auftragsnummer der IMS (IMS-Referenz)
19 | CustomerOrderRef | 1 | 1 | string | Referenz des Auftraggebers
20 | CustomerOrderDate | 1 | 1 | jjjj-mm-tt | Datum des Auftragseingangs bei IMS
21 | ServiceDateFrom | 1 | 1 | ü | jjjj-mm-tt | Beginn der Leistungserbringung
22 | ServiceDateUntil | 1 | 1 | ü | jjjj-mm-tt | Ende der Leistungserbringung
23 | Sender | 1 | 1 | string | Name, Land, Plz und Ort des Absenders
24 | Recipient | 1 | 1 | string | Name, Land, Plz und Ort des Empfängers
25 | IMSContact | 1 | 1 | string | Name des Sachbearbeiters bei IMS
26 | ShipName | 1 | 1 | string | Name des Schiffes
27 | POL | 1 | 1 | string | Bestimmungsland
28 | POD | 1 | 1 | string | Herkunftsland
29 | ETA | 1 | 1 | jjjj-mm-ttThh:nn:ss | Ladeschluss(Export)/Ankunftstermin(Import) Hafen
30 | OfferText | 1 | 1 | ü | string | Offertbeschreibung
31 ContainerText 1 1 ü string (13) Containernummer
Format: "xxxx nnnnnn-n"
32 | Scale | 1 | 1 | ü | string | Staffelbeschreibung
33 | Services | 1 | 1 | ü | string | verrechnete Leistung(en)
34 | Quantity | 1 | 1 | ü | integer | Anzahl der verrechneten Leistungseinheiten
35 | NetValue | 1 | 1 | ü | decimal (9,2) | verrechneter Nettobetrag
36 | TaxValue | 1 | 1 | ü | decimal (9,2) | verrechnete Umsatzsteuer
37 | TaxPercent | 1 | 1 | ü | decimal(3,2) | Umsatzsteuersatz in Prozent
38 | Memo | 1 | 1 | string | Notizen/Informationen zur Position
39 | Info | 1 | 1 | string | Notizen/Informationen zur Position
40 | SumLineCount | 1 | 1 | ü | integer | Anzahl Positionen der Rechnung
41 | SumNetValue | 1 | 1 | ü | decimal (9,2) | Nettogesamtwert der Rechnung
42 | SumTaxValue | 1 | 1 | ü | decimal (9,2) | Umsatzsteuergesamtwert der Rechnung

Legende

zurück


openTRANS_INVOICE_1_0
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > openTRANS_INVOICE_1_0

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Dieses Format liefert Ihnen die Ausgangsrechnung der IMS als XML-Dokument im Format openTrans 1.0 mit der Dateierweiterung .XML

aktuelle Version: 1.0.9.6

Das Format Invoice "openTrans" ist ein frei verfügbares XML-basierendes Modell zum Handling von Geschäftsprozesse unter der Leitung des Fraunhofer-Institut für Arbeitswirtschaft und Organisation IAO. Die Schnittstellenbeschreibung und die XML-Schemata können unter diesem Link bezogen werden.

Bitte beachten Sie, dass wir den Schnittstellentyp openTrans nur in der Version 1.0 unterstützen. Das von openTrans angebotene Schema 2.0 wird zur Zeit noch nicht unterstützt.
IMS verwendet das Subset "openTRANS_INVOICE_1_0" des openTrans-Schnittstellensystems in leicht abgewandelter Form als "IMS-Subset". Dies ist notwendig, um spezifische Codes und Formate verwenden zu können. In dieser Dokumentation wird immer das IMS-Subset beschrieben. Bitte verwenden Sie das in dieser Dokumentation enthaltene XML-Schema (siehe Downloads am Ende dieser Seite)

Show technische Spezifikationen

Spezifikation | Beschreibung
Dateierweiterung | XML
Schema | IMS_CI_Schemas.openTRANS_INVOICE_1_0_all_in_one
targetnamespec | <ns0:INVOICE version="1.0" xmlns:ns0="http://www.opentrans.org/XMLSchema/1.0">

Show Versionshistorie

Version | Freigabedatum | Beschreibung
1.0.9.6 | 23.11.2017 | Änderung der Versionsnummer auf 1.0.9.6 (Keine Änderungen in der XML-Struktur)
1.0.2.4 | 12.01.2012 | Implementierung CXML
1.0.0 | 01.10.2010 | Produktsionsfreigabe

Show Dokumentation XML Schema

IMS_CI_Schemas.openTRANS_INVOICE_1_0_all_in_one

Show Downloads / Beispiele

Datei | Beschreibung
openTRANS_INVOICE_1_0_all_in_one File_V1096 | XML schema V 1.0.9.6
IMS_openTRANS_INVOICE_1_0_Example File_V1096 | XML-interface file with example data V 1.0.9.6
openTRANS_INVOICE_1_0_all_in_one File | XML Schema
IMS_openTRANS_INVOICE_1_0_Example File | XML-Interfacedatei mit Testdaten

zurück


openTRANS_INVOICE_1_0_all_in_one - Knoten "INVOICE"
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Knoten "INVOICE"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Das XML-Schema der Schnittstelle openTrans ist eine komplexe Zusammenfassung aller XML-Knoten. Wir verwenden für unsere Schnittstelle "Customer Invoice" nur einen Teil der Knoten (ab Knoten "INVOICE"). Aus diesem Grund werden in dieser Dokumentation nur die verwendeten Knoten beschrieben.

Knoten min max Pflicht Format Beschreibung
INVOICE 1 1 ü Root Knoten für Rechnungsdatensatz

Attribut | Inhalt
version | "1.0"

Legende

zurück


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "INVOICE":

Knoten | min | max | Pflicht | Format | Beschreibung
INVOICE_HEADER | 1 | 1 | ü |  | Kopfdaten zum Beleg
INVOICE_ITEM_LIST | 1 | 1 | ü |  | Rechnungspositionen
INVOICE_SUMMARY | 1 | 1 | ü |  | Summenwerte zum Beleg

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_HEADER"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_HEADER"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "INVOICE_HEADER":

Knoten | min | max | Pflicht | Format | Beschreibung
CONTROL_INFO | 1 | 1 | ü |  | technische Informationen zur Schnittstellendatei
INVOICE_INFO | 1 | 1 | ü |  | Informationen zum Beleg

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_ITEM_LIST"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_ITEM_LIST"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "INVOICE_ITEM_LIST":

Knoten/Attribute | min | max | Pflicht | Format | Beschreibung
INVOICE_ITEM | 1 | 1 | ü |  | Rechnungsposition

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_SUMMARY"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_SUMMARY"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "INVOICE_SUMMARY":

Feld | min | max | Pflicht | Format | Beschreibung
TOTAL_ITEM_NUM | 1 | 1 | ü | integer | Anzahl Rechnungspositionen
TOTAL_AMOUNT | 1 | 1 | ü | decimal (9,2) | Gesamtrechnungsbetrag Netto
TOTAL_TAX_AMOUNT | 1 | 1 | ü | decimal (9,2) | Gesamtbetrag Umsatzsteuer
TOTAL_GROS_AMOUNT | 1 | 1 | ü | decimal (9,2) | Gesamtrechnungsbetrag brutto

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "CONTROL_INFO"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "CONTROL_INFO"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "CONTROL_INFO":

Feld | min | max | Pflicht | Format | Beschreibung
STOP_AUTOMATIC_PROCESSING | 1 | 1 |  | string | Unterscheidung Test-/Echtbetrieb Wird in diesem Feld ein Text übertragen, handelt es sich um einen Beleg im Testbetrieb. Ein leeres Feld identifiziert eine Rechnung aus dem Produktionsbetrieb Text für Identifikation Testbetrieb: "Testmodus! Bitte nicht in Produktionsumgebung überleiten"
GENERATOR_INFO | 1 | 1 | ü | string | Angaben zum Art des Belegs und Absender
GENERATION_DATE | 1 | 1 | ü | jjjj-mm-ttThh:nn:ss | Datum und Uhrzeit der Erstellung der Schnittstellendatei

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_INFO"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_INFO"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "INVOICE_INFO":

Knoten/Feld min max Pflicht

Format

 Beschreibung
INVOICE_ID 1 1 ü integer

Belegnummer (Rechnungsnummer)
INVOICE_DATE | 1 | 1 | ü | jjjj-mm-ttThh:mm:ss | Belegdatum
DELIVERY_DATE | 1 | 1 | ü | Zeitraum der Leistungserbringung
BUYER_PARTY | 1 | 1 | ü | Angaben zum Auftraggeber
SUPPLIER_PARTY | 1 | 1 | ü | Angaben zum Rechnungsleger
INVOICE_PARTY | 1 | 1 | ü | Angaben zum Rechnungsempfänger
PRICE_CURRENCY | 1 | 1 | ü | string (3) | Belegwährung
TERMS_AND_CONDITIONS | 1 | 1 | string | Link zu den "allgemeinen österreichischen Spediteurbedingungen (AÖSp)"
REMARK 1 n

string

Format:

"Zahlungsziel: jjjj-mm-tt"

Angaben zum Zahlungsziel

Attribut | Inhalt
type | "invoice"

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_ITEM"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "INVOICE_ITEM"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "INVOICE_ITEM":

Knoten/Feld min max Pflicht

Format

 Beschreibung
LINE_ITEM_ID | 1 | 1 | ü | integer | laufende Positionsnummer
ARTICLE_ID | 1 | 1 | ü | Containerdaten und Leistungsbeschreibung
QUANTITY | 1 | 1 | ü | integer | Anzahl verrechnete Leistungseinheiten
ORDER_UNIT | 1 | 1 | ü | string | immer "ZZ"
ARTICLE_PRICE 1 1 ü

Angaben zum Preis

Attribut | Inhalt
type | "net_customer"
ORDER_REFERENCE | 1 | 1 | ü | Referenzen aus Kundenauftrag
SUPPLIER_ORDER_REFERENCE | 1 | 1 | ü | IMS-Referenzen
REMARK 1 n erweiterte Informationen zur Rechnungspostion

Attribut | Inhalt | Text
type | "invoice" | Firmenname, Plz und Ort des Absenders
type | "receiver" | Firmenname, Plz und Ort des Empfängers
type | "PIC" | Name des Sachbearbeiters bei IMS
type | "ship" | Name des Schiffs
type | "POL" | Bestimmungsland
type | "POD" | Herkunftsland
type | "ETA" | Ladeschluss, bzw. Ankunftszeit im Hafen
type | "relation" | Angaben zum zugrundeliegenden Offert

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "ARTICLE_ID"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "ARTICLE_ID"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "ARTICLE_ID":

Knoten/Feld | min | max | Pflicht | Format | Beschreibung
SUPPLIER_AID | 1 | 1 | ü | string (13) | Containernummer Format: "xxxx nnnnnn-n"
DESCRIPTION_SHORT | 1 | 1 | ü | string | Staffelbeschreibung
DESCRIPTION_LONG | 1 | 1 | ü | integer | verrechnete Leistung(en)

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "ARTICLE_PRICE"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "ARTICLE_PRICE"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "ARTICLE_PRICE":

Knoten/Feld | min | max | Pflicht | Format | Beschreibung
PRICE_AMOUNT | 1 | 1 | ü | decimal (9,2) | Einzelpreis der Leistungseinheit
PRICE_LINE_AMOUNT | 1 | 1 | ü | decimal (9,2) | Nettobetrag
TAX | 1 | 1 | ü | decimal (9,2) | Umsatzsteuersatz in Prozent
TAX_AMOUNT | 1 | 1 | ü | decimal (9,2) | Umsatzsteuerbetrag
PRICE_QUANTITY | 1 | 1 | ü | integer | Anzahl fakturierte Leistungseinheiten

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "ORDER_REFERENCE"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "ORDER_REFERENCE"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "ORDER_REFERENCE":

Knoten/Feld | min | max | Pflicht | Format | Beschreibung
ORDER_ID | 1 | 1 | ü | string | Auftragsreferenz des Auftraggebers
LINE_ITEM_ID | 1 | 1 | ü | integer | immer "0"
ORDER_DATE | 1 | 1 | ü | jjjj-mm-ttT00:00:00.000 | Eingangsdatum des Auftrags bei IMS

Legende

zurück zum übergeordneten Knoten


openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "SUPPLIER_ORDER_REFERENCE"
Sende Feedback
Schnittstelle Customer Invoice > XML - openTRANS_INVOICE > XML Schemas > openTRANS_INVOICE_1_0_all_in_one - Inhalt des Knoten "SUPPLIER_ORDER_REFERENCE"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "SUPPLIER_ORDER_REFERENCE":

Knoten/Feld | min | max | Pflicht | Format | Beschreibung
SUPPLIER_ORDER_ID | 1 | 1 | ü | integer | IMS-Auftragsummer (IMS Referenz)
SUPPLIER_ORDER_ITEM_ID | 1 | 1 | ü | integer | immer "0"

Legende

zurück zum übergeordneten Knoten


IMS_CI_CustomerInvoice_XML
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > IMS_CI_CustomerInvoice_XML

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Dieses Format liefert Ihnen die Ausgangsrechnung der IMS als XML-Dokument mit der Dateierweiterung .XML.

aktuelle Version: 1.0.9.6

Show technische Spezifikationen

Spezifikation | Beschreibung
Dateierweiterung | XML
Schema | IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096
targetnamespec | <ns0:Invoice xmlns:ns0=http://IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096>

Show Versionshistorie

Version | Freigabedatum | Beschreibung
1.0.9.6 | 23.11.2017 | Korrekturen IMS_CustomerInvoice2
1.0.2.4 | 01.02.2012 | Implementierung CXML
1.0.0 | 01.10.2010 | Produktsionsfreigabe

Show Dokumentation XML Schema

XML Schema für IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096

Show Downloads / Beispiele

Datei | Beschreibung
IMS_CI_CustomerInvoice2_V1096 File | XML Schema V 1.0.9.6
IMS_CI_CustomerInvoice2_V1096_Example File | XML-Interfacedatei mit Testdaten V 1.0.9.6
IMS_CI_CustomerInvoice2_V1-0-2-4 File | XML Schema V 1.0.2.4 (veraltet)
IMS_CI_CustomerInvoice2_V1-0-2-4_Example File | XML-Interfacedatei mit Testdaten V 1.0.2.4 (veraltet)

zurück


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Summery"
Sende Feedback
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemas > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Summery"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Summery":

Knoten/Feld | min | max | Pflicht | Format | Beschreibung
LineCount | 1 | 1 | ü | integer | Anzahl Positionen innerhalb des Belegs
NetValue | 1 | 1 | ü | decimal (9,2) | Gesamtnettobetrag des Belegs
TaxValue | 1 | 1 | ü | decimal (9,2) | Gesamtumsatzstueerbetrag des Belegs

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Line"
Sende Feedback
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemas > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Line"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Line":

Knoten/Feld | min | max | Pflicht | Format | Beschreibung
LineNo | 1 | 1 | ü | integer | fortlaufende Positionsnummer innerhalb des Belegs
IMSOrderID | 1 | 1 | ü | integer | Auftragsnummer der IMS (IMS-Referenz)
CustomerOrderRef | 1 | 1 |  | string | Referenz des Auftraggebers
CustomerOrderDate | 1 | 1 |  | jjjj-mm-tt | Datum des Auftragseingangs bei IMS
ServiceDateFrom | 1 | 1 | ü | jjjj-mm-tt | Beginn der Leistungserbringung
DerviceDateUntil | 1 | 1 | ü | jjjj-mm-tt | Ende der Leistungserbringung
Sender | 1 | 1 | ü | string | Name, Land, Plz und Ort des Absenders
Recipient | 1 | 1 | ü | string | Name, Land, Plz und Ort des Empfängers
IMSContact | 1 | 1 | ü | string | Name des Sachbearbeiters bei IMS
ShipName | 0 | 1 |  | string | Name des Schiffes
POL | 0 | 1 |  | string | Bestimmungsland
POD | 0 | 1 |  | string | Herkunftsland
ETA | 0 | 1 |  | jjjj-mm-ttThh:nn:ss | Ladeschluss(Export)/Ankunftstermin(Import) Hafen
OfferText | 1 | 1 | ü | string | Offertbeschreibung
ContainerText | 1 | 1 | ü | string (13) | Containernummer Format: "xxxx nnnnnn-n"
Scale | 1 | 1 | ü | string | Staffelbeschreibung
Services | 1 | 1 | ü | string | verrechnete Leistung(en)
Quantity | 1 | 1 | ü | integer | Anzahl der verrechneten Leistungseinheiten
NetValue | 1 | 1 | ü | decimal (9,2) | verrechneter Nettobetrag
TaxValue | 1 | 1 | ü | decimal (9,2) | verrechnete Umsatzsteuer
TaxPercent | 1 | 1 | ü | decimal (3,2) | Umsatzsteuersatz in Prozent
Memo | 0 | 1 |  | string | Notizen/Informationen zur Position
Info | 0 | 1 |  | string | Notizen/Informationen zur Position

Legende

%%backParent%


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Lines"
Sende Feedback
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemas > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Lines"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Lines":

Knoten | min | max | Pflicht | Format | Beschreibung
Line | 1 | n | ü |  | Rechnungsposition

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Recipient"
Sende Feedback
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemas > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Recipient"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Recipient":

Knoten/Feld | min | max | Pflicht | Format | Beschreibung
ID | 1 | 1 | ü | integer | IMS-interne Kundennummer des Rechnungsempfängers
Name1 | 1 | 1 | ü | string | Firmenbezeichnung des Rechnungsempfängers
Name2 | 0 | 1 |  | string | erweiterte Firmenbezeichnung des Rechnungsempfängers
Street1 | 1 | 1 | ü | string | Strasse und Hausnummer der Anschrift des Rechnungsempfängers
Street2 | 0 | 1 |  | string | erweitere Anschrift des Rechnungsempfängers
Zip | 1 | 1 | ü | string | Postleitzahl der Anschrift des Rechnungsempfängers
Town | 1 | 1 | ü | string | Ort der Anschrift des Rechnungsempfängers
CountryCode | 1 | 1 | ü | string (2) | Länderkürzel (siehe Liste)
UID | 1 | 1 |  | string | Umsatzsteueridentnummer des Rechnungsempfängers

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Prefix"
Sende Feedback
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemas > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Prefix"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Prefix":

Knoten/Feld min max Pflicht

Format

 Beschreibung
CreationDate | 1 | 1 | ü | jjjj-mm-ddThh:nn:ss | Datum und Uhrzeit der Erstellung der Schnittstellendatei
Guid 1 1 ü string(2)

eindeutige GUID der Schnittstellendatei
Test 1 1 ü integer

Unterscheidung Test-/Produktionsbetrieb

Wert | Bedeutung
0 | Produktionsbetrieb
1 | Testbetrieb
MailTechnicalResponse | 1 | 1 | ü | string | eMail-Adresse bei IMS für EDV-technische Anfragen bezüglich dieses Belegs
MailReceiver | 1 | 1 | ü | integer | eMail-Adresse des Empfängers des Belegs beim Kunden

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Header"
Sende Feedback
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemas > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Header"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Header":

Knoten/Feld | min | max | Pflicht | Format | Beschreibung
InvoiceData | 1 | 1 | ü |  | Belegdaten
Recipient | 1 | 1 | ü |  | Angaben zum Belegempfänger (Rechnungsempfänger)

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "InvoiceData"
Sende Feedback
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemas > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "InvoiceData"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "InvoiceData":

Knoten/Feld | min | max | Pflicht | Format | Beschreibung
DocumentType | 1 | 1 | ü | string (2) | Art des Dokuments (Legende)
InvoiceNo | 1 | 1 | ü | integer | Belegnummer (Rechnungsnummer, Gutschriftsnummer, ...)
InvoiceDate | 1 | 1 | ü | jjjj-mm-tt | Belegdatum
IMSUID | 1 | 1 | ü | string | Umsatzsteueridentnummer der IMS
DatePayment | 1 | 1 | ü | jjjj-mm-tt | Zahlungsziel laut gültiger Zahlungsvereinbarung

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Invoice"
Sende Feedback
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemas > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Inhalt des Knoten "Invoice"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Invoice":

Knoten | min | max | Pflicht | Format | Beschreibung
Prefix | 1 | 1 | ü |  | technische Daten zum Beleg
Header | 1 | 1 | ü |  | Belegkopfdaten
Lines | 1 | 1 | ü |  | Positionen
Summery | 1 | 1 | ü |  | Belegsummen

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Knoten "Invoice"
Sende Feedback
Schnittstelle Customer Invoice > IMS_CI_CustomerInvoice_XML > XML Schemas > IMS_CI_Schemas.IMS_CI_CustomerInvoice2_V1096 - Knoten "Invoice"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Knoten | min | max | Pflicht | Format | Beschreibung
Invoice | 1 | 1 | ü |  | Root Knoten für Rechnungsdatensatz

Legende

zurück


Schnittstelle Order Inbound
Siehe auch Sende Feedback
Schnittstelle Order Inbound > Schnittstelle Order Inbound

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Die Schnittstelle Order Inbound dient zur Übermittlung von Aufträgen von Kunden an IMS.

Das Schnittstellensystem umfasst folgende Datenformate:

Schnittstellentyp | aktuelle Version | Freigabedatum | Beschreibung
IMS_CI_Order | IMS_Schemas_Ext.PxB_CI_OI.V3130 | 14.04.2017 | XML-Schema für Auftragsdaten
IMS_CI_ACK | IMS_Schemas.PxB_CI_ACK.V1-2-0-1 | 01.02.2011 | XML-Schema für Acknowledgedaten

Zur Anmeldung für diese Schnittstelle siehe Anmeldung zum elektronischen Datenaustausch

Um die einwandfreie Funktion der gemeinsamen Schnittstelle zu gewährleisten, wird am Beginn ein Testbetrieb durchgeführt, während dessen die Daten geprüft werden, ohne dass die übermittelten Aufträge tatsächlich in das Produktionssystem der IMS übernommen werden.

Show technische Spezifikationen

Spezifikation | Beschreibung
Dateiname

CI_OI_3-1-3-0_xxxxxxxxxxx.XML

Platzhalter Inhalt
xxxxxxxxxxx

eindeutige Kennung der Schnittstellendatei, vom Kunden generiert.

Eine Schnittstellendatei (Dateiname) muss eindeutig sein. Auch im Fehlerfall abgewiesene Daten dürfen nicht mit identen Dateinamen nochmals gesendet werden.

encoding | "utf-8"
Inhalt
Eine Schnittstellendatei kann immer nur einen Auftrag enthalten.

Show Kommunikation

Es stehen in der aktuellen Version zwei Kommunikationsarten zur Verfügung.

Kommunikationsart Beschreibung
FTP

Sie erhalten Zugang zum FTP-Server der IMS. Dort sind zwei Verzeichnisse vorhanden

Verzeichnis | Beschreibung
inbound

Dieses Verzeichnis stellt das Empfangsverzeichnis der IMS für Ihre Datensendungen dar. In der aktuellen Version sind in diesem Verzeichnis die Aufträge abzulegen.

Beim Übertragen der Dateien ist darauf zu achten, dass der entgültige Dateiname (laut Vorgabe) erst vergeben wird, wenn die Datenübertragung abgeschlossen ist. Damit wird vermieden, dass durch zeitliche Überschneidungen eine Datei von IMS verarbeitet wird, die noch nicht vollständig übertragen wurde.

Wir empfehlen dies durch die Verwendung einer alternativen Dateiendung (z.B. ".tmp") während der Übertragung. Nach Abschluss der Übertragung ist die Datei vom Sender am FTP-Server in ".xml" umzubenennen.
outbound | Dieses Verzeichnis stellt das Ausgabeverzeichnis der IMS dar. In der aktuellen Version werden von IMS in diesem Verzeichniss die Acknowledge-Meldungen (siehe) als Antwort auf erhaltene Aufträge abgelegt.

eMail

Sie erhalten von IMS eine eMail-Adresse genannt, an die sie eMails mit der Schnittstellendatei als Anhang senden können. IMS benötigt vom Kunden eine eMail-Adresse, an die Outbounds gesendet werden.

Feld | Beschreibung

Inbound

Bitte versenden Sie Ihre eMails immer als Plain-Text eMails.
Empfänger

Als eMail-Empfänger ist immer folgende eMail-Adresse anzugeben:

"interfaces.at@imscargo.com"

Senden Sie keine anderen eMails an diese eMail-Adresse außer eMails mit Schnittstellendateien. Die eMails werden ausschließlich elektronisch verarbeitet und nicht an natürliche Personen weitergeleitet!
Betreff

Der Eintrag in der Betreffzeile muss mit dem Text "IMS Order-Inbound" beginnen. Der restliche Text kann frei vergeben werden.
Text | Der Text im Textteil der eMail wird vom Schnittstellensystem ignoriert. Da diese eMails ausschließlich vom Schnittstellensystem gelesen werden, dürfen im Textbereich keine wichtigen Informationen übergeben werden.
Anhang | Die Schnittstellendatei muss im vorgegebenen Dateinamenformat als Anhang der eMail beiliegen (siehe technische Spezifikation oben)
Bestätigung | Der IMS eMail-Server sendet für erhaltene eMails an diesem Mailaccount keine Empfangs- und/oder Lesebestätigungen. Der Erhalt der Daten wird alleinig über die Zusendung des Acknowldege (siehe) bestätigt.

Outbound
Absender

Der Absender für eMails generiert durch das IMS Schnittstellensystem lautet immer:

"CustomerInterfaceRobot@imscargo.com"

Senden sie keine Antworten an diesen Absender. Diese eMails werden vom eMail-Server ignoriert.
Betreff

Der Text im Feld Betreff für den Versand von Acknowledge-Meldungen lautet:

"Customer-Interfaces Order-Inbound ACK für File ID nnnnnn"

wobei "nnnnnnn" = GUID (der Message-Ident der zugrundeliegenden Datensendung (Inbound) )
Text | Im Textbereich wird der Inhalt der Datensendung angeführt und dient nur zu Informationszwecken.
Anhang | Als Anhang erhalten Sie die Schnittstellendatei gemäß deren technischer Spezifikation (siehe oben)
Bestätigung | Das Schnittstellensystem versendet die eMails ohne Anforderung von Empfangs- und/oder Lesebestätigungen.

Inhalt
Eine Schnittstellendatei zur Auftragsübermittlung kann immer nur einen Auftrag enthalten.

Show Ablaufdiagramm

Klicken um zu vergrößern Klicken um zu vergrößern
Klicken um zu verkleinern Klicken um zu verkleinern

Show Legende

Sendungsnummer | Beschreibung
1

Versand des Auftrags an IMS

Schnittstellentyp | Richtung
IMS_CI_Order | Outbound
2

Versand des "technical acknowledge" von IMS an Kunden

Schnittstellentyp | Richtung
IMS_CI_ACK | Outbound

Mit dem Versand eines technical acknowledge bestätigt IMS den Erhalt der Datensendung (in diesem Fall des Order Inbounds).

Das technische ACK bestätigt nur den Erhalt der Datensendung, nicht deren Gültigkeit und erfolgreiche Verarbeitung !

Treten beim Empfang der Datensendung Fehler auf, wird kein technical acknowledge erstellt!

Aufgrund der vielen Systeme, die bei der Datenübertragung aktiv sind (z.B.: FTP Server offline, Kopiervorgang abgebrochen, Schnittstellensystem nicht online, ...) ist es nicht möglich, ein negatives technical ACk zu senden. Bitte stellen Sie in Ihrem System sicher, dass Datensendungen, für die Sie innerhalb von 30 Minuten kein technical ACK erhalten, als fehlerhaft gemeldet werden. In diesem Fall muss eine Fehlersuche im Übertragungsweg vorgenommen werden.
3

Information über Fehler in der XML-Struktur und/oder Fehler im Inhalt von einzelnen Knoten/Felder.

Versand des data acknowledge an den Kunden mit Informationen über Fehler in der Datenstruktur oder den enthaltenen Werten.

Schnittstellentyp | Richtung
IMS_CI_ACK | Outbound

Das Auftreten von Fehlern in den Datenfeldern und/oder der Struktur des XML-Dokuments beendet die Verarbeitung der Datesendung bei IMS. Die nachfolgende, logische Prüfung kann nicht durchgeführt werden. Es kann also durchaus vorkommen, dass Ihre Datensendung nach Korrektur der in diesem ACK angeführten Fehler bei erneuter Sendung bei der logischen Prüfung abgelehnt wird.

siehe IMS_CI_ACK
4

Information über logische Fehler in der Datensendung (z.B.: Gefahrengüter ohne Gefahrengutdefinitionen, Angabe von Schiffsdaten in falscher Relation, ...)

Versand des data acknowledge an den Kunden mit Informationen über Fehler bei der Verarbeitung des order inbounds.

Schnittstellentyp | Richtung
IMS_CI_ACK | Outbound

siehe IMS_CI_ACK
5

Information über logische Fehler beim Import des order inbounds.

Versand des data acknowledge an den Kunden mit Informationen über Fehler bei der Verarbeitung des order inbounds.

Schnittstellentyp | Richtung
IMS_CI_ACK | Outbound

siehe IMS_CI_ACK
6

Versand des data acknowledge an den Kunden als Bestätigung über die erfolgreiche Übernahme des order inbounds als Kundenauftrag in das Produktionssystem der IMS.

Schnittstellentyp | Richtung
IMS_CI_ACK | Outbound

Das data ACK enthält auch die Referenznummern der Auftragsdaten im Produktionssystem der IMS.

siehe auch IMS_CI_ACK
7 | Die von IMS im data acknowledge gesendeten IMS-Referenzen müssen von Ihnen nicht in Ihr System übernommen werden. Evtl. nachfolgende Informationen durch Schnittstellen des Systems Customer Interfaces sind immer mit den von Ihnen im Order Inbound angegebenen Referenzen versehen.

Siehe auch

IMS_CI_Order
IMS_CI_ACK


IMS_CI_Order
Schnittstelle Order Inbound > IMS_CI_Order

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Dieses Format definiert einen Kundenauftrag an IMS als XML-Dokument mit der Dateierweiterung .XML.

aktuelle Version: 3.1.3.0

Show technische Spezifikationen aktuelle Version

Spezifikation | Beschreibung
Dateierweiterung | XML
Schema | IMS_Schemas_Ext.PxB_CI_OI.V3130
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3130>

Show Versionshistorie

Version Freigabedatum Beschreibung
3.1.3.0 14.04.2017

(Erweitertes Subset zu V3.1.2.0.)

Spezifikation | Beschreibung
Dateierweiterung | XML
Schema | IMS_Schemas_Ext.PxB_CI_Order.V3130
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3130>
3.1.2.0 20.01.2017

(Erweitertes Subset zu V3.1.1.0.)

Spezifikation | Beschreibung
Dateierweiterung | XML
Schema | IMS_Schemas_Ext.PxB_CI_Order.V3120
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3120>

3.1.1.0

 01.07.2014

(Erweitertes Subset zu V3.1.0.0.)

Spezifikation | Beschreibung
Dateierweiterung | XML
Schema | IMS_Schemas_Ext.PxB_CI_Order.V3110
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3110>
3.1.0.0 23.11.2012

Produktionsbetrieb

Spezifikation | Beschreibung
Dateierweiterung | XML
Schema | IMS_Schemas.IMS_CI_Order.V3-1-0-0
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V3100>
1.2.2.0 01.02.2011

Produktionsbetrieb

Spezifikation | Beschreibung
Dateierweiterung | XML
Schema | IMS_Schemas.IMS_CI_Order.V1-2-2-0
targetnamespec | <ns0:Orders xmlns:ns0=http://IMS_Schemas_Ext.PxB_CI_OI.V1220>

Show Dokumentation XML Schema

aktuelle Version:

XML Schema für IMS_Schemas_Ext.PxB_CI_OI.V3130

(Subset zu V3.1.3.0/V3.1.1.0/V3.1.0.0)

vorangegangene Versionen:

XML Schema für IMS_Schemas_Ext.PxB_CI_OI.V3120 (Subset zu V3.1.1.0/V3.1.0.0)

XML Schema für IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0

Show Downloads / Beispiele

Datei | Beschreibung
IMS_CI_OI_V3130.xsd | XML Schema
IMS_CI_OI_V3130.xml | XML-Interfacedatei mit Testdaten
IMS_CI_OI_V3120.xsd | XML Schema
IMS_CI_OI_V3110.xsd | XML Schema
PxB_CI_OI_V3100.xsd | XML Schema
PxB_CI_OI_V3100.xml | XML-Interfacedatei mit Testdaten

zurück


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Knoten "Orders"
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Knoten "Orders"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Orders | 1 | 1 | ü |  | Root Knoten für Order Inbound

Legende

zurück


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Prefix"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Prefix"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Prefix":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
Version 1 1 ü string(7)

Versionsnummer der Schnittstellendatei

Es können nur Order Inbounds verarbeitet werden, deren Versionsnummer in diesem Feld mit der tatsächlichen Versionsnummer des verwendeten XML-Schemas übereinstimmen
aktuelle Versionskennung
1-2-2-0

ID 1 1 ü string(36-36)

eindeutige GUID dieser Datensendung (Schnittstellendatei) (siehe x.x)
DateTime 1 1 ü jjjj-mm-ddThh:nn:ss Datum und Uhrzeit der Erstellung der Schnittstellendatei
SendType 1 1 ü string(3-3)

Art des Kommunikationswegs

Wert | Bedeutung
MAI | eMail
FTP | per FTP push auf IMS-FTP-Server
HTP | HTTP *
HTS | HTTPS *
OTH | other (Kommunikationsweg unbekannt)
*) diese Kommunikationsarten sind in der aktuellen Version des Schnittstellensystems noch nicht verfügbar
HandlingCode 1 1 ü string(1-1)

Unterscheidung Test-/Produktionsbetrieb

Wert | Bedeutung
P | Produktionsbetrieb
T | Testbetrieb

Achten Sie bitte unbedingt auf die korrekte Auswahl in diesem Knoten. Die Adressierung der Testumgebung ist nur während der Testphasen erlaubt. Die an die Testumgebung adressierten Aufträge werden trotz gültigen data ACK von IMS nicht als Auftäge angenommen
SenderID 1 1 ü string(36-36)

GUID des Datensenders (Kunden)

Ihre GUID wird Ihnen im Zuge der Anmeldung zu dieser Schnittstelle bekanntgegeben.
ReceiverID 1 1 ü string(36-36)

GUID des Datenempfängers (immer IMS)

GUID der IMS
D4AF98C4-5930-430B-855B-B74785ACFEF6

IDReferenced 0 1 string(36-36)

GUID der zugrundeliegenden Datensendung

z.B.: bei der Sendung eines Auftragsstornos oder einer Auftragsänderung die GUID (ID) der ursprünglichen Datensendung (Order Inbound)

Dieser Knoten muss bei Neuaufträgen nicht oder mit dem Wert "" (leer) übermittelt werden.
DocumentType 1 1 ü string(1-1)

Art der übermittelten Auftragsdaten

Wert | Bedeutung
N | Neuauftrag
U | Änderung der Daten eines bestehenden Auftrags *
S | Storno eines bestehenden Auftrags *
*) nur möglich für Aufträge, die zuvor elektronisch mittels der Schnittstelle Order Inbound übermittelt wurden *) diese Dokumenttypen sind in der aktuellen Version des Schnittstellensystems noch nicht verfügbar

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten"Orders"
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten"Orders"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Orders":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Prefix | 1 | 1 | ü |  | technische Daten zur Datensendung
Order | 1 | 1 | ü |  | Auftrag

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Order"
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Order"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Order":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Header | 1 | 1 | ü |  | Kopfdaten des Auftrags
Relations | 1 | 1 | ü |  | Angaben zu Pickup-, Destination- und Wegpunkten
Container | 1 | 1 | ü |  | Angaben zu Container und Inhalten

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Header"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Header"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Header":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Customer | 0 | 1 |  |  | Angaben zum Auftraggeber
OrderData | 1 | 1 | ü |  | Angaben zum Auftrag
Informations | 1 | 1 | ü |  | Informationen, Referenzen und Kontaktinformationen

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Customer"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Customer"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Customer":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
CustomerNo | 0 | 1 |  | integer | Kundennummer des Auftraggebers bei IMS
Name1 | 0 | 1 |  | string(50) | Firmenname
Name2 | 0 | 1 |  | string(50) | Erweiterung Firmenname
Adress1 | 0 | 1 |  | string(50) | Adresse des Auftraggebers (Strasse und Hausnummer)
Adress2 | 0 | 1 |  | string(50) | Erweiterung Adresse des Auftraggebers (Strasse und Hausnummer)
ZipCode | 0 | 1 |  | string(4-8) | Postleitzahl
Town | 0 | 1 |  | string(50) | Ortsname
CountryCode | 0 | 1 |  | string(2-2) | Ländercode nach ISO 3166 ALPHA-2 (siehe auch Wikipedia)
VATID | 0 | 1 |  | string(15) | Umsatzsteuer Ident Nummer (siehe auch Wikipedia)

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "OrderData"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "OrderData"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "OrderData":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
OrderNo 1 1 ü string(50)

Auftragsreferenz des Auftraggebers
(z.B.: dessen Auftragsnummer)
OrderDate 1 1 ü jjjj-mm-tt

Auftragsdatum des Auftraggebers
IMSOfferNo 0 1 integer

Nummer des zugrundeliegenden Offerts der IMS
Direction 1 1 ü string(1-1)

Import-/Exportkennung

Wert | Bedeutung
I | Import
E | Export
N | Nationaler Transport
GoodsNetValue 0 1 decimal

Summe der Nettowarenwerte der im Auftrag enthaltenen Waren
CustomHandling 0 1 string

Zollabwicklung
(wird in der aktuellen Version nicht verwendet)
IMSOrderID 0 1 integer

Auftragsnummer der IMS
(Diese Nummer wird nach Auftragseingang durch IMS vergeben)
Verification 0 1 Angaben zur Überprüfung des Auftragsinhalts

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Verification"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Verification"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Verification":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
CountContainer | 0 | 1 |  | integer | Anzahl der im Auftrag enthaltenen Container
Net | 0 | 1 |  | decimal | Gesamt-Nettoauftragswert gemäß dem zugrundeliegenden Offert inkl. Nebenkosten
VAT | 0 | 1 |  | integer | Gesamt-Umsatzsteuerbetrag des Auftrags

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Informations"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Informations"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Informations":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
References | 0 | 1 |  |  | Referenzangaben
Comments | 0 | 1 |  |  | Kommentare und Zusatzinformationen
Contact | 0 | 1 |  |  | Angaben zum verantwortlichen Sachbearbeiter, bzw. Ansprechperson beim Auftraggeber

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "References"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "References"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "References":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Reference | 1 | 99 | ü |  | einzelne Referenzangabe

Legende

zurück zum übergeordneten Knoten "Informations"

zurück zum übergeordneten Knoten "Container"


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Reference"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Reference"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Reference":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung

Code

(Attribute)

1

1

ü

string

Das Attribute "Code" definiert die Art der Referenz. Die Codes werden zwischen IMS und den Auftraggebern direkt vereinbart.

Inhalt | Beschreibung
Reference 1 1

ü

 string

Referenzangabe

Note Box
Die Übergabe von Referenzen in diesem Knoten ist erst nur möglich, wenn Codes zwischen IMS und dem Auftraggeber vereinbart wurde.

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Comments"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Comments"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Comments":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Comment | 1 | 99 | ü |  | einzelne(r) Information/Kommentar

Legende

zurück zum übergeordneten Knoten "Information"

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"

zurück zum übergeordneten Knoten "Destination"

zurück zum übergeordneten Knoten "Container"


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Comment"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Comment"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Comment":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Comment | 1 | 1 | ü | string(255) | Kommentar/Information

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Contact"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Contact"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Contact" (für übergeordneten Knoten "Header"):

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
Department 0 1 string(100)

Name der Fachabteilung
Name 1 1 ü string(100)

Name des/der Sachbearbeiters/in
Phone 1 1 ü string(20)

Telefonnummer
Mail | 1 | 1 | ü | string(200) | eMail-Adresse des/der Sachbearbeiters/in
Fax | 0 | 1 | string(20) | Faxnummer
CallBack 0 1 string(1)

Kennzeichen über Anforderung eines Rückrufs vor Antragsannahme

Wert | Bedeutung
Y | IMS führt vor der Übernahme des Auftrags einen Rückruf bei dem angeführten Sachbearbeiters beim Auftraggeber durch
N | kein Rückruf erforderlich

Legende

zurück zum übergeordneten Knoten "Header"


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Relations"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Relations"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Relations":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Pickup | 1 | 1 | ü |  | Abgangsort
Waypoints | 0 | 1 |  |  | voirgegebene Wegpunkte
Destination | 1 | 1 | ü |  | Empfangsort

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "PickUp"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "PickUp"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "PickUp":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
CarriageType 1 1 ü string

Frachtart

Wert | Bedeutung
Vorlauf | x.x (WT fragen)
Nachlauf | x.x (WT fragen)
inknown | Frachtart nicht bekannt
TransportType 1 1 ü string

Transportart

Wert | Bedeutung
Train | Abholung per LKW
Truck | Abholung per Zug
unknown | Art der Abholung nicht bekannt
Outbound 1 1 ü

Angaben zum vorgeschriebenen/vorgeschlagenen Abholtermin
LocationCode 1 1 ü string(1)

Art der Ortsangabe

Wert | Bedeutung
L | nur Angabe über Adresse (keine Bahnhofdaten)
T | nur Angabe des Bahnhofs/Terminals (keine Adressangaben)
B | Art der Abholung nicht bekannt

Bemäß Ihrer Vorgabe in diesem Knoten müssen die entsprechenden nachfolgenden Knoten (T=StationData, L=LocationData, B=beide Knoten) in der Schnittstellendatei vorhanden sein.
StationData | 0 | 1 | Angaben zum Abholbahnhof
LocationData 0 1

Adressangaben zum Abholort
Ship 0 1

Angaben zum Schiff, Hafen und Reeder

Pflichtknoten bei Importaufträgen.
(entfällt bei Exportaufträgen)
Contact | 0 | 1 | Angaben zum Sachbearbeiter, der vor der Abholung kontaktiert werden soll
Comments | 0 | 1 | Kommentare/Informationen zum Abholort

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Outbound"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Outbound"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Outbound":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
Optional 1 1 ü string(1)

Art der Datumsangaben

Wert | Bedeutung
Y | Abholtermin optional (Terminvorgabe ist als Wunsch/Vorschlag zu verstehen)
N | Abholtermin ist als verbindliche/fixe Zeitvorgabe zu verstehen
Date 1 1 ü jjjj-mm-tt

Abholdatum

(gemäß Vorgabe in obigen Knoten "Optional")
TimeFrom 1 1 ü hh:mm:ss

frühest mögliche Abholzeit

(gemäß Vorgabe in obigen Knoten "Optional")
TimeTo 1 1 ü hh:mm:ss

spätest mögliche Abholzeit

(gemäß Vorgabe in obigen Knoten "Optional")
FreightTermin 0 1 string(3)

Frankatur

Wert | Bedeutung
FOT | free on truck (x.x)
FOR | free on rail (x.x)
FOG | free on ground (x.x)
UNK | unbekannt

Legende

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "StationData"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "StationData"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "StationData":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Code | 1 | 1 | ü | int | internationale Bahnhofsnummer (8-stellig inkl. Landesprefix)
Name | 1 | 1 | ü | string | Name des Bahnhofs
Terminal | 0 | 1 |  | string | Terminalcode
TerminalName | 1 | 1 | ü | string | Name des Terminals

Legende

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "LocationData"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "LocationData"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "LocationData":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Name | 1 | 1 | ü | string | Firmenname, bzw. Adressbezeichnung
Adress | 1 | 1 | ü | string | Strasse und Hausnummer
ZipCode | 1 | 1 | ü | string(4-8) | Postleitzahl
Town | 1 | 1 | ü | string | Ort
CountryCode | 1 | 1 | ü | string(2) | Ländercode nach ISO 3166 ALPHA-2 (siehe auch Wikipedia)

Legende

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Ship"
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Ship"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Ship" (für übergeordneten Knoten "PickUp"):

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
CarrierCode 1 1 ü string

Reedereicode
CarrierName 1 1 ü string

Name der Reederei
Code 0 1 string

Schiffsrufzeichen
Name 1 1 ü string

Name des Schiffs
ET 0 1 ü jjjj-mm-ttThh:nn:ss

Bedingung | Inhalt
Import | Ankunftszeit im Hafen (ETA)
Export | Ladeschluss (ETC)
PortCode 1 1 ü string

Hafencode (UN/LOCODE)

siehe UNECE
PortName | 1 | 1 | ü | string | Name des Hafens
TravelNumber | 0 | 1 | string | Reisenummer

Legende

zurück zum übergeordneten Knoten "PickUp"


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Contact"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Contact"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Contact" (für die Übergeordneten Knoten "PickUp", "WayPoint" und "Destination"):

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
Department 0 1 string(100)

Name der Fachabteilung
Name 1 1 ü string(100)

Name des/der Sachbearbeiters/in
Phone 1 1 ü string(20)

Telefonnummer
Mail | 0 | 1 | string(200) | eMail-Adresse des/der Sachbearbeiters/in
Fax | 0 | 1 | string(20) | Faxnummer
Advice 0 1 string(1)

Kennzeichen über Anforderung eines Rückrufs vor Abholung und/oder Anlieferung

Wert | Bedeutung
Y | IMS führt vor Abholung und/oder Anlieferung einen Rückruf bei dem angeführten Sachbearbeiters beim Auftraggeber durch
N | kein Rückruf erforderlich

Legende

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Waypoints"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Waypoints"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Waypoints":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Waypoint | 1 | 99 | ü |  | einzelner Wegpunkt

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Waypoint"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Waypoint"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Waypoint":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
CarriageType 1 1 ü string

Frachtart

Wert | Bedeutung
Vorlauf | x.x (WT fragen)
Nachlauf | x.x (WT fragen)
inknown | Frachtart nicht bekannt
TransportType 1 1 ü string

Transportart

Wert | Bedeutung
Train | Abholung per LKW
Truck | Abholung per Zug
unknown | Art der Abholung nicht bekannt
Inbound | 1 | 1 | ü | Angaben zum vorgeschriebenen/vorgeschlagenen Anlieferungtermins
Outbound 1 1 ü

Angaben zum vorgeschriebenen/vorgeschlagenen Abholtermin
LocationCode 1 1 ü string(1)

Art der Ortsangabe

Wert | Bedeutung
L | nur Angabe über Adresse (keine Bahnhofdaten)
T | nur Angabe des Bahnhofs/Terminals (keine Adressangaben)
B | Art der Anlieferung-/Abholung nicht bekannt

Bemäß Ihrer Vorgabe in diesem Knoten müssen die entsprechenden nachfolgenden Knoten (T=StationData, L=LocationData, B=beide Knoten) in der Schnittstellendatei vorhanden sein.
StationData | 0 | 1 | Angaben zum Anliefer-/Abholbahnhof
LocationData 0 1

Adressangaben zum Anliefer-/Abholort
Contact | 0 | 1 | Angaben zum Sachbearbeiter, der vor der Anlieferung-/Abholung kontaktiert werden soll
Comments | 0 | 1 | Kommentare/Informationen zum Anliefer-/Abholort

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Inbound"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Inbound"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Inbound":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
Optional 1 1 ü string(1)

Art der Datumsangaben

Wert | Bedeutung
Y | Anliefertermin optional (Terminvorgabe ist als Wunsch/Vorschlag zu verstehen)
N | Anliefertermin ist als verbindliche/fixe Zeitvorgabe zu verstehen
Date 1 1 ü jjjj-mm-tt

Anlieferdatum

(gemäß Vorgabe in obigen Knoten "Optional")
TimeFrom 1 1 ü hh:mm:ss

frühest mögliche Anlieferzeit

(gemäß Vorgabe in obigen Knoten "Optional")
TimeTo 1 1 ü hh:mm:ss

spätest mögliche Anlieferzeit

(gemäß Vorgabe in obigen Knoten "Optional")
FreightTermin 0 1 string(3)

Frankatur

Wert | Bedeutung
FOT | free on truck (x.x)
FOR | free on rail (x.x)
FOG | free on ground (x.x)
UNK | unbekannt

Legende

zurück zum übergeordneten Knoten "Waypoint"


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Destination"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Destination"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Destination":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
CarriageType 1 1 ü string

Frachtart

Wert | Bedeutung
Vorlauf | x.x (WT fragen)
Nachlauf | x.x (WT fragen)
inknown | Frachtart nicht bekannt
TransportType 1 1 ü string

Transportart

Wert | Bedeutung
Train | Abholung per LKW
Truck | Abholung per Zug
unknown | Art der Abholung nicht bekannt
Outbound 1 1 ü

Angaben zum vorgeschriebenen/vorgeschlagenen Anliefertermin
LocationCode 1 1 ü string(1)

Art der Ortsangabe

Wert | Bedeutung
L | nur Angabe über Adresse (keine Bahnhofdaten)
T | nur Angabe des Bahnhofs/Terminals (keine Adressangaben)
B | Art der Anlieferung nicht bekannt

Bemäß Ihrer Vorgabe in diesem Knoten müssen die entsprechenden nachfolgenden Knoten (T=StationData, L=LocationData, B=beide Knoten) in der Schnittstellendatei vorhanden sein.
StationData | 0 | 1 | Angaben zum Anlieferbahnhof
LocationData 0 1

Adressangaben zum Anlieferort
Ship 0 1

Angaben zum Schiff, Hafen und Reeder

Pflichtknoten bei Exportaufträgen.
(entfällt bei Importaufträgen)
Contact | 0 | 1 | Angaben zum Sachbearbeiter, der vor der Anlieferung kontaktiert werden soll
Comments | 0 | 1 | Kommentare/Informationen zum Anlieferort

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Container"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Container"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Order":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Container | 1 | 99 | ü |  | Angaben zu einem einzelnen Container

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Container"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Container"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
Data 1 1 ü

Angaben zum Container
Temperature | 0 | 1 | Angaben zur Kühlvorschrift
References | 0 | 1 | Referenzangaben
Comments | 0 | 1 | Kommentare und Informationstexte
Content | 1 | 1 | ü | Angaben zum Inhalt des Containers
Services 0 1

Angaben zu den geforderten Leistungen

Angaben im Knoten "Services" wird in der aktuellen Version nicht verarbeitet.

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Data"
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Data"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Data":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
RefNo 1 1 ü string

Referenz des Auftraggebers für diesen Container
ID | 0 | 1 | string(11) | Containernummer
ContainerType 1 1 ü string(2)

Containertype

Wert | Bedeutung
BK | Bulk
DC | Box
FC | Flat
RH | High Cube Reefer
HC | High Cube
HT | Hard Top
OT | Open Top
RE | Reefer
TA | Tank
VB | Ventilated
LengthCode 1 1 ü string(2)

Länge des Containers in Fuß

Wert | Bedeutung
20 | 20 Fuß
22 | 22 Fuß
24 | 24 Fuß
30 | 30 Fuß
40 | 40 Fuß
45 | 45 Fuß
Tara 1 1 ü integer

Leergewicht des Containers in kg
Weight 1 1 ü integer

Gesamtgewicht (Tara + Netto) des Containers
Empty 1 1 ü string(1)

Kennzeichnen Leercontainer

Wert | Bedeutung
Y | Leercontainer
N | Container mit Inhalt
CustomSealNumber | 0 | 1 | string | Zollsiegelnummer
IMSContainerID 0 1 integer

IMS-Referenz für diesen Container
(wird von IMS vergeben)
IMSPoolID 0 1 integer

IMS-Referenz für Container-Pool
(wird von IMS vergeben)
TurnInOut | 0 | 1 | string | Turn-In, bzw. Turn-Out Referenz (x.x WT)
DeliveryReference | 0 | 1 | string | Anlieferreferenz
CustomIndicator 1 1 ü string(1)

Kennzeichnung Zollgut (x.x WT)

Wert | Bedeutung
Y | Zollgut
N | kein Zollgut
CustomProcedure 0 1 ü string(2-3)

Zollprozedur

Wert | Bedeutung
AZA | Exportverzollung
BT1 | Bahn T1
ERL | Container ist abgefertigt
EU | Gemeinschaftsware
IVZ | Importverzollung
T1 | T1
T1B | FB T1 Stempel
VZT | IVZ d. Terminalspedition
XX | keine Verfügung

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Temperature"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Temperature"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Temperature":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
Refrigeration 1 1 ü string(1)

gekühlt/beheizt

Wert | Bedeutung
Y | Container ist gekühlt/beheizt
N | Container ist nicht gekühlt/beheizt
Min 1 1 ü decimal

Mindesttemperatur in Grad Celsius
Max 1 1 ü decimal

Maximaltemperatur in Grad Celsius

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Content"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Content"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Content":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
RefNo 1 1 ü string

Referenz des Auftraggebers für diese Ware
Description | 0 | 1 | string(255) | Beschreibung der Ware
RIDCode 1 1 ü string(2)

Gefahrengutkennung

Wert | Bedeutung
Y | Gefahrengut
N | kein Gefahrengut

Wird Ware als Gefahrengut gekennzeichnet ("Y"), ist die Anführung des untergeordnete Knoten "DangerousClass" (siehe unten) verpflichtend.
NetWeight 0 1 integer

Nettogewicht der Ware in kg
Tara 1 1 ü integer

Leergewicht des Containers in kg
Weight 1 1 ü integer

Gesamtgewicht (Tara + Netto) des Containers
Collis 1 1 ü

Angaben zur Verpackung
CountryCodeOrigin 1 1 ü string(2)

Herkunftsland

Ländercode nach ISO 3166 ALPHA-2
(siehe auch Wikipedia)
CountryCodeDestination 1 1 ü string(2)

Bestimmungsland

Ländercode nach ISO 3166 ALPHA-2
(siehe auch Wikipedia)
NetValue 1 1 ü decimal

Netto-Warenwert in Euro
CustomNumber | 0 | 1 | string | Zollnummer
ATBNumber | 0 | 1 | string | ATB-Nummer
IMSContentID | 0 | 1 | integer | IMS_Referenz der Ware innerhlb des Containers
DangerousClass 0 1

Angaben zur Gefahrenklasse

Der Inhalt dieses Knotens wird von IMS nur verarbeitet, wenn die Ware als Gefahrengut gekennzeichnet wurde (siehe "RIDCode" (oben).

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Content"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Content"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Content":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Content | 1 | 1 | ü |  | Angaben zum Containerinhalt

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Collis"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Collis"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Collis":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Colli | 1 | 99 | ü |  | Angaben zur einzelnen Verpackungseinheit

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Colli"
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Colli"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Colli":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Count | 1 | 1 | ü | string | Anzahl der Verpackungseinheiten
Code | 1 | 1 | ü | string(2) | Verpackungscode (siehe x.x)
Description | 1 | 1 | ü | string | Bezeichnung der Verpackung

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "DangerousClass"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "DangerousClass"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "DangerousClass":

Knoten/Feld/Attribut min max Pflicht

Format

 Beschreibung
Class 1 1 ü string

Gefahrenklasse

(siehe x.x)

(siehe auch Wikipedia)
UNNumber 1 1 ü string UN-Gefahrennummer
Description 1 1 ü string(500)

Beschreibung des Gefahrenguts
FlashPoint 1 1 ü decimal

Flammpunkt in Grad Celsius
GrossWeight 1 1 ü integer

Bruttogewicht des Gefahrenguts in kg
NetWeight 0 1 ü integer

Nettogewicht des Gefahrenguts in kg
NetExplosive 1 1 integer

Nettogewicht der explosiven Stoffe in kg
Number 1 1 ü string

RID-Gefahrennummer
ClassCode 1 1 ü string

RID-Klassifizierungscode
GrossZettel 0 1 ü string

Gefahrengutzettel

dieses Feld wird in der aktuellen Version nicht verarbeitet
Packaging 0 99

Angaben zur Gefahrengutverpackung

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Packaging"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V1_2_2_0 > IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Packaging"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Packaging":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Code | 1 | 1 | ü | string | Verpackungscode (siehe x.x)
Count | 1 | 1 | ü | string(2) | Anzahl der Verpackungseinheiten
Group | 1 | 1 | ü | string | Gefahrengruppe

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Knoten "Orders"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Knoten "Orders"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Orders | 1 | 1 | ü | . | Root Knoten für Order Inbound

Legende

zurück


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Orders"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Orders"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Orders":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Prefix | 1 | 1 | ü | . | technische Daten zur Datensendung
Order | 1 | 1 | ü | . | Auftrag

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Order"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Order"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Order":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Header | 1 | 1 | ü | . | Kopfdaten des Auftrags
Relations | 1 | 1 | ü | . | Angaben zu Pickup-, Destination- und Wegpunkten
Container | 1 | 1 | ü | . | Angaben zu Container und Inhalten

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Prefix"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Prefix"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Prefix":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Version

1

1

ü

string(7-7)

Versionsnummer der Schnittstellendatei

Es können nur Order Inbounds verarbeitet werden, deren Versionsnummer in diesem Feld mit der tatsächlichen Versionsnummer des verwendeten XML-Schemas übereinstimmen

aktuelle Versionskennung
3-1-0-0

ID

1

1

ü

string(36-36)

 eindeutige GUID dieser Datensendung (Schnittstellendatei)
DateTime

1

1

ü

jjjj-mm-ddThh:nn:ss

 Datum und Uhrzeit der Erstellung der Schnittstellendatei
Sendtype

1

1

ü

string(3-3)

Art des Kommunikationswegs

Inhalt | Beschreibung
MAI | eMail
FTP | per FTP push auf IMS-FTP-Server
HandlingCode

1

1

ü

string(1-1)

Unterscheidung Test-/Produktionsbetrieb

Inhalt | Beschreibung
P | Produktion
T | Test

Achten Sie bitte unbedingt auf die korrekte Auswahl in diesem Knoten. Die Adressierung der Testumgebung ist nur während der Testphasen erlaubt. Die an die Testumgebung adressierten Aufträge werden trotz gültigen data ACK von IMS nicht als Auftäge angenommen
SenderID

1

1

ü

string(36-36)

GUID des Datensenders (Kunde)

Ihre GUID wird Ihnen im Zuge der Anmeldung zu dieser Schnittstelle bekanntgegeben.
ReceiverID

1

1

ü

string(36-36)

GUID IMS
D4AF98C4-5930-430B-855B-B74785ACFEF6

IDReferenced

0

1

string(36-36)

GUID der zugrundeliegenden Datensendung

Wird in dieser Version der Schnittstelle nicht verwendet
DocumentType

1

1

ü

string(1-1)

Art der übermittelten Auftragsdaten

Inhalt | Beschreibung
N | Neuauftrag
U | Änderung der Daten eines bestehenden Auftrags *
S | Storno eines bestehenden Auftrags *

*) nur möglich für Aufträge, die zuvor elektronisch mittels der Schnittstelle Order Inbound übermittelt wurden

*) diese Dokumenttypen sind in der aktuellen Version des Schnittstellensystems noch nicht verfügbar
DB

0

1

string

 nicht verwendet
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet
Field5

0

1

string

 nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Header"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Header"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Header":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Customer | 1 | 1 |  | . | Angaben zum Auftraggeber
OrderData | 1 | 1 | ü | . | Angaben zum Auftrag
Informations | 1 | 1 | ü | . | Informationen, Referenzen und Kontaktinformationen

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Customer"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Customer"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Customer":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
CustomerNo | 0 | 1 |  | integer | Kundennummer des Auftraggebers bei IMS
Name1 | 0 | 1 |  | string(50) | Firmenname
Name2 | 0 | 1 |  | string(50) | Erweiterung Firmenname
Adress1 | 0 | 1 |  | string(50) | Adresse des Auftraggebers (Strasse und Hausnummer)
Adress2 | 0 | 1 |  | string(50) | Erweiterung Adresse des Auftraggebers (Strasse und Hausnummer)
ZipCode | 0 | 1 |  | string(4-8) | Postleitzahl
Town | 0 | 1 |  | string(50) | Ortsname
CountryCode | 0 | 1 |  | string(2-2) | Ländercode nach ISO 3166 ALPHA-2 (siehe auch Wikipedia)
VATID | 0 | 1 |  | string(15) | Umsatzsteuer Ident Nummer (siehe auch Wikipedia)
Field1 | 0 | 1 |  | string | nicht verwendet
Field2 | 0 | 1 |  | string | nicht verwendet
Field3 | 0 | 1 |  | string | nicht verwendet
Field4 | 0 | 1 |  | string | nicht verwendet
Field5 | 0 | 1 |  | string | nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "OrderData"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "OrderData"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "OrderData":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
OrderNo

1

1

ü

integer

Auftragsreferenz des Auftraggebers
(z.B.: dessen Auftragsnummer)
OrderDate

1

1

ü

string(50)

Auftragsdatum des Auftraggebers
IMSOfferNo

0

1

string(50)

Nummer des zugrundeliegenden Offerts der IMS
Direction

1

1

ü

string(50)

Import-/Exportkennung

Inhalt | Beschreibung
I | Import
E | Export
GoodsNetValue

0

1

string(50)

Summe der Nettowarenwerte der im Auftrag enthaltenen Waren
CustomHandling

1

1

string(4-8)

nicht verwendet
IMSOrderID

0

1

string(50)

Auftragsnummer der IMS
(Diese Nummer wird nach Auftragseingang durch IMS vergeben)
FreightTerm

0

1

string(2-3)

Frankatur

Inhalt | Beschreibung
FOG | free on ground
FOT | free on truck
FOR | free on rail
NA | unbekannt
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet
Field5

0

1

string

 nicht verwendet

Verification

0

1

.

Angaben zur Überprüfung des Auftragsinhalts
Der Knoten "Verification" wird in der aktuellen Schnittstellenversion nicht verwendet.

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Informations"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Informations"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Informations":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
References | 0 | 1 |  | . | Referenzangaben
Comments | 0 | 1 |  | . | Kommentare und Zusatzinformationen
Contact | 0 | 1 |  | . | Angaben zum verantwortlichen Sachbearbeiter, bzw. Ansprechperson beim Auftraggeber

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "References"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "References"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "References":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
References | 0 | 99 | ü | . | einzelne Referenzangabe

Legende

zurück zum übergeordneten Knoten "Informations"

zurück zum übergeordneten Knoten "Container"


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Reference"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Reference"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Reference":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung

Code

(Attribut)

1

1

ü

string

Das Attribut "Code" definiert die Art der Referenz. Die Codes werden zwischen IMS und den Auftraggebern direkt vereinbart.

Inhalt | Beschreibung
Reference

1

1

ü

string

Referenzangabe

Die Übergabe von Referenzen in diesem Knoten ist erst nur möglich, wenn Codes zwischen IMS und dem Auftraggeber vereinbart wurde.

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Comments"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Comments"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Comments":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Comment | 1 | 99 | ü | . | einzelne(r) Information/Kommentar

Legende

zurück zum übergeordneten Knoten "Information"

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"

zurück zum übergeordneten Knoten "Destination"

zurück zum übergeordneten Knoten "Container"


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Comment"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Comment"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Comment":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Comment | 1 | 1 | ü | string(255) | Kommentar/Information

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Contact"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Contact"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Contact" (für übergeordneten Knoten "Header"):

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Department

0

1

string(100)

Name der Fachabteilung
Name

1

1

ü

string(100)

Name des/der Sachbearbeiters/in
Phone

1

1

ü

string(20)

Telefonnummer
Mail

1

1

ü

string(200)

eMail-Adresse des/der Sachbearbeiters/in
Fax

0

1

string(20)

Faxnummer
CallBack

0

1

string(1)

Kennzeichen über Anforderung eines Rückrufs vor Antragsannahme

Inhalt | Beschreibung
Y | IMS führt vor der Übernahme des Auftrags einen Rückruf bei dem angeführten Sachbearbeiters beim Auftraggeber durch
N | kein Rückruf erforderlich

Legende

zurück zum übergeordneten Knoten "Header"


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Verification"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Verification"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Verification":

Der Knoten "Verification" wird in der aktuellen Schnittstellenversion nicht verwendet.

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
CountContainer | 0 | 1 |  | integer | Anzahl der im Auftrag enthaltenen Container
Net | 0 | 1 |  | decimal | Gesamt-Nettoauftragswert gemäß dem zugrundeliegenden Offert inkl. Nebenkosten
VAT | 0 | 1 |  | integer | Gesamt-Umsatzsteuerbetrag des Auftrags

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Relations"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Relations"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Relations":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Pickup | 1 | 1 | ü | . | Ladestelle
Waypoints | 0 | 1 |  | . | vorgegebene Wegpunkte
Destination | 1 | 1 | ü | . | Entladestelle

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "PickUp"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "PickUp"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "PickUp":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
CarriageType

1

1

ü

string

Frachtart

fixer Wert: "unbekannt"
TransportType

1

1

ü

string

Transportart

Inhalt | Beschreibung
Train | Abholung per Zug
Truck | Abholung per LKW
unknown | Art der Abholung nicht bekannt
Outbound

1

1

ü

.

Angaben zum vorgeschriebenen/vorgeschlagenen Abholtermin
LocationCode

1

1

ü

string(1)

Art der Ortsangabe

Inhalt | Beschreibung
L | Angabe zur Adresse (keine Bahnhofdaten)
T | Angaben zum Bahnhof
B | Angaben zum Bahnhof und Adresse

Bemäß Ihrer Vorgabe in diesem Knoten müssen die entsprechenden nachfolgenden Knoten (T=StationData, L=LocationData, B=beide Knoten) in der Schnittstellendatei vorhanden sein.
StationData

0

1

.

Angaben zum Abholbahnhof
LocationData

0

1

.

Adressangaben zum Abholort
Ship

0

1

.

Angaben zum Schiff, Hafen und Reeder

Pflichtknoten bei Importaufträgen.
(entfällt bei Exportaufträgen)
Contact

0

1

.

 Angaben zum Sachbearbeiter, der vor der Abholung kontaktiert werden soll
Comments

0

1

.

 Kommentare/Informationen zum Abholort
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet

Field5

0

1

string

 nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Waypoints"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Waypoints"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Waypoints":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Waypoint | 1 | 99 | ü | . | einzelner Wegpunkt

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Waypoint"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Waypoint"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Waypoint":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
CarriageType

1

1

ü

string

Frachtart

fixer Wert: "unbekannt"
TransportType

1

1

ü

string

Transportart

Inhalt | Beschreibung
Train | Anlieferung per Zug
Truck | Anlieferung per LKW
unknown | Art der Anlieferung nicht bekannt
Inbound

1

1

ü

.

Angaben zum vorgeschriebenen/vorgeschlagenen Anlieferungtermins
Outbound

1

1

ü

.

Angaben zum vorgeschriebenen/vorgeschlagenen Abholtermin
LocationCode

1

1

ü

string(1)

Art der Ortsangabe

Inhalt | Beschreibung
L | nur Angabe über Adresse (keine Bahnhofdaten)
T | Abholung/Anlieferung per Zug
B | Angaben zum Bahnhof und Adresse

Bemäß Ihrer Vorgabe in diesem Knoten müssen die entsprechenden nachfolgenden Knoten (T=StationData, L=LocationData, B=beide Knoten) in der Schnittstellendatei vorhanden sein.
StationData

0

1

.

Angaben zum Anliefer-/Abholbahnhof
LocationData

0

1

.

Adressangaben zum Anliefer-/Abholort
Contact

0

1

.

 Angaben zum Sachbearbeiter, der vor der Anlieferung-/Abholung kontaktiert werden soll
Comments

0

1

.

 Kommentare/Informationen zum Anliefer-/Abholort
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet

Field5

0

1

string

 nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Destination"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Destination"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Destination":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
CarriageType

1

1

ü

string

Frachtart

fixer Wert: "unbekannt"
TransportType

1

1

ü

string

Transportart

Inhalt | Beschreibung
Train | Abholung per Zug
Truck | Abholung per LKW
unknown | Art der Anlieferung nicht bekannt
Inbound

1

1

ü

.

Angaben zum vorgeschriebenen/vorgeschlagenen Anlieferungtermins
LocationCode

1

1

ü

string(1)

Art der Ortsangabe

Inhalt | Beschreibung
L | Angabe zurAdresse (keine Bahnhofdaten)
T | Angaben zum Bahnhof
B | Angaben zum Bahnhof und Adresse

Bemäß Ihrer Vorgabe in diesem Knoten müssen die entsprechenden nachfolgenden Knoten (T=StationData, L=LocationData, B=beide Knoten) in der Schnittstellendatei vorhanden sein.
StationData

0

1

.

Angaben zum Anlieferbahnhof
LocationData

0

1

.

Adressangaben zum Anlieferort
Ship

0

1

.

Angaben zum Schiff, Hafen und Reeder

Pflichtknoten bei Importaufträgen.
(entfällt bei Exportaufträgen)
Contact

0

1

.

 Angaben zum Sachbearbeiter, der vor der Anlieferung kontaktiert werden soll
Comments

0

1

.

 Kommentare/Informationen zum Anlieferort
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet

Field5

0

1

string

 nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Inbound"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Inbound"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Inbound":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Optional

1

1

ü

string(1)

Art der Datumsangaben

Inhalt | Beschreibung
Y | Anliefertermin optional (Terminvorgabe ist als Wunsch/Vorschlag zu verstehen)
N | Anliefertermin ist als verbindliche/fixe Zeitvorgabe zu verstehen
Date

1

1

ü

jjjj-mm-tt

Anlieferdatum

(gemäß Vorgabe in obigen Knoten "Optional")
TimeFrom

1

1

ü

hh:mm:ss

frühest mögliche Anlieferzeit

(gemäß Vorgabe in obigen Knoten "Optional")
TimeTo

1

1

ü

hh:mm:ss

spätest mögliche Anlieferzeit

(gemäß Vorgabe in obigen Knoten "Optional")

Legende

zurück zum übergeordneten Knoten "Waypoint"

zurück zum übergeordneten Knoten "Destination"


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Outbound"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Outbound"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Outbound":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Optional

1

1

ü

string(1)

Art der Datumsangaben

Inhalt | Beschreibung
Y | Abholtermin optional (Terminvorgabe ist als Wunsch/Vorschlag zu verstehen)
N | Abholtermin ist als verbindliche/fixe Zeitvorgabe zu verstehen
Date

1

1

ü

jjjj-mm-tt

Abholdatum

(gemäß Vorgabe in obigen Knoten "Optional")
TimeFrom

1

1

ü

hh:mm:ss

frühest mögliche Abholzeit

(gemäß Vorgabe in obigen Knoten "Optional")
TimeTo

1

1

ü

hh:mm:ss

spätest mögliche Abholzeit

(gemäß Vorgabe in obigen Knoten "Optional")

Legende

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"

zurück zum übergeordneten Knoten "Destination"


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "StationData"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "StationData"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "StationData":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Code | 1 | 1 | ü | int | internationale Bahnhofsnummer (immer 8-stellig inkl. Landesprefix) (siehe Wikipedia)
Name | 1 | 1 | ü | string | Name des Bahnhofs
Terminal | 1 | 1 | ü | string | Terminalcode
TerminalName | 1 | 1 | ü | string | Name des Terminals

Legende

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"

zurück zum übergeordneten Knoten "Destination"


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "LocationData"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "LocationData"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "LocationData":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Name | 1 | 1 | ü | string | Firmenname, bzw. Adressbezeichnung
Adress | 1 | 1 | ü | string(4-8) | Strasse und Hausnummer
Town | 1 | 1 | ü | string | Ort
CountryCode | 1 | 1 | ü | string(2) | Ländercode nach ISO 3166 ALPHA-2 (siehe auch Wikipedia)

Legende

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"

zurück zum übergeordneten Knoten "Destination"


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Ship"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Ship"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Ship" (für übergeordneten Knoten "PickUp"):

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
CarrierCode

1

1

string

Reedereicode

4-stelliger SCAC-Code des Reeders
(siehe Wikipedia)
CarrierName

1

1

ü

string

Name der Reederei
Code

0

1

string

Schiffsrufzeichen
Name

1

1

ü

string

Name des Schiffs

ETA (Segment Pickup)

ETC (Segment Destination)

0

1

jjjj-mm-ttThh:nn:ss

Inhalt | Beschreibung
Import | Ankunftszeit im Hafen (ETA)
Export | Ladeschluss (ETC)

Bitte verwenden Sie den korrekten knotennamen (ETA/ETC) je nach Position des Segments "Ship" in Segment "PickUp" oder "Destination"
PortCode

1

1

ü

string

Hafencode (UN/LOCODE)

(siehe UNECE, Liste aller internationalen Häfen)
PotName

1

1

ü

string

 Name des Hafens
TravelNumber

0

1

string

 Reisenummer

Legende

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Destination"


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Contact"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Contact"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Contact" (für die Übergeordneten Knoten "PickUp", "WayPoint" und "Destination"):

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Department

0

1

string(100)

Name der Fachabteilung
Name

1

1

ü

string(100)

Name des/der Sachbearbeiters/in
Phone

1

1

ü

string(20)

Telefonnummer
Mail

1

1

ü

string(200)

eMail-Adresse des/der Sachbearbeiters/in
Fax

0

1

string(20)

Faxnummer
CallBack

0

1

string(1)

Kennzeichen über Anforderung eines Rückrufs vor Abholung und/oder Anlieferung

Inhalt | Beschreibung
Y | IMS führt vor der Übernahme des Auftrags einen Rückruf bei dem angeführten Sachbearbeiters beim Auftraggeber durch
N | kein Rückruf erforderlich

Legende

zurück zum übergeordneten Knoten "PickUp"

zurück zum übergeordneten Knoten "Waypoint"

zurück zum übergeordneten Knoten "Destination"


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Container"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Container"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Container (bis Version 3.1.2.0) Container (ab version 3.1.3.0) | 1 | 99 | ü | . | einzelner Container

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Container"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Container"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung

Data (bis V3.1.1.0)

Data (V3.1.2.0)

1

1

ü

.

Angaben zum Container
Temperature

0

1

.

Angaben zur Kühlvorschrift
References

0

1

.

Referenzangaben
Comments

0

1

.

Kommentare und Informationstexte
Content

0

1

.

Angaben zum Inhalt des Containers
Services

0

1

.

Angaben zu den geforderten Leistungen

Angaben im Knoten "Services" wird in der aktuellen Version nicht verarbeitet.

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3000 - Inhalt Knoten "Data"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3000 - Inhalt Knoten "Data"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Data":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
RefNo

1

1

ü

string

Referenz des Auftraggebers für diesen Container
ID

0

1

string(11)

Containernummer

HabisCode

1

1

ü

string

Code basierend auf Rail-Port-Direkt HABIS A05-Containertypen

(siehe Rail-Port-Direkt)
ContainerType

1

1

ü

string(2)

Containertyp

(siehe Containertypen)
LengthCode

1

1

ü

string(2)

Länge des Containers in Fuß

(siehe Containerlängen)
Tara

1

1

ü

integer

Leergewicht des Containers in kg
Weight

1

1

ü

decimal(2)

Gesamtgewicht (Tara + Inhalt) des Containers
Empty

1

1

ü

string(1)

Kennzeichnen Leercontainer

Inhalt | Beschreibung
Y | Leercontainer
N | Container mit Inhalt
CustomSealNumber

0

1

string

Zollsiegelnummer
IMSContainerID

0

1

integer

IMS-Referenz für diesen Container
(wird von IMS vergeben)
IMSPoolID

0

1

integer

IMS-Referenz für Container-Pool
(wird von IMS vergeben)
TurnInOut

0

1

string

Turn-In, bzw. Turn-Out Referenz
PickUpReference

0

1

string

Anholreferenz
DeliveryReference

0

1

string

Anlieferreferenz
CustomIndicator

1

1

ü

string(1)

Kennzeichnung Zollgut

Inhalt | Beschreibung
Y | Zollgut
N | kein Zollgut
CustomProcedure

0

1

ü

string(2-3)

Zollprozedur

Inhalt | Beschreibung
AZA | Exportverzollung
BT1 | Bahn T1
ERL | Container ist abgefertigt
EU | Gemeinschaftsware
IVZ | Importverzollung
T1 | T1
T1B | FB T1 Stempel
VZT | IVZ d. Terminalspedition
XX | keine Verfügung
CustomsAgency

0

1

string

Angaben zur Zollagentur

Name und Adresse
DossierNo

0

1

string

Dossiernummer

(nur benötigt für Import/Export Hafen Rotterdam)
EmptyDepot

0

1

string

Name des Leercontainerdepots
EmptyDepotPin

0

1

string

Pin für Abholung-/Anlieferung des Containers im Leerdepot
ATBNo

0

1

string

ATB Nummer
ATA-ATCNo

0

1

string

ATA oder ATC Nummer
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet
Field5

0

1

string

 nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Data"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Data"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Data":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
RefNo

1

1

ü

string

Referenz des Auftraggebers für diesen Container
ID

0

1

string(11)

Containernummer

HabisCode

1

1

ü

string

Containertyp

(siehe Containertypen)
LengthCode

1

1

ü

string(2)

Länge des Containers in Fuß

(siehe Containerlängen)
Tara

1

1

ü

integer

Leergewicht des Containers in kg
Weight

1

1

ü

decimal(2)

Gesamtgewicht (Tara + Inhalt) des Containers
Empty

1

1

ü

string(1)

Kennzeichnen Leercontainer

Inhalt | Beschreibung
Y | Leercontainer
N | Container mit Inhalt
CustomSealNumber

0

1

string

Zollsiegelnummer
IMSContainerID

0

1

integer

IMS-Referenz für diesen Container
(wird von IMS vergeben)
IMSPoolID

0

1

integer

IMS-Referenz für Container-Pool
(wird von IMS vergeben)
TurnInOut

0

1

string

Turn-In, bzw. Turn-Out Referenz
PickUpReference

0

1

string

Anholreferenz
DeliveryReference

0

1

string

Anlieferreferenz
CustomIndicator

1

1

ü

string(1)

Kennzeichnung Zollgut

Inhalt | Beschreibung
Y | Zollgut
N | kein Zollgut
CustomProcedure

0

1

ü

string(2-3)

Zollprozedur

Inhalt | Beschreibung
AZA | Exportverzollung
BT1 | Bahn T1
ERL | Container ist abgefertigt
EU | Gemeinschaftsware
IVZ | Importverzollung
T1 | T1
T1B | FB T1 Stempel
VZT | IVZ d. Terminalspedition
XX | keine Verfügung
CustomsAgency

0

1

string

Angaben zur Zollagentur

Name und Adresse
DossierNo

0

1

string

Dossiernummer

(nur benötigt für Import/Export Hafen Rotterdam)
EmptyDepot

0

1

string

Name des Leercontainerdepots
EmptyDepotPin

0

1

string

Pin für Abholung-/Anlieferung des Containers im Leerdepot
ATBNo

0

1

string

ATB Nummer
ATA-ATCNo

0

1

string

ATA oder ATC Nummer

NetValue

0

1

.

decimal(2)

Nettowert der Ware im Container

Wird IMS von Ihnen mit der Erstellung von Zolldokumenten beauftragt, ist die Angabe des Warenwerts und Währung verpflichtend.

NetValueCurrencyCode

0

1

.

string(3)

 Währung (ISO 4217)
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet
Field5

0

1

string

 nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "Data"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "Data"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Data":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
RefNo

1

1

ü

string

Referenz des Auftraggebers für diesen Container
ID

0

1

string(11)

Containernummer

HabisCode

1

1

ü

string

Containertyp

(siehe Containertypen)
LengthCode

1

1

ü

string(2)

Länge des Containers in Fuß

(siehe Containerlängen)
Tara

1

1

ü

integer

Leergewicht des Containers in kg
Weight

1

1

ü

decimal(2)

Gesamtgewicht (Tara + Inhalt) des Containers
Empty

1

1

ü

string(1)

Kennzeichnen Leercontainer

Inhalt | Beschreibung
Y | Leercontainer
N | Container mit Inhalt
CustomSealNumber

0

1

string

Zollsiegelnummer
IMSContainerID

0

1

integer

IMS-Referenz für diesen Container
(wird von IMS vergeben)
IMSPoolID

0

1

integer

IMS-Referenz für Container-Pool
(wird von IMS vergeben)
TurnInOut

0

1

string

Turn-In, bzw. Turn-Out Referenz
PickUpReference

0

1

string

Anholreferenz
DeliveryReference

0

1

string

Anlieferreferenz
CustomIndicator

1

1

ü

string(1)

Kennzeichnung Zollgut

Inhalt | Beschreibung
Y | Zollgut
N | kein Zollgut
CustomProcedure

0

1

ü

string(2-3)

Zollprozedur

(siehe Zollprozeduren)
CustomsAgency

0

1

string

Angaben zur Zollagentur

Name und Adresse
CustomsDepartment

0

1

.

string

Kennnummer der Zollstelle für Einfuhr/Ausfuhr

(siehe http://ec.europa.eu/taxation_customs)

Wird IMS von Ihnen mit der Erstellung von Zolldokumenten beauftragt, ist die Angabe der Kennnummer der Zollstelle verpflichtend.
CustomsDepartmentName

0

1

.

string

Name der Zollstelle
DossierNo

0

1

string

Dossiernummer

(nur benötigt für Import/Export Hafen Rotterdam)
EmptyDepot

0

1

string

Name des Leercontainerdepots
EmptyDepotPin

0

1

string

Pin für Abholung-/Anlieferung des Containers im Leerdepot
ATBNo

0

1

string

ATB Nummer
ATA-ATCNo

0

1

string

ATA oder ATC Nummer

NetValue

0

1

.

decimal(2)

Nettowert der Ware im Container

Wird IMS von Ihnen mit der Erstellung von Zolldokumenten beauftragt, ist die Angabe des Warenwerts und Währung verpflichtend.

NetValueCurrencyCode

0

1

.

string(3)

 Währung (ISO 4217)
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet
Field5

0

1

string

 nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Temperature"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Temperature"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Temperature":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Refrigeration

1

1

ü

string(1)

gekühlt

Inhalt | Beschreibung
Y | Container wird gekühlt
N | Container ist nicht gekühlt
Min

1

1

ü

decimal(2)

Mindesttemperatur in Grad Celsius
Max

1

1

ü

decimal(2)

Maximaltemperatur in Grad Celsius

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Content"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Content"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Content":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Content (bis V3.1.1.0) Content (ab V3.1.2.0) | 1 | 99 | ü | . | Angaben zum Containerinhalt

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3000 - Inhalt Knoten "Content"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3000 - Inhalt Knoten "Content"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Content":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
RefNo

1

1

ü

string

Referenz des Auftraggebers für diese Ware
Description

1

1

ü

string(255)

Beschreibung der Ware
RIDCode

1

1

ü

string(1)

Gefahrengutkennung

Inhalt | Beschreibung
Y | Gefahrengut
N | kein Gefahrengut

Wird Ware als Gefahrengut gekennzeichnet ("Y"), ist die Anführung des untergeordnete Knoten "DangerousClass" (siehe unten) verpflichtend.
NetWeight

1

1

ü

decimal(2)

Nettogewicht der Ware inkl. Verpackung in kg
Collis

1

1

ü

Angaben zur Verpackung
CountryCodeOrigin

1

1

ü

string(2)

Herkunftsland

Ländercode nach ISO 3166 ALPHA-2
(siehe auch Wikipedia)
CountryCodeDestination

1

1

ü

string(2)

Bestimmungsland

Ländercode nach ISO 3166 ALPHA-2
(siehe auch Wikipedia)
NetValue

0

1

decimal(2)

Netto-Warenwert in Euro
CustomNumber

0

1

string

Zollnummer
ATBNumber

0

1

string

ATB-Nummer
IMSContentID

0

1

integer

IMS_Referenz der Ware innerhalb des Containers
(wird durch IMS vergeben)
BLNo

0

1

string

Master BL Nr. (Bill of Lading)

nur bei Import/Export im Hafen Rotterdam
BLSerialNo

0

1

string

Reihenfolge der Ware innerhalb einer Master BL Nr. (Bill of Lading)

nur bei Import/Export im Hafen Rotterdam
MRNNo

0

1

string

Movement Reference Number

(siehe Wikipedia)

HSCode

0

1

.

integer

Harmonized system code

siehe (Wikipedia, TARIC EU)

If you athorize IMS to create customsdocuments, you need to provide the HS code.
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet
Field5

0

1

string

 nicht verwendet

DangerousClass (V3.1.0.0)

DangerousClass (ab V3.1.1.0)

0

1

.

Angaben zur Gefahrenklasse

Der Inhalt dieses Knotens wird von IMS ist zwingend erforderlich, wenn die Ware als Gefahrengut gekennzeichnet wurde (siehe "RIDCode" (oben).

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Content"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Content"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Content":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
RefNo

1

1

ü

string

Referenz des Auftraggebers für diese Ware
Description

1

1

ü

string(255)

Beschreibung der Ware
RIDCode

1

1

ü

string(1)

Gefahrengutkennung

Inhalt | Beschreibung
Y | Gefahrengut
N | kein Gefahrengut

Wird Ware als Gefahrengut gekennzeichnet ("Y"), ist die Anführung des untergeordnete Knoten "DangerousClass" (siehe unten) verpflichtend.
NetWeight

1

1

ü

decimal(2)

Nettogewicht der Ware inkl. Verpackung in kg
Collis

1

1

ü

Angaben zur Verpackung
CountryCodeOrigin

1

1

ü

string(2)

Herkunftsland

Ländercode nach ISO 3166 ALPHA-2
(siehe auch Wikipedia)
CountryCodeDestination

1

1

ü

string(2)

Bestimmungsland

Ländercode nach ISO 3166 ALPHA-2
(siehe auch Wikipedia)
NetValue

0

1

decimal(2)

Netto-Warenwert in Euro
CustomNumber

0

1

string

Zollnummer
ATBNumber

0

1

string

ATB-Nummer
IMSContentID

0

1

integer

IMS_Referenz der Ware innerhalb des Containers
(wird durch IMS vergeben)
BLNo

0

1

string

Master BL Nr. (Bill of Lading)

nur bei Import/Export im Hafen Rotterdam
BLSerialNo

0

1

string

Reihenfolge der Ware innerhalb einer Master BL Nr. (Bill of Lading)

nur bei Import/Export im Hafen Rotterdam
MRNNo

0

1

string

Movement Reference Number

(siehe Wikipedia)

HSCode

0

1

.

integer

Zolltarifnummer

(siehe Wikipedia, TARIC EU)

Wird IMS von Ihnen mit der Erstellung von Zolldokumenten beauftragt, ist die Angabe des HS Codes (Zolltarifnummer) verpflichtend.

Es müssen 8 Stellen des HS-Codes übermittelt werden. Die Stellen 7-8 können mit "00" gefüllt werden.

Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet
Field5

0

1

string

 nicht verwendet

DangerousClass (V3.1.0.0)

DangerousClass (ab V3.1.1.0)

0

1

.

Angaben zur Gefahrenklasse

Der Inhalt dieses Knotens wird von IMS ist zwingend erforderlich, wenn die Ware als Gefahrengut gekennzeichnet wurde (siehe "RIDCode" (oben).

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Collis"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Collis"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Collis":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Colli | 1 | 99 | ü | . | Angaben zur einzelnen Verpackungseinheit

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Colli"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Colli"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Colli":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Count | 1 | 1 | ü | integer | Anzahl Verpackungseinheiten
Code | 1 | 1 | ü | string(2) | Verpackungscode Wir verwenden für den Datenaustausch folgende Codes
Description | 1 | 1 | ü | string | Bezeichnung der Verpackung

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "DangerousClass"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "DangerousClass"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "DangerousClass":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Class

1

1

ü

string

Gefahrenklasse

(siehe auch Wikipedia)
UNCode

0

1

ü

string

IMS-interne UN-Gefahrennummercodierung
UNNumber

1

1

ü

string

UN-Gefahrennummer

(siehe auch Wikipedia)
Description

1

1

ü

string(500)

Beschreibung des Gefahrenguts
FlashPoint

1

1

ü

decimal

Flammpunkt in Grad Celsius
GrossWeight

1

1

ü

integer

Bruttogewicht des Gefahrenguts in kg
NetWeight

0

1

ü

integer

Nettogewicht des Gefahrenguts in kg
NetExplosive

0

1

integer

Nettogewicht der explosiven Stoffe in kg
Number

1

1

ü

string

RID-Gefahrennummer

(siehe auch Wikipedia)
ClassCode

1

1

ü

string

RID-Klassifizierungscode
GrossZettel

0

1

string

Gefahrengutzettel

dieses Feld wird in der aktuellen Version nicht verarbeitet
Packaging

0

99

.

Angaben zur Gefahrengutverpackung
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet
Field5

0

1

string

 nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3110 - Inhalt Knoten "DangerousClass"
Sende Feedback
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3110 - Inhalt Knoten "DangerousClass"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "DangerousClass":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Class

1

1

ü

string

Gefahrenklasse

(siehe auch Wikipedia)
UNCode

0

1

ü

string

IMS-interne UN-Gefahrennummercodierung
UNNumber

1

1

ü

string

UN-Gefahrennummer

(siehe auch Wikipedia)
Description

1

1

ü

string(500)

Beschreibung des Gefahrenguts
FlashPoint

1

1

ü

decimal

Flammpunkt in Grad Celsius
GrossWeight

1

1

ü

integer

Bruttogewicht des Gefahrenguts in kg
NetWeight

0

1

ü

integer

Nettogewicht des Gefahrenguts in kg
NetExplosive

0

1

integer

Nettogewicht der explosiven Stoffe in kg
Number

1

1

ü

string

RID-Gefahrennummer

(siehe auch Wikipedia)
ClassCode

1

1

ü

string

RID-Klassifizierungscode
GrossZettel

0

1

string

Gefahrengutzettel

dieses Feld wird in der aktuellen Version nicht verarbeitet
Packaging

0

99

.

Angaben zur Gefahrengutverpackung

LQ

0

1

.

string

Limited Quantity

(siehe auch Wikipedia)

Inhalt Beschreibung
N

Keine Beförderung gemäß Limited Quantity Definition
Y

Beförderung gemäß Limited Quantity Definitiom

Im Falle einer Beförderung gemäß Limited Quantity Definition wird nur die Angabe der "UNNumber" verpflichtend.

UWG

0

1

.

string

Umweltgefährdende Stoffe

(siehe auch Wikipedia)

Inhalt | Beschreibung
N | Beinhaltet keine umweltgefährdenden Stoffe
Y | Beinhaltet umweltgefährdende Stoffe

BefCode

0

1

.

integer

Beförderungscode

Inhalt | Beschreibung
0 oder keine Angabe | Keine besonderen beförderungsvorgaben
1 | Beförderung erfolgt nach gem. RID Unterabschnitt 1.1.4.2.1.
Field1

0

1

string

 nicht verwendet
Field2

0

1

string

 nicht verwendet
Field3

0

1

string

 nicht verwendet
Field4

0

1

string

 nicht verwendet
Field5

0

1

string

 nicht verwendet

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Packaging"
Schnittstelle Order Inbound > IMS_CI_Order_V31nn > IMS_Schemas_Ext.PxB_CI_OI.V3100 - Inhalt Knoten "Packaging"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Packaging":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Code | 1 | 1 | ü | string(2) | Verpackungscode Wir verwenden für den Datenaustausch folgende Codes
Count | 1 | 1 | ü | integer | Anzahl Verpackungseinheiten
Group | 1 | 1 | ü | string | Gefahrengruppe

Legende

zurück zum übergeordneten Knoten


Schnittstelle Status Outbound
Siehe auch Sende Feedback
Schnittstelle Status Outbound > Schnittstelle Status Outbound

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Die Schnittstelle Status Outbound dient zur Übermittlung von Statusinformationen zu Kundenaufträgen von IMS an den Kunden.

Aktuelle Schnittstellenversion:

Schnittstellentyp | aktuelle Version | Freigabedatum | Beschreibung
IMS_CI_StatusOutbound | IMS_CI_Schemas.IMS_CI_StatusOutbound_V1095 | 20.01.2017 | XML-Schema für Statusinformationen

Die aktuelle Version V1.0.9.5 verwendet die gleiche Feldstruktur wie die vorangegangene Version V1.0.3.1.

Es wurde ein neuer Statuscode implementiert (218 Rechnungsaviso)

IMS versendet die Daten mit dem neuen Target Namespec http://IMS_CI_Schemas.IMS_CI_StatusOutbound_V1095

Zur Anmeldung für diese Schnittstelle siehe Anmeldung zum elektronischen Datenaustausch

Um die einwandfreie Funktion der gemeinsamen Schnittstelle zu gewährleisten, wird am Beginn ein Testbetrieb durchgeführt, während dessen die Daten geprüft werden, ohne dass die übermittelten Aufträge tatsächlich in das Produktionssystem des Kunden übernommen werden.

Show technische Spezifikationen

Spezifikation | Beschreibung
Dateiname

IMS_CI_SO_a-a-a-a_nnn_xxxxxxxxxxx.XML

Platzhalter | Inhalt
a-a-a-a | Versionsnummer der Schnittstellendefinition
nnn | Statuscode
xxxxxxxxxxx

GUID zur eindeutigen Kennung der Schnittstellendatei

Der Name einer Schnittstellendatei ist immer eindeutig.

encoding | "utf-8"
Inhalt
Eine Schnittstellendatei enthält immer die Statusinformationen für einen Container.

Show Kommunikation

Es stehen in der aktuellen Version drei Kommunikationsarten zur Verfügung.

Kommunikationsart | Beschreibung
FTP Abholung

Sie erhalten Zugang zum FTP-Server der IMS.

Verzeichnis | Beschreibung
outbound | Dieses Verzeichnis stellt das Ausgabeverzeichnis der IMS dar. Die Status Oubound Meldungen werden in diesem Verzeichnis zum Download zur Verfügung gestellt.
FTP Zustellung | IMS überträgt die Status Outbound Meldungen auf Ihren FTP Server.
eMail

IMS sendet die Status Outbound Meldungen als Attachment in einer eMail an den Kunden.

Feld | Beschreibung
Absender

Der Absender für eMails generiert durch das IMS Schnittstellensystem lautet immer:

"CustomerInterfaceRobot@imscargo.com"

Senden sie keine Antworten an diesen Absender. Diese eMails werden vom eMail-Server ignoriert.
Betreff

Der Text im Feld Betreff für den Versand von Status Outbound-Meldungen lautet:

"Customer-Interfaces - Status Outbound - Code nnn xxx...xxx

Platzhalter | Inhalt
nnn | Statuscode
xxx...xxx | Statusbezeichnung
Text | Im Textbereich wird der Inhalt der Datensendung angeführt und dient nur zu Informationszwecken.
Anhang | Als Anhang erhalten Sie die Schnittstellendatei gemäß deren technischer Spezifikation (siehe oben)
Bestätigung | Das Schnittstellensystem versendet die eMails ohne Anforderung von Empfangs- und/oder Lesebestätigungen.

Inhalt
Eine Schnittstellendatei zur Auftragsübermittlung kann immer nur Statusinformationen zu einem Container enthalten.

Show Status Codes

Eine Übersicht über die aktiven Statuscodes in der aktuellen Version der Schnittstelle erhalten sie hier.

Show Dokumentation XML Schema

aktuelle Version:

IMS_CI_Schemas.IMS_CI_StatusOutbound_V1095

vorangegangene Versionen:

IMS_CI_Schemas.IMS_CI_StatusOutbound_V1031

Show Downloads / Beispiele

Datei | Beschreibung
IMS_CI_StatusOutbound_V1095.xsd | XML Schema
IMS_CI_StatusOutbound_V1031.xsd | XML Schema
IMS_CI_StatusOutbound_V1031.xml | XML-Interfacedatei mit Testdaten

Siehe auch

Legenden
Legende Status-Codes

Version 1.0.3.1
IMS_CI_Schemas.IMS_CI_SO_V1_0_3_1

Release 1.0.9.5
IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5


Legende zur XML Schemata Beschreibung
Legenden > Legende zur XML Schemata Beschreibung

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Legende zu Tabellen mit den Knoten-/Feldbeschreibungen:

Spalte | Beschreibung
Knoten | Name des Knoten bzw. Felds
min

Mindestanzahl des Vorkommens dieses Knoten/Felds

"0" = Knoten/Feld muss in der Datenstruktur an dieser Stelle nicht angeführt sein
max

Maximalanzahl des Vorkommens dieses Knoten/Felds

"n" = Knoten/Feld darf in der Datenstruktur an dieser Stelle beliebig oft angeführt werden
Pflicht | Markierung dieser Knoten / dieses Feld als Pflichtfeld
Format

Format der Daten in diesem Knoten/Feld

Format | Beschreibung
string (n)

alphanumerischer Wert

Wert | Beschreibung
n | maximale Anzahl Zeichen
string (m-n)

alphanumerischer Wert

Wert | Beschreibung
m | Mindestanzahl Zeichen
n | maximale Anzahl Zeichen
integer | numerischer, ganzzahliger Wert
decimal (n)

Dezimalwert. Dezimaltrennzeichen = "."

Wert | Beschreibung
n | Anzahl Nachkommastellen
jjjj-mm-ttThh:nn:ss

Datum und Uhrzeit

Wert | Beschreibung
jjjj | Jahr, 4-stellig
mm | Monat
tt | Tag
hh | Stunde
nn | Minute
ss | Sekunde

Die Zeichen "T", "-" und ":" sind fixe Trennzeichen gemäß der XML-Datumsdefinition
boolean

Ja/Nein Information

Wert | Beschreibung
J | ja
N | nein

Beschreibung | Informationen zum Knoten-/FeldInhalt


Rechnungsschnittstelle - Dokumenttypen
Legenden > Rechnungsschnittstelle - Dokumenttypen

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Art des übermittelten Dokuments in der Rechnungsschnittstelle (Customer Invoice).

Code | Beschreibung
RG | Rechnung
GU | Gutschrift
RU | Rückbelastung
PG | Partnergutschrift


Legende Containertypen
Siehe auch Sende Feedback
Legenden > Legende Containertypen

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Liste aller verwendeten Containertypen:

Code | Beschreibung
BK | Bulk
DC | Box
FC | Flat
RH | High Cube Reefer
HC | High Cube
HT | Hard Top
OT | Open Top
RE | Reefer
TA | Tank

Siehe auch

Version 3.1.n.n
IMS_Schemas_Ext.PxB_CI_OI.V3000 - Inhalt Knoten "Data"
IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Data"
IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "Data"

Version 1.2.2.0
IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Data"


Legende Containerlängen
Siehe auch Sende Feedback
Legenden > Legende Containerlängen

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Liste aller verfügbaren Containerlängen:

Code | Beschreibung
20 | 20 Fuß
24 | 24 Fuß
25 | 25 Fuß
30 | 30 Fuß
40 | 40 Fuß
45 | 45 Fuß

Siehe auch

Version 3.1.n.n
IMS_Schemas_Ext.PxB_CI_OI.V3000 - Inhalt Knoten "Data"
IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Data"
IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "Data"

Version 1.2.2.0
IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Data"


Firmen der IMS Firmengruppe
Siehe auch Sende Feedback
Legenden > Firmen der IMS Firmengruppe

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Die IMS Gruppe umfasst folgende Firmen:

Shortcut | Kurzname | Address
IMS AT | IMS CARGO Austria GmbH | IMS CARGO Austria GMBH Trillergasse 8 1210 Wien Österreich
IMS DE | IMS CARGO Germany GmbH | IMS CARGO Germany GmbH Heidenkampsweg 44 20097 Hamburg Deutschland
IMS SK | IMS CARGO Sloavkia s.r.o | IMS CARGO Slovakia s.r.o Hranicna 18 82105 Bratislava Slowakei
IMS CH | IMS RAIL Switzerland AG | IMS RAIL SWITZERLAND AG Margarethenstrasse 38 4002 Basel Schweiz
IMS HU | IMS CARGO Hungary Kft. | IMS CARGO HUNGARY Kft. Visonta utca 1 1151 Budapest Ungarn
IMS BE | IMS CARGO Belgium BVBA | IMS CARGO Belgium BVBA Legrandlaan 41 1050 Brüssel Belgien
IMS ES | Intercontainer Iberica S.A. | Intercontainer Iberica S.A. C/ Enrique Larreta, 7 28036 Madrid Spanien
IMS NL | IMS CARGO Netherlands B.V. | IMS CARGO Netherlands B.V. Hoefsmidstraat 41 3194 AA Rotterdam-Hoogvliet Niederlande

Siehe auch

Legende Status-Codes


Legende Status-Codes
Siehe auch Sende Feedback
Legenden > Legende Status-Codes

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Die Schnittstelle Status Outbound in der aktuellen Version beinhaltet die Übertragung von Informationen zu folgender Ereignissen:

Show allgemeine Daten

Jede Statusinformation enthält neben den Statusinformationen immer folgende generelle Informationen:

  • Auftrag
    • Auftragsreferenz des Kunden
    • IMS Auftrags ID
    • IMS Offert ID
    • Kundennummer bei IMS
    • dem Auftrag zugeordneter Sachbearbeiter beim Kunden
  • Container
    • IMS Container ID
    • Containernummer
    • Containertyp
    • Staffel
    • Gesamtgewicht

Show Status-Codes

Status-Code

Code

ab Version

 Beschreibung übermittelte Werte
205

Order confirmation

1.0.3.1

Auftragsbestätigung

net, PoD, PoA, notes

(net, PoD, PoA, notes)
206

Additional costs - pre advice

1.0.3.1

 Information über neu anfallende Nebenspesen

service, net, company, notes

(service, net, company, notes)
207

Container number assigned

1.0.3.1

 Containernummer wurde einem Container zugeordnet

containerno

(containerno)
208 Seal number assigned

1.0.3.1

 Siegelnummer wurde einem Container zugeordnet

sealno

(sealno)
209 . .

noch unbenutzt

 .
210 . .

noch unbenutzt

 .
211 . .

noch unbenutzt

 .
212 Booking confirmation

1.0.3.1

 Information über die erstmalige Buchung eines Containers für den Transport

DoD, DoA, ship, carrier, SoA, ToA, notes

(DoD, DoA, ship, carrier, SoA, ToA, notes)
213 Booking information

1.0.3.1

 Information über Zuordnung eines Containers auf einen Zug

DoD, DoA, SoA, ToA, notes

(DoD, DoA, SoA, ToA, notes)
214 Information about delay

1.0.3.1

 Information über eine Verzögerung/Verschiebung des Transporttermins

DoD, notes

(DoD, notes)
215 Crossbooking information

1.0.3.1

 Information über die Umbuchung des Containers auf einen anderen Zug

DoD, notes

(DoD, notes)
216 Train departure

1.0.3.1

 Information über den Abgang eines Containers vom Abgangsterminal

DoD, DToA, SoA, ToA, SoD, ToD, wagon, notes

(DoD, DToA, SoA, ToA, SoD, ToD, wagon, notes)
217 Train arrival

1.0.3.1

 Information über den Eingang eines Containers am Zielterminal

DoD, DToA, SoA, ToA, SoD, ToD, wagon, notes

(DoD, DToA, SoA, ToA, SoD, ToD, ToA, wagon, notes)
218 Invoice advice

1.0.9.5

Vorabinformation zu einer Ausgangsrechnung

service, net, company, notes, invoiceID

(service, net, company, notes, invoiceID)
219 Train delay

1.0.3.1

 Information über Zugsverspätung

DToD, notes

(DToD, notes)
220 Road arrival

1.0.9.5

(ab 01.09.2017)

Information über den Eingang eines Containers am Abgangsterminal

Der Versand der "Road Arrival"-Meldung wird von IMS nur für Terminals versendet, die Gate-In-/Gate-Out-Meldungen elektronisch zur Verfügung stellen.

Zur Zeit wird diese Meldung nur für die Terminals "WienCont Containerterminal Wien Freudenau" und "Containerterminal Enns" versendet.

DToA, SoD, ToD

(DToA, SoD, ToD)
221 Road departure

1.0.9.5

(ab 01.09.2017)

Information über den Abgang eines Containers am Zielterminal

Der Versand der "Road Departure"-Meldung wird von IMS nur für Terminals versendet, die Gate-In-/Gate-Out-Meldungen elektronisch zur Verfügung stellen.

Zur Zeit wird diese Meldung nur für die Terminals "WienCont Containerterminal Wien Freudenau" und "Containerterminal Enns" versendet.

DToD, SoA, ToA

(DToD, SoA, ToA)

Siehe auch

Tutorials
Schnittstelle Status Outbound


Legende Zollprozeduren
Siehe auch Sende Feedback
Legenden > Legende Zollprozeduren

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Liste aller verfügbaren Zollprozeduren:

ab Version 3.1.3.0:

Code | Beschreibung
EER | Export: Container ist abgefertigt
EEU | Export: Gemeinschaftsware (EU)
ENE | Export: keine Gemeinschaftsware
ETT | Export: T1
IEM | Leercontainer
IER | Import: Container ist abgefertigt
IEU | Import: Gemeinschaftsware (EU)
IKK | Import: Bahn T1 durch Kunde
IT | Import: Bahn T1 bis Endbestimmung
ITC | Import: T1/Importverzollung durch Kunde
ITI | Import: T1/Importverzollung
ITN | Import: T1/keine Verfügung
ITT | Import: T1/T1
ITG | Import: T1 + Gemeinschaftsware *)

*) seit 22.11.2017

bis Version 3.1.2.0:

Code | Beschreibung
AZA | Exportverzollung
BT1 | Bahn T1
ERL | Container ist abgefertigt
EU | Gemeinschaftsware
IVZ | Importverzollung
T1 | T1
T1B | FB T1 Stempel
VZT | IVZ d. Terminalspedition
XX | keine Verfügung

Siehe auch

Version 3.1.n.n
IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "Data"
IMS_Schemas_Ext.PxB_CI_OI.V3000 - Inhalt Knoten "Data"
IMS_Schemas_Ext.PxB_CI_OI.V3120 - Inhalt Knoten "Data"

Version 1.2.2.0
IMS_CI_Schemas.IMS_CI_Order_V1_2_2_0 - Inhalt Knoten "Data"


Downloads
Download > Downloads

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Liste aller XML-Schemata und Beispieldateien des Schnittstellensystems "Customer Interfaces":

Teilsystem "Customer Invoice"

Show XML Schemata

Schnittstelle | Datei | Beschreibung
Customer Invoice - IMS_CI_CustomerInvoice_XML | IMS_CI_CustomerInvoice2_V1096 File | XML Schema
Customer Invoice - openTRANS_INVOICE_1_0_all_in_one | openTRANS_INVOICE_1_0_all_in_one File_V1096 | XML Schema
Customer Invoice - IMS_CI_CustomerInvoice_FF | . | XML Schema

Show Beispieldaten

Die Beispieldateien sind logisch in sich nicht schlüssig. Es sind alle Knoten/Felder mit gültigen Werten gefüllt. Aber weder Mengen-, Preis- oder Relationsangaben entsprechen Produktionsdaten. Auch sind alle kundenspezifischen Angaben fiktiv.

Schnittstelle | Datei | Beschreibung
Customer Invoice - IMS_CI_CustomerInvoice_XML | IMS_CI_CustomerInvoice2_V1096_Example File | XML-Schnittstellendatei mit Testdaten
Customer Invoice - IMS_openTRANS_INVOICE_1_0 | IMS_openTRANS_INVOICE_1096_Example File | XML-Schnittstellendatei mit Testdaten
Customer Invoice - IMS_CI_CustomerInvoice_FF | IMS_CI_CustomerInvoice_V1096_Example File | CSV-Schnittstellendatei mit Testdaten

Teilsystems "Order Inbound"

Show XML Schemata

Schnittstelle | Datei | Beschreibung
Order Inbound - IMS_CI_Order | PxB_CI_OI_V3130.xsd PxB_CI_OI_V3120.xsd PxB_CI_OI_V3110.xsd PxB_CI_OI_V3100.xsd | XML Schema Order Inbound
Order Inbound - IMS_CI_ACK | PxB_CI_ACK.xsd | XML Schema Acknowledge

Show Beispieldaten

Die Beispieldateien sind logisch in sich nicht schlüssig. Es sind alle benötigten Knoten/Felder mit gültigen Werten gefüllt. Aber weder Mengen-, Preis- oder Relationsangaben entsprechen Produktionsdaten. Auch sind alle kundenspezifischen Angaben fiktiv.

Schnittstelle | File | Beschreibung
Order Inbound - IMS_CI_Order | PxB_CI_OI_V3100.xml | XML-Schnittstellendatei mit Testdaten
Order Inbound - IMS_CI_ACK | PxB_CI_TACK_V1201.xml | XML-Schnittstellendatei mit Testdaten für technical acknowledge
Order Inbound - IMS_CI_ACK | PxB_CI_DACK_V1201_Error.xml | XML-Schnittstellendatei mit Testdaten für data acknowledge (mit Fehler)
Order Inbound - IMS_CI_ACK | PxB_CI_DACK_V1201_OK.xml | XML-Schnittstellendatei mit Testdaten für data acknowledge (ohne Fehler)

Teilsystems "Status Outbound"

Show XML Schemata

Schnittstelle | Datei | Beschreibung
Status Outbound - IMS_CI_StatusOutbound | IMS_CI_StatusOutbound_V1031.xsd | XML Schema Status Outbound

Show Beispieldaten

Die Beispieldateien sind logisch in sich nicht schlüssig. Es sind alle benötigten Knoten/Felder mit gültigen Werten gefüllt. Aber weder Mengen-, Preis- oder Relationsangaben entsprechen Produktionsdaten. Auch sind alle kundenspezifischen Angaben fiktiv.

Schnittstelle | File | Beschreibung
Status Outbound - IMS_CI_StatusOutbound | IMS_CI_StatusOutbound_V1031.xml | XML-Schnittstellendatei mit Testdaten


eRechnung
Siehe auch Sende Feedback
eRechnung > eRechnung

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

IMS bietet seinen Kunden die Zustellung von elektronisch signierten Rechnungen per eMail an. Die eRechnung bietet Ihnen zahlreiche Vorteile:

  • Rechnung liegt in digitaler Form vor
  • Einfache Ablage der Rechnung
  • die Aufbewahrungsfristen entsprechen denen von Rechnungen in Papierform
  • Wir tragen gemeinsam zum Schutz unserer Umwelt bei, da wir auf Papier und Energie sparen und weniger Abfall erzeugen
  • durch rechtskonforme Signierung entspricht die eRechnung allen gesetzlichen Anforderungen innerhalb der EU

Show Informationen zur Signierung

Root Certificate Authority - Installation Wir verwenden zur Signierung der Dokumente das Zertifikat 'A-CERT Advanced'.

Sie finden in den nachfolgenden Links Informationen zur Installation des Zertifikats und zu den rechtlichen Grundlagen.

Einstellungen für Adobe Reader

http://www.a-cert.at/php/cms_monitor.php?q=PUB-SUPPORT-A-CERT

A-CERT ADVANCED 3 ist Microsoft XP- und Vista-ready. Erhält ein Kunde erstmals ein Dokument/Mail, dass mit einem von A-CERT ADVANCED 3 ausgestellten Zertifikat signiert wurde, wird seine Zertifikatsspeicherverwaltung automatisch aktualisiert (Internetverbindung vorausgesetzt). Benutzer älterer Microsoft-Betriebssysteme sollten mittels dem Windows-Patch ihre Zertifikatverwaltung aktualisieren:
http://download.windowsupdate.com/msdownload/update/v3/static/trustedr/en/rootsupd.exe

Ausführliche Informationen zum Stammzertifikatsupdate finden sich unter
http://www.a-cert.at/php/cms_monitor.php?q=PUB-TEXT-A-CERTs=03375qjv

Allgemeine Informationen zum Thema Zertifizierung finden sich unter
http://www.a-cert.at/php/cms_monitor.php?q=FAQ-A-CERT

Signaturgesetz:
http://www.signatur.rtr.at/de/legal/sigg.html

Hier können Sie das Anmeldeformular für die eRechnung der IMS abrufen. Für Fragen stehen wir Ihnen gerne auch telefonisch zur Verfügung.

Siehe auch

Einleitung
Anmeldung


%%Phrase%%

Glossar

Glossary Item Box

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

acknowledge

Unter "acknowledge" wird bei den Customer Interfaces die Beantwortung einer Datensendung verstanden.

Das "technical acknowledge" bestätigt den physischen Empfang einer Schnittstellendatei.

Das "data acknowledge" bestätigt die Verarbeitung der enthaltenen Daten. Das "data acknowledge" beinhaltet eine Bestätigung der Verarbeitung der Daten oder eine Ablehnung der Daten verbunden mit einer Beschreibung des Ablehnungsgrunds.

C

Customer Interfaces
Der Begriff "Customer Interfaces" umfasst alle Schnittstellen zum elektronischen Datenaustausch zwischen Kunden und Partner der IMS und der IMS.

Customer Invoice
Der Begriff "Customer Invoice" umfasst alle elektronischen Schnittstellen zum Versand einer elektronsichen Rechnung durch IMS an unsere Kunden.

D

data acknowledge

Das "data acknowledge" bestätigt die Verarbeitung der enthaltenen Daten. Das "data acknowledge" beinhaltet eine Bestätigung der Verarbeitung der Daten oder eine Ablehnung der Daten verbunden mit einer Beschreibung des Ablehnungsgrunds.

F

FieldCode: Carrier
SCA-Code und Name des Reeders

FieldCode: Company
Code zur Angabe der beauftragten Firma der IMS Firmengruppe

FieldCode: Container number
11-stellige Containernummer (ohne Sonderzeichen)

FieldCode: DoA
Datum des Eingangs / der Ankunft

FieldCode: DoD
Datum des Abgangs (ohne Angabe einer Uhrzeit)

FieldCode: DToA
Datum und Uhrzeit der Ankunft / des Eingangs

FieldCode: DToD
Datum und Uhrzeit des Abgangs

FieldCode: invoiceID
Rechnungsnummer der avisierten Ausgangsrechnung

FieldCode: Netto-Auftragswert
Nettowert des Auftrags für alle bereits bekannten Leistungen.

FieldCode: Netto-Leistungswert
Nettowert einer Leistung

FieldCode: Notes
Notizen, Hinweise, zusätzliche Informationen

FieldCode: Port of Arrival
UNLoCode und Name des Bestimmungshafens

FieldCode: Port of Departure
UNLoCode und Name des Abgangshafens

FieldCode: Seal number
Die dem Container zugewiesene Siegelnummer

FieldCode: Service
Beschreibung der erbrachten Leistung

FieldCode: Ship
Name des Schiffs

FieldCode: SoA
Bahnhofsnummer (IBNR) des Empfangsbahnhofs

FieldCode: SoD
Bahnhofsnummer (IBNR) des Abgangsbahnhofs

FieldCode: ToA
Bezeichnung des AGL am Empfangsbahnhof

FieldCode: ToD
Bezeichnung des AGL am Abgangsbahnhof

FieldCode: wagon
Wagennummer des Wagens, auf den der Container verladen wurde

G

GUID

Global Unique Identifier

Eine hexadecimale Zeichenfolge zur eindeutigen Definition einer Firma, einer Datenübertragung oder eines Dateninhalts in dem Schnittstellensystem "Customer Interfaces".

Format: "XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX"
z.B.: "936DA01F-9ABD-4D9D-80C7-02AF85C822A8"

I

Inbound
Der Inbound (Datenausgang) umfasst alle Datenübertragungen an IMS.

O

Order Inbound
"Order Inbound" ist der technische Begriff für das Eintreffen eines online gesendeten Auftrags durch den Kunden an IMS.

Outbound
Der Outbound (Datenausgang) umfasst alle Datensendungen von IMS an Kunden oder Partner.

S

Status Outbound
"Status Outbound" ist der technische Begriff für den Versand von Statusmeldungen zu Kundenaufträgen von IMS an den Kunden.

T

technical acknowledge

Das "technical acknowledge" bestätigt den physischen Empfang einer Schnittstellendatei.


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you


IMS_CI_ACK

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Dieses Format definiert das Acknowledge (technical und data), dass als Quittung von IMS als XML-Dokument an den Datensender übermittelt wird..

aktuelle Version: 1.2.0

Show technische Spezifikationen

Spezifikation | Beschreibung
Dateierweiterung | XML
Schema | IMS_Schemas.PxB_CI_ACK.V1-2-0-1
targetnamespec | <ns0:ACK xmlns:ns0="http://IMS_Schemas.PxB_CI_ACK.V1-2-0-1">

Show Versionshistorie

Spezifikation | Freigabedatum | Beschreibung
1.2.0.1 | 01.02.2011 | Betatest-Phase

Show Dokumentation XML Schema

XML Schema für IMS_CI_Schemas.PxB_CI_ACK.V1-2-0-1

Show Downloads / Beispiele

Spezifikation | Beschreibung
PxB_CI_ACK.xsd | XML Schema
PxB_CI_TACK_V1201.xml | XML-Interfacedatei mit Testdaten für technical acknowledge
PxB_CI_DACK_V1201_Error.xml | XML-Interfacedatei mit Testdaten für data acknowledge (mit Fehler)
PxB_CI_DACK_V1201_OK.xml | XML-Interfacedatei mit Testdaten für data acknowledge (ohne Fehler)

zurück


Glossary Item Box


IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "Container"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung

Data (ab Version 3.1.3.0)

1

1

ü

.

Angaben zum Container
Temperature

0

1

.

Angaben zur Kühlvorschrift
T1Consignee (ab Version 3.1.3.0)

0

1

.

.

Angaben zum Warenempfänger laut

Angaben zum Warenempfänger laut T1-Dokument sind nur erforderlich, wenn der Containerzollrelevante Güter geladen hat und der Warenempfänger laut T1-Dokument abweichend zum Warenempfänger in den Knoten "Relations" ist.

References

0

1

.

Referenzangaben
Comments

0

1

.

Kommentare und Informationstexte
Content

0

1

.

Angaben zum Inhalt des Containers
Services

0

1

.

Angaben zu den geforderten Leistungen

Angaben im Knoten "Services" wird in der aktuellen Version nicht verarbeitet.

Legende

zurück zum übergeordneten Knoten


IMS_Schemas_Ext.PxB_CI_OI.V3130 - Inhalt Knoten "T1Consignee"
Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "T1Consignee":

Angaben zum Warenempfänger laut T1-Dokument sind nur erforderlich, wenn der Container zollrelevante Güter geladen hat und der Warenempfänger laut T1-Dokument abweichend zum Warenempfänger in den Knoten "Relations" ist.

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Name1 | 1 | 1 | ü | string(50) | Name des T1-Empfängers
Name2 | 1 | 1 |  | string(50) | Erweiterung Name des T1-Empfängers
Adress1 | 1 | 1 |  | string(50) | Adresse des T1-Empfängers(Strasse und Hausnummer)
Adress2 | 1 | 1 |  | string(50) | Erweiterung Adresse des T1-Empfängers(Strasse und Hausnummer)
ZipCode | 1 | 1 |  | string(7) | Postleitzahl
Town | 1 | 1 | ü | string(50) | Ort
CountryCode | 1 | 1 | ü | string(2) | Ländercode nach ISO 3166 ALPHA-2 (siehe auch Wikipedia)
VATID | 1 | 1 |  | string(13) | Umsatzsteuer Ident Nummer (siehe auch Wikipedia)

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 - Knoten "Invoice"
Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Knoten | min | max | Pflicht | Format | Beschreibung
Invoice | 1 | 1 | ü |  | Root Knoten für Rechnungsdatensatz

Legende

zurück


IMS_CI_Schemas.IMS_CI_CustomerInvoice_V1096 - Knoten "Line"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Invoice":

Knoten | min | max | Pflicht | Format | Beschreibung
Line | 1 | n | ü |  | Rechnungsposition

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Knoten "ACK"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
ACK | 1 | 1 | ü | . | Root Knoten für acknowledge

Legende

zurück


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Knoten "ACK"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "ACK":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Data

1

1

ü

.

 Daten zum Acknowledge
Errors

0

1

.

.

Auflistung von aufgetretenen Fehlern

Nur bei data acknowledge für fehlerhafte Datensendung eines online Auftrags
References

0

1

.

.

Auflistung der Referenzen

Nur bei data acknowledge für Datensendung eines online Auftrags ohne Fehler

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Knoten "Data"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Data":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
ID

1

1

ü

guid

ID der Datensendung (ACK)
DateTime

1

1

ü

jjjj-mm-ttThh:mm:ss

 Datum und Uhrzeit der Erstellung des ACK
Code

1

1

ü

string(1)

Art des ACK

Inhalt | Beschreibung
T | technical acknowledge
D | data acknowledge
SendType

1

1

ü

string(1)

Art des Kommunikationswegs

Inhalt | Beschreibung
MAI | eMail
FTP | per FTP push auf IMS-FTP-Server
OTH | other (Kommunikationsweg unbekannt)
HandlingCode

1

1

ü

string(1)

Unterscheidung Test-/Produktionsbetrieb

Inhalt | Beschreibung
P | Produktionsbetrieb
T | Testbetrieb
SenderID

1

1

ü

guid

GUID des Senders des ACK
ReceiverID

1

1

ü

guid

GUID des Empfängers des ACK
IDReferenced

1

1

ü

guid

ID der quittierten Datensendung
ErrorCode

1

1

ü

string(2)

Fehlercode

Inhalt | Beschreibung
OK | keine Fehler
OE | Fehler (siehe Knoten Errors)
DE | Fehler (siehe Knoten Errors)

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Knoten "Errors"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Errors":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Error | 1 | 99 | ü | . | einzelne Fehlermeldung

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Knoten "Error"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Error":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Text | 1 | 1 | ü | string | Fehlerbeschreibung

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Knoten "References"
Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "References":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Orders | 1 | 1 | ü | . | Knoten mit den Referencen zu einem übermittelten Datensatz

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Knoten "Orders"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Orders":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Order | 1 | 99 | ü | . | Knoten mit den Referencen zum übermittelten online Auftrag

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Knoten "Order"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Order":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
RefExt | 0 | 1 |  | string | Auftragsreferenz des Auftraggebers
RefIMS | 0 | 1 | . | integer | Auftragsnummer IMS
Container | 0 | 1 | . | . | Auflistung Referenzen für Container

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Knoten "Container"
Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Container | 1 | 1 | ü | . | Knoten mit den Referencen zu einem übermittelten Datensatz

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_ACK_V1_2_0_1 - Content Knoten "Container"
Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
RefExt

0

1

string

 Auftragsreferenz des Auftraggebers
RefIMS

0

1

.

integer

 Container ID IMS
Content

0

1

.

.

Auflistung Referenzen für Containerinhalt

Dieser Knoten wird in der aktuellen Version nicht verwendet.

Legende

zurück zum übergeordneten Knoten


IMS_CI_Schemas.IMS_CI_SO_V1_0_3_1

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
StatusOutbound | 1 | 1 | ü | . | Root Knoten für Status Meldungen

Legende

zurück


IMS_CI_SO_V1_0_3_1 - Knoten StatusOutbound

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "StatusOutbound":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Prefix | 1 | 1 | ü | . | technische Daten zur Datensendung
Status | 1 | 1 | ü | . | Daten zur Statusmeldung

Legende

zurück


IMS_CI_SO_V1_0_3_1 - Knoten Prefix

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Prefix":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Version

1

1

ü

string(7-7)

Versionsnummer der Schnittstellendatei

Bitte achten Sie auf die Versionsnummer. Bei Änderungen erhalten Sie rechtzeitig eine Information über die neue Version.

aktuelle Versionskennung
1-0-3-1

ID

1

1

ü

string(36-36)

 eindeutige GUID dieser Datensendung (Schnittstellendatei)
DateTime

1

1

ü

jjjj-mm-ddThh:nn:ss

 Datum und Uhrzeit der Erstellung der Schnittstellendatei
Sendtype

1

1

ü

string(3-3)

Art des Kommunikationswegs

Inhalt | Beschreibung
MAI | eMail
FTP | FTP push/pull
HandlingCode

1

1

ü

string(1-1)

Unterscheidung Test-/Produktionsbetrieb

Inhalt | Beschreibung
P | Produktion
T | Test

Achten Sie bitte unbedingt auf die korrekte Auswahl in diesem Knoten. Die Adressierung der Testumgebung ist nur während der Testphasen erlaubt. Die aus der Testumgebung erstellten Statusmeldungen dürfen nicht in Ihr Produktionssystem übernommen werden.
SenderID

1

1

ü

string(36-36)

GUID IMS
D4AF98C4-5930-430B-855B-B74785ACFEF6

ReceiverID

1

1

ü

string(36-36)

GUID des Datenempfängers (Kunde)

Ihre GUID wird Ihnen im Zuge der Anmeldung zu dieser Schnittstelle bekanntgegeben.
IDReferenced

0

0

.

string(36-36)

GUID der zugrundeliegenden Datensendung

Wird in dieser Schnittstelle nicht verwendet
ErrorCode

0

0

.

string(2)

Fehlercode

Wird in dieser Schnittstelle nicht verwendet

Legende

zurück


IMS_CI_SO_V1_0_3_1 - Knoten Status
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Status":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Code | 1 | 1 | ü | integer | Status-Code
Text | 1 | 1 | ü | string | Bezeichnung Status-Code
Order | 1 | 1 | ü | . | Daten zum Auftrag/Container/Status

Legende

zurück

Siehe auch

Legenden
Legende Status-Codes


IMS_CI_SO_V1_0_3_1 - Knoten Order

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Order":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Reference | 1 | 1 | ü | string | Kundenreferenz zum Auftrag
IMSOrderID | 1 | 1 | ü | integer | Auftragsnummer bei IMS
IMSOfferID | 1 | 1 | ü | integer | ID des dem Auftrag zugrundeliegenden Offerts bei IMS
IMSCustomerID | 1 | 1 | ü | integer | Kundenummer des Auftraggebers bei IMS
User | 1 | 1 | ü | string() | Name des Ansprechpartners beim Kunden (für diesen Auftrag)
Container | 1 | 1 | ü | . | Liste der Container

Legende

zurück


IMS_CI_SO_V1_0_3_1 - Knoten Container

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Container | 1 | n | ü | . | Daten zu einem Container / Status

Legende

zurück


IMS_CI_SO_V1_0_3_1 - Knoten Container

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
IMSContainerID | 1 | 1 | ü | integer | Container ID bei IMS
Number | 1 | 1 | ü | string(11) | Containernummer (ohne Formatierungszeichen)
Type | 1 | 1 | ü | string | Containertyp (siehe)
Scale | 1 | 1 | ü | string | Angaben zur Gewichts-/Längenstaffel (siehe)
GrossWeight | 1 | 1 | ü | decimal(2) | Gesamtgewicht inkl. Tara
Data | 1 | 1 | ü | . | Liste der Informationen zum Status

Legende

zurück


IMS_CI_SO_V1_0_3_1 - Knoten Data

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Data":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Data | 1 | n | ü | . | Information zum Status

Legende

zurück


IMS_CI_SO_V1_0_3_1 - Knoten Data1
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Data":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Code | 1 | 1 | ü | string | Code (siehe Definitionen)
Value | 1 | 1 | ü | string | Wert
Text | 0 | 1 |  | string | Weitere Informationen (siehe Definitionen)

Legende

zurück

Siehe auch

Legenden
Legende Status-Codes


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
StatusOutbound | 1 | 1 | ü | . | Root Knoten für Status Meldungen

Legende

zurück


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Knoten StatusOutbound

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "StatusOutbound":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Prefix | 1 | 1 | ü | . | technische Daten zur Datensendung
Status | 1 | 1 | ü | . | Daten zur Statusmeldung

Legende

zurück


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Knoten Prefix

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Prefix":

Knoten/Feld/Attribut

min

max

Pflicht

Format

 Beschreibung
Version

1

1

ü

string(7-7)

Versionsnummer der Schnittstellendatei

Bitte achten Sie auf die Versionsnummer. Bei Änderungen erhalten Sie rechtzeitig eine Information über die neue Version.

aktuelle Versionskennung
1-0-3-1

ID

1

1

ü

string(36-36)

 eindeutige GUID dieser Datensendung (Schnittstellendatei)
DateTime

1

1

ü

jjjj-mm-ddThh:nn:ss

 Datum und Uhrzeit der Erstellung der Schnittstellendatei
Sendtype

1

1

ü

string(3-3)

Art des Kommunikationswegs

Inhalt | Beschreibung
MAI | eMail
FTP | FTP push/pull
HandlingCode

1

1

ü

string(1-1)

Unterscheidung Test-/Produktionsbetrieb

Inhalt | Beschreibung
P | Produktion
T | Test

Achten Sie bitte unbedingt auf die korrekte Auswahl in diesem Knoten. Die Adressierung der Testumgebung ist nur während der Testphasen erlaubt. Die aus der Testumgebung erstellten Statusmeldungen dürfen nicht in Ihr Produktionssystem übernommen werden.
SenderID

1

1

ü

string(36-36)

GUID IMS
D4AF98C4-5930-430B-855B-B74785ACFEF6

ReceiverID

1

1

ü

string(36-36)

GUID des Datenempfängers (Kunde)

Ihre GUID wird Ihnen im Zuge der Anmeldung zu dieser Schnittstelle bekanntgegeben.
IDReferenced

0

0

.

string(36-36)

GUID der zugrundeliegenden Datensendung

Wird in dieser Schnittstelle nicht verwendet
ErrorCode

0

0

.

string(2)

Fehlercode

Wird in dieser Schnittstelle nicht verwendet

Legende

zurück


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Knoten Status
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Status":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Code | 1 | 1 | ü | integer | Status-Code
Text | 1 | 1 | ü | string | Bezeichnung Status-Code
Order | 1 | 1 | ü | . | Daten zum Auftrag/Container/Status

Legende

zurück

Siehe auch

Legenden
Legende Status-Codes


IMS_CI_Schemas.IMS_CI_SO_V1_0_8_5 - Knoten "Order"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Order":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Reference | 1 | 1 | ü | string | Kundenreferenz zum Auftrag
IMSOrderID | 1 | 1 | ü | integer | Auftragsnummer bei IMS
IMSOfferID | 1 | 1 | ü | integer | ID des dem Auftrag zugrundeliegenden Offerts bei IMS
IMSCustomerID | 1 | 1 | ü | integer | Kundenummer des Auftraggebers bei IMS
User | 1 | 1 | ü | string() | Name des Ansprechpartners beim Kunden (für diesen Auftrag)
Container | 1 | 1 | ü | . | Liste der Container

Legende

zurück


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Knoten "Container"

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Container | 1 | n | ü | . | Daten zu einem Container / Status

Legende

zurück


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Knoten Container

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Container":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
IMSContainerID | 1 | 1 | ü | integer | Container ID bei IMS
Number | 1 | 1 | ü | string(11) | Containernummer (ohne Formatierungszeichen)
Type | 1 | 1 | ü | string | Containertyp (siehe)
Scale | 1 | 1 | ü | string | Angaben zur Gewichts-/Längenstaffel (siehe)
GrossWeight | 1 | 1 | ü | decimal(2) | Gesamtgewicht inkl. Tara
Data | 1 | 1 | ü | . | Liste der Informationen zum Status

Legende

zurück


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Knoten Data

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Data":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Data | 1 | n | ü | . | Information zum Status

Legende

zurück


IMS_CI_Schemas.IMS_CI_SO_V1_0_9_5 - Knoten Data1
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "Data":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
Code | 1 | 1 | ü | string | Code (siehe Definitionen)
Value | 1 | 1 | ü | string | Wert
Text | 0 | 1 |  | string | Weitere Informationen (siehe Definitionen)

Legende

zurück

Siehe auch

Legenden
Legende Status-Codes


XML Vorlage

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Inhalt des Knoten "xxx":

Knoten/Feld/Attribut | min | max | Pflicht | Format | Beschreibung
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .
. | . | . |  | . | .

Inhalt | Beschreibung
. | .
. | .
. | .

Legende

zurück zum übergeordneten Knoten


Legende - Field-Code "net" (Nettobetrag)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "net":

Value

Text

 Beschreibung verwendet bei Status-Code
Nettowert

Währungscode

Nettowert des Auftrags für alle bereits bekannten Leistungen

Format: XML decimal (siehe)

Im Zuge der weiteren Verarbeitung können zusätzlcihe Nebenspesen (z.B.: Terminalleistungen, Zuschläge, ...) anfallen.
205
Nettowert

Währungscode

Nettowert einer zusätzlichen Leistung

Format: XML decimal (siehe)

 206

Siehe auch

Legende Status-Codes


Legende - Field-Code "PoD" (Abgangshafen)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "PoD":

Value | Text | Beschreibung | verwendet bei Status-Code
UNLoCode | Name des Hafens | Abgangshafen | 205,

Siehe auch

Legende Status-Codes


Legende - Field-Code "PoA" (Ankunftshafen)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "PoA":

Value | Text | Beschreibung | verwendet bei Status-Code
UNLoCode | Name des Hafens | Abgangshafen | 205,

Siehe auch

Legende Status-Codes


Legende - Field-Code "notes" (Notizen/Informationen)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "notes":

Value | Text | Beschreibung | verwendet bei Status-Code
<Notizen> | . | Zusätzliche Informationen, Notizen, Hinweise zum Status | 205, 206, 212, 213, 214, 215, 216, 217, 219

Siehe auch

Legende Status-Codes


Legende - Field-Code "service" (Leistung)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "service":

Value | Text | Beschreibung | verwendet bei Status-Code
<Serice name> | . | Beschreibung der erbrachten Leistung | 206

Siehe auch

Legende Status-Codes


Legende - Field-Code "company" (Firma der IMS Gruppe)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "company":

Value | Text | Beschreibung | verwendet bei Status-Code
<Company shortcut> | Name der IMS Firma | verantwortliche Firma innerhalb der IMS Firmengruppe (Liste) | 206

Siehe auch

Firmen der IMS Firmengruppe
Legende Status-Codes


Legende - Field-Code "containerno" (Containernummer)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "containerno":

Value | Text | Beschreibung | verwendet bei Status-Code
<Container number> | . | 11-stellige Containernummer | 207

Siehe auch

Legende Status-Codes


Legende - Field-Code "sealno" (Siegelnummer)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "sealno":

Value | Text | Beschreibung | verwendet bei Status-Code
<Siegelnummer> | . | neu zugeordnete Siegelnummer des Containers | 208

Siehe auch

Legende Status-Codes


Legende - Field-Code "DoD" (Datum Abfahrt)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "DoD":

Value | Text | Beschreibung | verwendet bei Status-Code
Datum | . | Datum der Abfahrt (ohne Angabe der Uhrzeit) Format: XML date (siehe) | 212, 213, 214, 215, 216, 217

Siehe auch

Legende Status-Codes


Legende - Field-Code "DToD" (Datum und Uhrzeit Abfahrt)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "DToD":

Value | Text | Beschreibung | verwendet bei Status-Code
Datum und Uhrzeit | . | Datum und Uhrzeit der Abfahrt Format: XML date (siehe) | 219, 221

Siehe auch

Legende Status-Codes
Legende zur XML Schemata Beschreibung


Legende - Field-Code "DoA" (Datum Ankunft)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "DoA":

Value | Text | Beschreibung | verwendet bei Status-Code
Datum | . | Datum der Ankunft (ohne Angabe der Uhrzeit) Format: XML date (siehe) | 212, 213

Siehe auch

Legende Status-Codes


Legende - Field-Code "DToA" (Datum und Uhrzeit Ankunft))
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "DToA":

Value | Text | Beschreibung | verwendet bei Status-Code
Datum und Uhrzeit | . | Datum und Uhrzeit der Ankunft Format: XML date (siehe) | 216, 217, 220

Siehe auch

Legende Status-Codes
Legende zur XML Schemata Beschreibung


Legende - Field-Code "ship" (Schiffsname)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "ship":

Value | Text | Beschreibung | verwendet bei Status-Code
<Schiffsname> | . | Name des Schiffs | 212

Siehe auch

Legende Status-Codes


Legende - Field-Code "carrier" (Reeder)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "ship":

Value | Text | Beschreibung | verwendet bei Status-Code
SCA-Code | Name des Reeders | SCA Code und Name des Reeders | 212

Siehe auch

Legende Status-Codes


Legende - Field-Code "SoA" (Empfangsbahnhof)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "SoA":

Value | Text | Beschreibung | verwendet bei Status-Code
IBNR Bahnhofsnummer | Name des Bahnhofs | IBNR des Empfangsbahnhofs | 212, 213, 216, 217, 221

Siehe auch

Legende Status-Codes


Legende - Field-Code "ToA" (AGL Ankunft)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "ToA":

Value | Text | Beschreibung | verwendet bei Status-Code
<Name des AGL> | . | Bezeichnung des AGL am Empfangsbahnhof | 212, 213, 216, 217, 221

Siehe auch

Legende Status-Codes


Legende - Field-Code "SoD" (Abgangsbahnhof)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "SoD":

Value | Text | Beschreibung | verwendet bei Status-Code
IBNR Bahnhofsnummer | Name des Bahnhofs | IBNR des Abgangssbahnhofs | 216, 217, 220

Siehe auch

Legende Status-Codes


Legende - Field-Code "ToD" (AGL Abfahrt)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "ToD":

Value | Text | Beschreibung | verwendet bei Status-Code
<Name des AGL> | . | Bezeichnung des AGL am Abgangsbahnhof | 216, 217, 220

Siehe auch

Legende Status-Codes


Legende - Field-Code "wagon" (Wagennummer)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "wagon":

Value | Text | Beschreibung | verwendet bei Status-Code
<Wagennummer> | . | Wagennummer | 216, 217

Siehe auch

Legende Status-Codes


Legende - Field-Code "invoiceID" (Rechnungsnummer)
Siehe auch Sende Feedback

Glossary Item Box

Alle anzeigen Alle anzeigen
Alles zusammenklappen Alles zusammenklappen

Feldcode "service":

Value | Text | Beschreibung | verwendet bei Status-Code
<Invoice ID> | . | Rechnungsnummer der avisierten Rechnung | 218

Siehe auch

Legende Status-Codes